LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 02-22-2007, 11:00 AM   #1
SentralOrigin
Member
 
Registered: Jul 2005
Distribution: Gentoo, Ubuntu
Posts: 318

Rep: Reputation: 30
GRUB Error (wrong 'root=' format)


I am on my last step to installing Gentoo, but I get a GRUB error when I try to boot:

Code:
VFS: Cannot open root device "hda3" or unknown-block(0,0)
Please append a correct "root=" boot option
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)
This is what my current /boot/grub/grub.conf looks like:

Code:
default 0
timeout 2
title=Linux
root (hd0,0)
kernel /boot/linux-2.6.17.13 root=/dev/hda3

Yes I made sure that was the correct kernel name in the correct directory. Partition 1 is my boot, 2 is my swap, and 3 is my root. I installed GRUB to partition 1 where the /boot is. I formatted corectly and everything. I did this before, and I remember getting this very same error, but I don't remember what I did to GRUB to fix it. I didn't make changes to anything else, I think.
 
Old 02-22-2007, 11:30 AM   #2
reddazz
Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 73
What device node are you using as your root partition? As it is you have set two different device nodes hd0,0 (which is hda1) and hda3.
 
Old 02-22-2007, 11:39 AM   #3
SentralOrigin
Member
 
Registered: Jul 2005
Distribution: Gentoo, Ubuntu
Posts: 318

Original Poster
Rep: Reputation: 30
This is my /etc/fstab:

Code:
/dev/hda1 /boot ext3 defaults,noatime 1 2
/dev/hda3 / ext3 noatime 0 1
/dev/hda2 none swap sw 0 0
So I guess hd0,0 is hda1
And hd0,2 is hda3

Last edited by SentralOrigin; 02-22-2007 at 12:11 PM.
 
Old 02-22-2007, 11:44 AM   #4
reddazz
Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 73
Yes, hda3 is hd0,2.
 
Old 02-22-2007, 11:44 AM   #5
Gethyn
Member
 
Registered: Aug 2003
Location: UK
Distribution: (X)Ubuntu 10.04/10.10, Debian 5, CentOS 5
Posts: 900

Rep: Reputation: 32
Is there a symlink in /boot pointing to itself? I seem to remember that Gentoo puts it there by default, but if it's missing then the final line of your grub.conf is wrong.

Probably this is a stupid question, but it has to be asked: did you compile ext3 support into your kernel? (not as a module)

Also, there appears to be an error in the first line of your fstab as posted above: it should be ext3, not /ext3.
 
Old 02-22-2007, 11:45 AM   #6
SentralOrigin
Member
 
Registered: Jul 2005
Distribution: Gentoo, Ubuntu
Posts: 318

Original Poster
Rep: Reputation: 30
What settings should I change then?

Yes, in /boot there is a directory called /boot which goes back to itself.
Yes I compiled it with a *, not an M
Oh I typed it in wrong. There is no more / in the first line. Since I can't copy paste from another computer. Just a typo

Last edited by SentralOrigin; 02-22-2007 at 12:09 PM.
 
Old 02-22-2007, 12:41 PM   #7
SentralOrigin
Member
 
Registered: Jul 2005
Distribution: Gentoo, Ubuntu
Posts: 318

Original Poster
Rep: Reputation: 30
/boot/grub/device.map
Code:
(fd0) /dev/fd0
(hd0) /dev/hda
 
Old 02-25-2007, 02:44 PM   #8
aa085564
LQ Newbie
 
Registered: Apr 2006
Posts: 2

Rep: Reputation: 0
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)

I had the same issue on my system running FC5, however the problem manifested without
an upgrade attempt.

The problem ended up being a bad SDRAM module. I was running 2GB, 1024x2.

A memory test revealed sever errors on one of the modules. I removed it and the problem went away.

It may be worth running a memory test on your system. If you don't have a utility, the SUSE 10 boot cd or dvd has a built in memory tester.

Hope this helps.

CG



Quote:
Originally Posted by SentralOrigin
I am on my last step to installing Gentoo, but I get a GRUB error when I try to boot:

Code:
VFS: Cannot open root device "hda3" or unknown-block(0,0)
Please append a correct "root=" boot option
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)
This is what my current /boot/grub/grub.conf looks like:

Code:
default 0
timeout 2
title=Linux
root (hd0,0)
kernel /boot/linux-2.6.17.13 root=/dev/hda3

Yes I made sure that was the correct kernel name in the correct directory. Partition 1 is my boot, 2 is my swap, and 3 is my root. I installed GRUB to partition 1 where the /boot is. I formatted corectly and everything. I did this before, and I remember getting this very same error, but I don't remember what I did to GRUB to fix it. I didn't make changes to anything else, I think.
 
Old 02-25-2007, 03:00 PM   #9
saikee
Senior Member
 
Registered: Sep 2005
Location: Newcastle upon Tyne UK
Distribution: Any free distro.
Posts: 3,398
Blog Entries: 1

Rep: Reputation: 112Reputation: 112
I am just curious as I don't use my Gentoo very much.

The menu.lst seem to miss out the ramdisk file, marked red below.

My Gentoo 2006.1 has the following entries in menu.lst
Code:
title Gentoo Linux
	root (hd1,39)
	kernel /boot/kernel-genkernel-x86-2.6.17-gentoo-r7 root=/dev/ram0 init=/linuxrc ramdisk=8192 real_root=/dev/hdc40
	initrd /boot/initramfs-genkernel-x86-2.6.17-gentoo-r7
 
Old 02-25-2007, 03:11 PM   #10
dxqcanada
Member
 
Registered: Sep 2006
Location: Canada
Distribution: Gentoo
Posts: 702

Rep: Reputation: 43
Make sure you are actually looking at your /boot partition.

By default the /boot partion is not auto mounted ... and must be manually mounted.


Run mount ... if you do not see /dev/hda1 then you are not viewing your real /boot directory.
 
Old 02-25-2007, 03:19 PM   #11
Emerson
Senior Member
 
Registered: Nov 2004
Location: Saint Amant, Acadiana
Distribution: Gentoo ~
Posts: 3,177

Rep: Reputation: Disabled
VFS: Cannot open root device "hda3" or unknown-block(0,0)

This error usually indicates kernel is unable to cope with your HDD controller. Missing SATA chipset driver, missing SCSI support.

Edit: I see now you have IDE, so it's missing IDE controller support.

Last edited by Emerson; 02-25-2007 at 03:20 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Lost root partition grub error 17 qplumb Linux - Newbie 1 02-28-2006 12:31 PM
grub, fedora, ubuntu and wrong root? hometoast Ubuntu 1 06-10-2005 11:29 PM
svgalib module - wrong format lukebeales Linux - Software 2 08-27-2004 09:34 AM
kernel 2.6.3 compile ends in grub error 13: unsupported executable format(?) browny_amiga Linux - General 4 03-06-2004 02:33 PM
the format of the date in stat in wrong rhuser Programming 9 03-16-2003 12:46 PM


All times are GMT -5. The time now is 03:37 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration