LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 09-27-2006, 03:48 PM   #1
MarkMark
LQ Newbie
 
Registered: Sep 2006
Posts: 7

Rep: Reputation: 0
grub error - "Linux kernal must be loaded before initrd"


Hi folks,

I've done a search in posts & FAQ for help on this... there are plenty of similar questions, but none that quite match my situation.

"Error 19: Linux kernel must be loaded before initrd"

I'm trying to configure a second linux OS on my PC and have installed it on an a logical ext2 partion in my extended partition.

Having gained some insight into GRUB configuration, I cant seem to come up with the correct declaration in my /boot/grub/menu.lst


In my primary partitions, I've got:
(hd0,0) for my windows (ok)
(hd0,3) for my knoppix (ok)

The new PCLinuxOx, is already installed & ready to boot in an extended logical partition (hd0,4)

However, telling my grub where it is is fine, but getting it to boot there is not :-(




Here's what I've got in that grub-menu file...


### KNOPPIX... working
title Debian GNU/Linux, kernel 2.6.16-beyond4.1 Default
root (hd0,3)
kernel /boot/vmlinuz root=/dev/hda4 ro ramdisk_size=100000 lang=us apm=power-off nomce vga=791
initrd /boot/initrd.img
savedefault
boot

### Windows XP... working
title Windows 2K/XP/2003 (hda1)
chainloader (hd0,0)+1

### PCLINUXOS .... fails to boot
title PCLinuxOS
root (hd0,4)
kernal /boot/vmlinuz root=/dev/hda5 ro ramdisk_size=100000 lang=us apm=power-off nomce
initrd /boot/initrd.img
savedefault
boot

please note.... the files really do exist in the logical partition, but I'm just guessing those kernel parameters for vmlinuz, by copying from the knoppix entry

Thanks in advance for any suggestions or advice,

Regards

Mark

Last edited by MarkMark; 09-27-2006 at 03:49 PM.
 
Old 09-27-2006, 05:07 PM   #2
homey
Senior Member
 
Registered: Oct 2003
Posts: 3,057

Rep: Reputation: 56
Mine looks like this.
Code:
title PCLinuxOS
        root (hd0,4)
        kernel /boot/vmlinuz ro root=/dev/hda5
        initrd /boot/initrd.img
 
Old 09-27-2006, 05:38 PM   #3
MarkMark
LQ Newbie
 
Registered: Sep 2006
Posts: 7

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by homey
Mine looks like this.
Code:
title PCLinuxOS
        root (hd0,4)
        kernel /boot/vmlinuz ro root=/dev/hda5
        initrd /boot/initrd.img
Thanks for this!

It doesn't look much different to mine, but I'll give modify and reboot right now.

one question I have in mid is that... are my problems related to the fact that my grub 'belongs' to my Debian primary partiion? Can it be that you cant boot another kernal/partion in the extended/logical area of my disk? I can boot my windows, but that has its own chainloaded primary partition.

<wishes he was a grub-guru>
 
Old 09-27-2006, 05:59 PM   #4
MarkMark
LQ Newbie
 
Registered: Sep 2006
Posts: 7

Original Poster
Rep: Reputation: 0
Well... that was encouraging!

I rebooted & chose the PCLinuxOS from the bootmenu & suddenly lots of kernal messages went flying up the screen.

Until one of them said ...
"Kernal panic! - not synching"
"try passing an init=option into the kernal."

I'm presuming I need to add this (and possibly some other stuff) to my
kernel /boot/vmlinuz ro root=/dev/hda5 in grb-file.

I'll go google about on their site for it

<crosses fingers>

Thanks again, homey... I think I'm getting somewhere
 
Old 09-27-2006, 06:00 PM   #5
homey
Senior Member
 
Registered: Oct 2003
Posts: 3,057

Rep: Reputation: 56
It doesn't matter what Linux OS version has the grub menu and several of my distro installs are on logical partitions.
Windows is best left on the first primary drive, and first partition.

Edit: What version of PCLinux do you have? Did you install it by using the livecd installer?

Last edited by homey; 09-27-2006 at 06:02 PM.
 
Old 09-27-2006, 06:17 PM   #6
MarkMark
LQ Newbie
 
Registered: Sep 2006
Posts: 7

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by homey
It doesn't matter what Linux OS version has the grub menu and several of my distro installs are on logical partitions.
Windows is best left on the first primary drive, and first partition.

Edit: What version of PCLinux do you have? Did you install it by using the livecd installer?
Yes, I did an install using the live CD. I simply put it on a pre-prepared ext2 logigal-part of my extended partion. No grub option, because I already have a working grub thats booting my Knoppix & Windows. I'm hoping I can just add the relevant entries to grub.

PClinuxOS version: p93a- "mini me"
Kernel 2.6.16.17
Grub v0.97
 
Old 09-27-2006, 06:37 PM   #7
homey
Senior Member
 
Registered: Oct 2003
Posts: 3,057

Rep: Reputation: 56
I'm not sure what's wrong then. I let the installer go ahead with the grub part. Then, I switch back to my FC grub after I know the new Linux is working.
 
Old 09-29-2006, 04:50 AM   #8
MarkMark
LQ Newbie
 
Registered: Sep 2006
Posts: 7

Original Poster
Rep: Reputation: 0
I'm still totally stumped by this kernel error...

"Kernel panic! - not synching"
"try passing an init=option into the kernal."

Are there any reference site out there where I can read out the linux kernel options passed in at boot time? init=??

For example, perhaps I could boot it step-by-step with debugging switched on.
 
Old 12-27-2006, 12:05 PM   #9
linuxdavem
LQ Newbie
 
Registered: Dec 2006
Posts: 2

Rep: Reputation: 0
I feel your pain! Im at the same spot you are with that same kernel panic error. Im trying to install PClos over the current "imfedupwith=Fedora6" line atm

1. Load up liveCD
2. Run installer
3. I let the partition program auto setup the partitions (which it now lists are sde1=root, sde6=home)
3a. Does the fact that it set up the partitions as sde /boggle anyone else? I have a 320G internal SATA drive btw.
4. Go through the rest of the install wizard and reboot
5. kernel panic error!
6. reload livecd.
7. repeat install
8. kernel panic error!
9. kick computer and pound keyboard!

Well ok. Omit line 9 above. Anyway, I suspect that whole sde/sda thing above might be an issue. Although I do see alot of posts about this exact issue with just vague suggestions to fix it, including the 5 page thread that was on the pclinuxos forums before the site bit the dust. I dont have any USB devices hooked up (and I seriously doubt that would have anything to do with this kernel error anyway). Has someone found a real fix for this issue? If so, please share the wealth!
 
Old 12-27-2006, 03:20 PM   #10
RHELL
Member
 
Registered: Feb 2004
Location: Outermost mingetty
Distribution: RHEL3,RH4U4,Sol9, Sol10
Posts: 321

Rep: Reputation: 31
You misspelled 'kernel'.

Quote:
kernal /boot/vmlinuz

Last edited by RHELL; 12-27-2006 at 03:21 PM.
 
Old 12-27-2006, 04:58 PM   #11
pixellany
LQ Veteran
 
Registered: Nov 2005
Location: Annapolis, MD
Distribution: Arch/XFCE
Posts: 17,802

Rep: Reputation: 728Reputation: 728Reputation: 728Reputation: 728Reputation: 728Reputation: 728Reputation: 728
Things to try:
  1. make sure everything is spelled correctly (kernel, not kernal)
  2. make sure you are editing the grub config file that matches the grub actually installed. (grub gets hard-coded on installation so that it points to the partition where /boot/grub/menu.lst lives.)
  3. In the grub config file, make sure of the following:

Code:
root (hdX,Y)     --must point to the partition where /boot is mounted
for the OS to be booted, and must be in grub-speak, counting from zero
kernel /boot/vmlinuz---etc root=/dev/hdVW   --here the root statement must
point to the partition where / is mounted.  numbering here starts at "a" and "1". 
 Also, this code is correct only if /boot is on the same partition with /. 
 If it is separate, then the correct code is:
kernel /vmlinuz---etc----etc

Last edited by pixellany; 12-27-2006 at 05:01 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
executing a loaded module returns "command not found" error neelay1 Linux - Software 1 05-08-2006 02:25 PM
Installation error "error informing kernal about modifications..." lexx11 Fedora - Installation 1 01-17-2006 07:07 PM
what does it mean initrd error " no such file or directory" chittico Linux - Newbie 2 08-02-2004 10:12 AM
Error "Kernel version mismatch" when nic driver will be loaded grubjo Linux - Networking 1 10-03-2003 04:12 AM
What is "initrd" in grub.conf? captainstorm Linux - Newbie 2 07-30-2003 04:12 AM


All times are GMT -5. The time now is 06:06 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration