LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
LinkBack Search this Thread
Old 03-03-2007, 12:36 PM   #1
demmylls
Member
 
Registered: Aug 2003
Location: AT
Distribution: Fedora Core 3
Posts: 404

Rep: Reputation: 30
GRUB dualboot XP and Linux Problem


i have IDE Drive at Primary Master slot and a SATA drive at SATA1 slot

i've installed Windows XP on /dev/sda1 (SATA Drive) and then i install Fedora Core 6 at /dev/hda1 (IDE Drive)

In Bios i've set SATA1 slot as my Primary Boot device when installing XP
then when i install FC6 i've set IDE Primary Master slot as my Primary Boot Device

FC6 detected XP and added it to GRUB.
Both XP and FC6 boot up fine.

When i set SATA1 slot at the primary device then i can only boot XP
but when i set IDE Primary Master drive as my primary device in bios i can use GRUB to boot FC6.

The problem starts when i tried to use GRUB to boot XP and it gives me error message
"Missing 'io.sys'"

after that i no longer be able to use the GUI GRUB to boot any of the my OS.
just by selecting XP and press enter in GUI GRUB i no longer be able to boot anymore.

So i have to change my BIOS to SATA1 slot at my primary boot device.

Now everytime i goes into GRUB i will be given GRUB command line interface (grub>)

how do i fix this?

the following is my grub.conf auto generated when i install FC6
Code:
# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE:  You do not have a /boot partition.  This means that
#          all kernel and initrd paths are relative to /, eg.
#          root (hd0,0)
#          kernel /boot/vmlinuz-version ro root=/dev/hda1
#          initrd /boot/initrd-version.img
#boot=/dev/hda
default=0
timeout=5
splashimage=(hd0,0)/boot/grub/splash.xpm.gz
hiddenmenu
title Fedora Core 6 Zod (2.6.18-1.2798.fc6)
	root (hd0,0)
	kernel /boot/vmlinuz-2.6.18-1.2798.fc6 ro root=LABEL=/ rhgb quiet
	initrd /boot/initrd-2.6.18-1.2798.fc6.img
title Windows XP Pro SP2
	rootnoverify (hd2,0)
	chainloader +1
 
Old 03-03-2007, 01:37 PM   #2
Maestro485
Member
 
Registered: Apr 2004
Location: Pittsburgh
Distribution: Slackware
Posts: 136

Rep: Reputation: 16
I think the problem is that when you change the boot device in your BIOS, grub's configuration is no longer accurate. I'm not positive, but it seems like when grub looks for '/dev/hd0' its actually finding the wrong disk because of the new BIOS settings.

As for what to do at the 'grub>' prompt, you can just enter the commands by hand:

root (hd0,0)
kernel /boot/vmlinuz-2.6.18-1.2798.fc6 ro root=LABEL=/ rhgb quiet
initrd /boot/initrd-2.6.18-1.2798.fc6.img

if you're having problems, try setting (hd0,0) to different values such as (hd1,0) or (hd0,1)

Again, I'm somewhat guessing here, but it can't hurt to try.
 
Old 03-03-2007, 01:43 PM   #3
bigrigdriver
LQ Addict
 
Registered: Jul 2002
Location: East Centra Illinois, USA
Distribution: Debian Squeeze
Posts: 5,698

Rep: Reputation: 287Reputation: 287Reputation: 287
Set the ide as primary.

Edit grub.conf to change this:
title Windows XP Pro SP2
rootnoverify (hd2,0)
chainloader +1

to this:
title Windows XP Pro SP2
rootnoverify (hd2,0)
map (hd2,0) (hd0,0)
map (hd0,0) (hd2,0)
makeactive
chainloader +1

You should then be able to boot both Linux and windows via grub.

Last edited by bigrigdriver; 03-03-2007 at 01:47 PM.
 
Old 03-03-2007, 01:52 PM   #4
demmylls
Member
 
Registered: Aug 2003
Location: AT
Distribution: Fedora Core 3
Posts: 404

Original Poster
Rep: Reputation: 30
Quote:
Originally Posted by Maestro485
I think the problem is that when you change the boot device in your BIOS, grub's configuration is no longer accurate. I'm not positive, but it seems like when grub looks for '/dev/hd0' its actually finding the wrong disk because of the new BIOS settings.

As for what to do at the 'grub>' prompt, you can just enter the commands by hand:

root (hd0,0)
kernel /boot/vmlinuz-2.6.18-1.2798.fc6 ro root=LABEL=/ rhgb quiet
initrd /boot/initrd-2.6.18-1.2798.fc6.img

if you're having problems, try setting (hd0,0) to different values such as (hd1,0) or (hd0,1)

Again, I'm somewhat guessing here, but it can't hurt to try.

when i install XP i've set SATA slot 1 to primary HDD
when i install FC6 i've set IDE Primary Master as my primary HDD in BIOS
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
grub for dualboot gawain Slackware 8 01-02-2007 02:09 AM
dualboot two harddrives linux/XP problem loading XP vortex777 Red Hat 1 05-27-2006 09:19 AM
different Problem with your dualboot XP/Linux yoron Linux - Newbie 2 11-13-2005 12:32 PM
grub+dualboot with xp/linux linuxtesting2 Linux - General 5 11-15-2004 11:35 AM
winXP / linux dualboot via GRUB problems r0bman Linux - Software 4 07-20-2004 03:14 PM


All times are GMT -5. The time now is 10:37 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration