LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 01-05-2005, 04:23 AM   #1
UltimatePower
Member
 
Registered: Jul 2004
Posts: 31

Rep: Reputation: 15
Grub, booting problems.


Greetings, i''m using Gentoo.
I've got troubles with booting at gentoo.
The kernel has been compiled with Genkernel
It says as startup:
Kernel Panic: VFS: Unable to mount root fs

I've got these information in grub.conf

default 0
timeout 9
splashimage(hd0,0)grub/slash.xmpf

title=Gentoo Startup
root (hd0,0)
kernel (hd0,0)/kernel-2-6-7-gentoo-r11 root=/dev/sda3
initrd (hd0,0)/initrd-2-4.26-gentoo-r14


I'm sure it's SDA, due vmware simulates only SDA drivers.

I'm very gladd, if this could be fixed somehow.

Last edited by UltimatePower; 01-05-2005 at 04:31 AM.
 
Old 01-05-2005, 04:54 AM   #2
jrtayloriv
Member
 
Registered: Jun 2004
Location: Inland NW, US
Distribution: Ubuntu
Posts: 365
Blog Entries: 1

Rep: Reputation: 44
Your problem might be these two lines.:

kernel (hd0,0)/kernel-2-6-7-gentoo-r11 root=/dev/sda3
initrd (hd0,0)/initrd-2-4.26-gentoo-r14

I believe they should be as follows:

kernel /kernel-2-6-7-gentoo-r11 root=/dev/sda3
initrd /initrd-2-4.26-gentoo-r14

hope this helps,
jrtayloriv
 
Old 01-05-2005, 05:01 AM   #3
UltimatePower
Member
 
Registered: Jul 2004
Posts: 31

Original Poster
Rep: Reputation: 15
Same error
 
Old 01-05-2005, 05:46 AM   #4
oneandoneis2
Senior Member
 
Registered: Nov 2003
Location: London, England
Distribution: Ubuntu
Posts: 1,460

Rep: Reputation: 46
What filesystem are you using on the root partition, and has support for it been compiled into the kernel?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems with Grub/booting [LAG] Evo Linux - General 5 04-03-2005 02:40 PM
Problems booting Windows XP with Grub Amuro-Ray2020 Linux - Newbie 9 09-10-2004 11:49 AM
grub booting problems?? chansen0421 Linux - Newbie 3 07-23-2004 09:15 AM
Booting problems: grub and lilo neri Linux - Newbie 10 05-17-2004 11:17 AM
suse8.1 + grub + ext2fs=>booting problems seawolf Linux - General 15 01-27-2003 09:38 AM


All times are GMT -5. The time now is 08:46 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration