LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices



Reply
 
Search this Thread
Old 03-08-2010, 08:48 AM   #1
amit_pansuria
Member
 
Registered: Sep 2006
Posts: 73

Rep: Reputation: 15
got the error while patching the file using patch command


Hello I m using RHEL 4.7
When follow the below step for patching the file

diff file1 file2 > patchfile.patch

patch -p0 file1 < patchfile.patch

but I got the following error after that

Reversed (or previously applied) patch detected! Assume -R? [n]

I dont know what happen here

Kernel version is:

2.6.9-89.0.20.ELsmp

patch version is:

patch-2.5.4-20

Can any one know what the issue

Regards,
Amit P
 
Old 03-08-2010, 11:25 AM   #2
TB0ne
Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 15,087

Rep: Reputation: 2714Reputation: 2714Reputation: 2714Reputation: 2714Reputation: 2714Reputation: 2714Reputation: 2714Reputation: 2714Reputation: 2714Reputation: 2714Reputation: 2714
Quote:
Originally Posted by amit_pansuria View Post
Hello I m using RHEL 4.7
When follow the below step for patching the file

diff file1 file2 > patchfile.patch

patch -p0 file1 < patchfile.patch

but I got the following error after that

Reversed (or previously applied) patch detected! Assume -R? [n]

I dont know what happen here

Kernel version is:
2.6.9-89.0.20.ELsmp

patch version is:
patch-2.5.4-20

Can any one know what the issue
Yes, RedHat support probably does. Since you're using RHEL, did you call them?

And did you read what you posted? You're running 2.6.9 kernel, and trying to patch it to 2.5.4. Google points out lots of info on this error message, indicating that you're reversing the kernel level.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Patching kernel using patch-o-matic ceco91 Linux - Kernel 2 10-01-2009 06:28 PM
Patching xcdroast with a wav patch fof3 Linux - Software 1 03-04-2008 08:28 PM
problem in installation of gcc3.3.6 and patching its patch files. rahaf Linux - Software 1 06-24-2007 08:19 AM
patching of MPLS patch with kernel-2.4.20-6 priyanka.chandel Linux - Kernel 0 12-15-2006 03:14 AM
rpm error-> patch: command not found Bosnja Linux - Software 5 01-30-2004 01:59 PM


All times are GMT -5. The time now is 12:03 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration