LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - General (http://www.linuxquestions.org/questions/linux-general-1/)
-   -   gmplayer displays one of two error messages depending on whether I'm user or root (http://www.linuxquestions.org/questions/linux-general-1/gmplayer-displays-one-of-two-error-messages-depending-on-whether-im-user-or-root-534534/)

Zim_ 03-04-2007 02:15 PM

gmplayer displays one of two error messages depending on whether I'm user or root
 
Hi

When I try to use gmplayer (as in opening it in nautilus) as user it says
Quote:

Error opening/initializing the selected video_out (-vo) device.
If I open a file with root in nautilus it plays but an error message says
Quote:

New_Face failed. Maybe the font path is wrong. Please supply the text font file (~/.mplayer/subfont.ttf).
If I use mplayer with the command line as user the file opens fine (i.e. mplayer filename). If I open gmplayer with the command line as user I get the "New face..." error message (i.e. gmplayer). If I try to oopen a file with that gmplayer I get the "...video_out..." error message. If I use gmplayer with the command line as user I get the "...video_out..." error message (i.e. gmplayer filename). The gmplayer error messages for root are the "New Face..." messages with mplayer working fine from the command line as it does as a user.

This behaviour started suddenly. I understand that the first message happens when another program is using the video out device, like another mplayer, but I've looked and nothing should be using it. gmplayer, not mplayer, seems to be the problem. But I have no idea why. My skin is the default one so that shouldn't be the problem.

I hope that is a sufficient amount of information. Normally google solves these sorts of problems but I'm lost on this one.

Thanks for any help.

Zim_

drpt 03-04-2007 03:44 PM

.
 
New_Face failed. Maybe the font path is wrong. Please supply the text font file (~/.mplayer/subfont.ttf).

in /<user>/.mplayer you need to make a link to any font of your choosing

and the other error is because the videro output is not right

type " mplayer -vo help" to get a list of the Available video output drivers

pete


All times are GMT -5. The time now is 11:44 PM.