LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 02-26-2006, 09:00 AM   #1
egghead
LQ Newbie
 
Registered: Jan 2006
Distribution: Slackware 9.1
Posts: 23

Rep: Reputation: 15
glibc 2.3.6 - configure: error: compiler support for __thread is required


Hi,
I'm trying to install glibc 2.3.6 on Slackware 9.1, but I'm getting this error:
configure: error: compiler support for __thread is required

I'm also getting this message from configure: checking for __thread... no

What exactly is __thread and where can I get it?

I had tried configure with the following options:
../glibc-2.3.6/configure --enable-add-ons=nptl --with-tls --with-__thread
../glibc-2.3.6/configure --enable-add-ons
../glibc-2.3.6/configure --enable-add-ons=nptl
../glibc-2.3.6/configure --enable-add-ons=nptl --with-__thread

I'm getting the same error in all the above cases.

Last edited by egghead; 02-26-2006 at 09:23 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
error in configure glibc-2.3.4 isilinux Linux - Software 11 07-07-2010 12:04 PM
checking for C compiler default output... configure: error: C compiler cannot create fiorejm Linux - Software 6 11-12-2009 12:35 PM
PPTP Error: MPPE required, but kernel has no support. lennysokol Linux - Software 2 03-22-2009 02:51 PM
./configure error while compiling superkaramba .qt-mt required -=|Man0waR|=- Mandriva 2 02-26-2005 04:10 AM
glibc error with ./configure speel Linux - Distributions 1 08-07-2004 07:57 PM


All times are GMT -5. The time now is 12:28 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration