LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - General (http://www.linuxquestions.org/questions/linux-general-1/)
-   -   Getting fstab to work... (http://www.linuxquestions.org/questions/linux-general-1/getting-fstab-to-work-909662/)

Sweyn78 10-23-2011 09:35 AM

Getting fstab to work...
 
Hello! I just installed Fedora 15 and am editing the fstab file. I have a good idea of what I want from it, and I used the man pages to figure-out what to put. However, it always gets an error that prevents Fedora from starting-up. Nothing big; I can always change the fstab file from a live CD. The thing is, though, that I don't know what all is causing the problem, and I was hoping someone on LQ would.
Here is my fstab:
Code:

#
# /etc/fstab
# Created by Sweyn78 on Sun Oct 23 07:46:11 2011
#
# Accessible filesystems, by reference, are maintained under '/dev/disk'
# See man pages fstab(5), findfs(8), mount(8) and/or blkid(8) for more info
#
UUID=b364b5ca-404d-4139-b804-5b7e10d30ea3    /          ext4        defaults,acl,sync,dirsync,relatime,user_xattr,data=jounrnal                                          1    1
UUID=9d74ca24-e157-485f-88e7-1872339d40ef    /boot      ext2        defaults,acl,relatime                                                                                1    2
/dev/sdb2                                    /tmp        reiserfs    defaults,noexec,nosuid,async,nolog,hash=rupasov,noatime,nodiratime,notail,noborder                    0    0 
UUID=c565f04c-e247-4868-bde9-d988ecd7c2d1    /home        xfs        defaults,acl,sync,dirsync,relatime,user_xattr                                                        1    2
/dev/sda3                                    swap        swap        defaults,pri=1                                                                                        0    0
/dev/sdb6                                    swap        swap        defaults,pri=2                                                                                        0    0
tmpfs                                        /dev/shm    tmpfs      defaults                                                                                              0    0
devpts                                      /dev/pts    devpts      gid=5,mode=620                                                                                        0    0
sysfs                                        /sys        sysfs      defaults                                                                                              0    0
proc                                        /proc      proc        defaults                                                                                              0    0
/dev/sda2                                    /windows    ntfs        defaults,utf8,posix=0                                                                                1    2

Once all the problems are worked-out, I'll add errors=remount-ro; I just don't want to do so before I know that there are no errors.

Thanks greatly in advance! :)

eSelix 10-23-2011 09:50 AM

First, no one known how your disk looks, so "fdisk -l" and "ls -l /dev/disk/by-uuid" will help us. Also you should post your error and logs from booting here. Second I see small error in your root mount "data=jounrnal" - should be "journal".

Sweyn78 10-23-2011 10:19 AM

Ah, Okay...
 
Quote:

Originally Posted by eSelix (Post 4505839)
First, no one known how your disk looks, so "fdisk -l" and "ls -l /dev/disk/by-uuid" will help us. Also you should post your error and logs from booting here. Second I see small error in your root mount "data=jounrnal" - should be "journal".

Bah, I would have missed a typo. I could have sworn I'd fixed them all...

Here's the output for those commands:
Code:

root@PartedMagic:~# fdisk -l

Disk /dev/sda: 1000.2 GB, 1000204886016 bytes
255 heads, 63 sectors/track, 121601 cylinders, total 1953525168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x00046dfb

  Device Boot      Start        End      Blocks  Id  System
/dev/sda1  *        2048      206847      102400    7  HPFS/NTFS/exFAT
/dev/sda2          206848  1937213439  968503296    7  HPFS/NTFS/exFAT
/dev/sda3      1937213440  1953523711    8155136  82  Linux swap

Disk /dev/sdb: 320.1 GB, 320072933376 bytes
255 heads, 63 sectors/track, 38913 cylinders, total 625142448 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x000bdff2

  Device Boot      Start        End      Blocks  Id  System
/dev/sdb1  *          63    1028159      514048+  83  Linux
/dev/sdb2        1028160    7164989    3068415  83  Linux
/dev/sdb3        7164990    68597549    30716280  83  Linux
/dev/sdb4        68597550  625142447  278272449    5  Extended
/dev/sdb5        68597613  616751414  274076901  83  Linux
/dev/sdb6      616753463  625142447    4194492+  82  Linux swap
root@PartedMagic:~# ls -l
total 1
drwxr-xr-x    2 root    root          175 Apr 26 16:14 Desktop/
drwxr-xr-x    2 root    root            3 Oct  4  2008 Network_Settings/
drwxr-xr-x    2 root    root            99 Mar 21  2011 clamav/
lrwxrwxrwx    1 root    root            6 Apr 25 03:05 media -> /media/
-rw-r--r--    1 root    root          804 Jan 23  2011 readme.txt

I'm going to fix that typo and see if it works now. :)

EDIT: It still isn't mounting everything, but it went to emergency mode (it didn't before) and my root password worked, so I'll assume that the / partition was mounted successfully (though, I could be wrong).

eSelix 10-23-2011 10:57 AM

If you have emergency mode check your /etc/fstab if it is yours and then type
Code:

mount -av
You should get errors on the screen.

Sweyn78 10-23-2011 11:13 AM

Quote:

Originally Posted by eSelix (Post 4505864)
If you have emergency mode check your /etc/fstab if it is yours and then type
Code:

mount -av
You should get errors on the screen.

Alright, I've booted-up into emergency-mode. I pressed control+D, and it said that BOOT was clean (per fsck); it encountered problems upon trying to mount the XFS (/home).
I then entered your suggestion, got some errors recommending me to type-in "dmesg | tail", and followed the error-messages' advice.

Here are the problems all that gave me:

hash=rupasov is an unknown mount-option
acl is an unknown mount-option for XFS
tmp.mount entered a failed state,

The general consensus amongst the errors is that the XFS is the biggest problem. I'll go attempt to fix this now.
____________________________________________________________________________________________________

I've made some changes to fstab. It's now saying that sdb2/5 are having problems.
sdb2: it wouldn't specify the problem.
sdb5: user_xattr is unknown mount-option
I'll correct them.
____________________________________________________________________________________________________

I've made all the corrections and commented-out the /tmp one. It booted-up just fine. I'm going to try it with /tmp, now...
____________________________________________________________________________________________________

It booted-up with /tmp, but /tmp didn't mount correctly.
At least I don't have to use a live CD anymore. :P


All times are GMT -5. The time now is 06:18 PM.