LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices



Reply
 
Search this Thread
Old 01-30-2006, 12:46 AM   #1
procfs
Member
 
Registered: Jan 2006
Location: Sri Lanka
Posts: 507

Rep: Reputation: 34
get this error when runnign make ***** "no rule to make target 'config'. stop"


I am new to linex. Have a machine with RedHat 8 and when I run make menuconfig/xconfig/ etc he gives me this "o rule to make target 'config'. stop"

can enybody help me with this how to get over this

Thank you

Kind regards

Asanka
 
Old 01-30-2006, 01:01 AM   #2
paulsm4
Guru
 
Registered: Mar 2004
Distribution: SusE 8.2
Posts: 5,863
Blog Entries: 1

Rep: Reputation: Disabled
Hi -

Please try this:

1. "cd" into the directory in question
2. Run
./configure

If that doesn't help, please:
3. Specify exactly what program you're trying to build

4. Cut and paste the exact command you're running, and the
first few lines of the specific error message you're getting

'Hope that helps .. PSM
 
Old 01-30-2006, 02:19 AM   #3
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Rep: Reputation: Disabled
Quote:
Originally Posted by paulsm4
3. Specify exactly what program you're trying to build
Looks like a new kernel, since he/she is using "make menuconfig" or "make xconfig".

asankacgl, I don't know how to solve your problem, but why are you using Red Hat 8?? Try something newer, as RH 8 is ancient and you won't get support from Red Hat for it.
 
Old 01-31-2006, 04:32 AM   #4
procfs
Member
 
Registered: Jan 2006
Location: Sri Lanka
Posts: 507

Original Poster
Rep: Reputation: 34
Hay guis its ok I found the answer in here it seems I have to run the command from /usr/src/linuxx.x.x.x.x fot it to run

Thanks you

Kind regards

Asanka
 
1 members found this post helpful.
Old 05-12-2013, 11:25 AM   #5
asifmdalam1987
LQ Newbie
 
Registered: May 2013
Posts: 4

Rep: Reputation: Disabled
make cmd

Quote:
Originally Posted by procfs View Post
Hay guis its ok I found the answer in here it seems I have to run the command from /usr/src/linuxx.x.x.x.x fot it to run

Thanks you

Kind regards

Asanka
thanks Asanka it's also help me too
md asif
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Help with Installation. "No rule to make target.." Aries311 Linux - Software 2 07-02-2005 04:47 PM
make: *** No rule to make target 'gconfig'. Stop. cswake Slackware 4 10-10-2004 01:13 PM
Error "make: *** No rule to make target `install'. Stop." help Ohmn Mandriva 8 07-02-2004 08:02 PM
Error: *** No rule to make target 'all'. Stop aa2bi Linux - Newbie 6 06-08-2004 01:55 PM
*** No rule to make target `modules'. Stop. kmack2001 Linux - Newbie 9 02-16-2004 02:02 PM


All times are GMT -5. The time now is 05:34 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration