LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - General (http://www.linuxquestions.org/questions/linux-general-1/)
-   -   get rid of "printk: # messages suppressed" message (http://www.linuxquestions.org/questions/linux-general-1/get-rid-of-printk-messages-suppressed-message-511702/)

android6011 12-18-2006 03:48 PM

get rid of "printk: # messages suppressed" message
 
I hate that alert that I keep getting when in a terminal. When ever I try to type or use nano those message fill the window and mess everything up. how do i stop them? thanks

introuble 12-19-2006 03:47 AM

Check out /etc/syslog.conf; see which messages are sent to "all", change it as you wish [perhaps redirect them to a file/tty etc.]

nx5000 12-19-2006 03:56 AM

Or if you want to remove everything from the console:
Quote:

# /etc/sysctl.conf - Configuration file for setting system variables
# See sysctl.conf (5) for information.
#

#kernel.domainname = example.com
#net/ipv4/icmp_echo_ignore_broadcasts=1

# Uncomment the following to stop low-level messages on console
#kernel.printk = 4 4 1 7

sheryco 12-21-2006 06:49 AM

i believe to prevent messages to printed on the console you should uncomment this line per nx5000
Quote:

#kernel.printk = 4 4 1 7
to
Quote:

kernel.printk = 4 4 1 7
You could also use 3 4 17 if you want once you have edited the /etc/sysctl.conf run
Quote:

#/sbin/sysctl -p

amarknm 10-04-2010 06:37 AM

some times prink throws messages in the /var/log/messages

you can grep using $cat /var/log/messages | grep "your message"

Thanks,
Amar


All times are GMT -5. The time now is 07:55 PM.