LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices



Reply
 
Search this Thread
Old 06-08-2005, 06:17 PM   #1
dsschanze
Member
 
Registered: Aug 2004
Location: Gainesville, FL
Distribution: Linux Mint 12, Win7, iOS
Posts: 206

Rep: Reputation: 32
get out of twm in vnc?


Hi,
I have never had this problem before on my RH9 machines, but when I started vncserver on my RHEL machine and logged in to it, I only see twm. On my RH9 machine I had to do no configuring to get gnome to work in vnc, so is there some configuration file that I need to access to tell vnc to use gnome instead of twm?

-Derek
 
Old 06-08-2005, 10:42 PM   #2
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,791
Blog Entries: 1

Rep: Reputation: 414Reputation: 414Reputation: 414Reputation: 414Reputation: 414
You need to edit your ~/.vnc/xstartup file to start the X environment you want.
 
Old 06-08-2005, 11:38 PM   #3
dsschanze
Member
 
Registered: Aug 2004
Location: Gainesville, FL
Distribution: Linux Mint 12, Win7, iOS
Posts: 206

Original Poster
Rep: Reputation: 32
Here is my xstartup file. Where do I need to specify the path or the desktop to start?

Code:
#!/bin/sh

# Uncomment the following two lines for normal desktop:
# unset SESSION_MANAGER
# exec /etc/X11/xinit/xinitrc

[ -x /etc/vnc/xstartup ] && exec /etc/vnc/xstartup
[ -r $HOME/.Xresources ] && xrdb $HOME/.Xresources
xsetroot -solid grey
vncconfig -iconic &
xterm -geometry 80x24+10+10 -ls -title "$VNCDESKTOP Desktop" &
twm &
 
Old 06-09-2005, 12:12 PM   #4
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,791
Blog Entries: 1

Rep: Reputation: 414Reputation: 414Reputation: 414Reputation: 414Reputation: 414
Quote:
twm &
That is the command that is starting twm, so comment that out and add gnome-session & in its place
 
Old 06-09-2005, 05:46 PM   #5
dsschanze
Member
 
Registered: Aug 2004
Location: Gainesville, FL
Distribution: Linux Mint 12, Win7, iOS
Posts: 206

Original Poster
Rep: Reputation: 32
Question

Ok...here is my config file:
Code:
#!/bin/sh

# Uncomment the following two lines for normal desktop:
# unset SESSION_MANAGER
# exec /etc/X11/xinit/xinitrc

[ -x /etc/vnc/xstartup ] && exec /etc/vnc/xstartup
[ -r $HOME/.Xresources ] && xrdb $HOME/.Xresources
xsetroot -solid grey
vncconfig -iconic &
xterm -geometry 80x24+10+10 -ls -title "$VNCDESKTOP Desktop" &
gnome-session &
I have "gnome-session &" into where "twm &" was and it is now giving me this failsafe type view. Here is a screenshot of it http://dssdirectory.cjb.net/directory/vnc-error/vnc.png. Do you know what is wrong now?
 
Old 06-10-2005, 08:27 AM   #6
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,791
Blog Entries: 1

Rep: Reputation: 414Reputation: 414Reputation: 414Reputation: 414Reputation: 414
That looks an awful lot like twm. Are you sure you edited the right xstartup file? You have to edit the file in the home/.vnc directory of the user starting VNC. What I mean is that if you edit the xstartup file for user1, but then user2 starts vncserver, vnc will use user2's settings.
 
Old 06-10-2005, 08:31 AM   #7
ethics
Senior Member
 
Registered: Apr 2005
Location: London
Distribution: Arch - Latest
Posts: 1,522

Rep: Reputation: 45
looks like my default gnome desktop when i installed FC3 :P what about gnome & ?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
I get a TWM session with VNC instead of Gnome paul.nel Linux - General 1 02-27-2005 03:00 PM
Twm ! Cdzin Slackware 1 07-30-2003 02:51 PM
Uh oh, TWM? orange400 Linux - General 3 03-26-2003 09:18 PM
Help with TWM. jake Linux - General 0 01-21-2002 07:12 AM
Twm Mimician Linux - Newbie 2 12-03-2001 06:08 AM


All times are GMT -5. The time now is 04:03 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration