LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - General (http://www.linuxquestions.org/questions/linux-general-1/)
-   -   Gentoo NVIDIA error (http://www.linuxquestions.org/questions/linux-general-1/gentoo-nvidia-error-101511/)

dalek 10-08-2003 01:28 AM

Gentoo NVIDIA error
 
I have been working on the NVIDIA driver for a while now. I tried to follow the how to and done some searches and no luck.

After emergeing glx and kernel and I do the modprobe I get this boo boo message:

bash-2.05b# modprobe nvidia
/lib/modules/2.4.20-gentoo-r5/video/nvidia.o: unresolved symbol highmem_start_page
/lib/modules/2.4.20-gentoo-r5/video/nvidia.o: unresolved symbol kmap_prot
/lib/modules/2.4.20-gentoo-r5/video/nvidia.o: unresolved symbol kmap_pte
/lib/modules/2.4.20-gentoo-r5/video/nvidia.o:
Hint: You are trying to load a module without a GPL compatible license
and it has unresolved symbols. Contact the module supplier for
assistance, only they can help you.

/lib/modules/2.4.20-gentoo-r5/video/nvidia.o: insmod /lib/modules/2.4.20-gentoo-r5/video/nvidia.o failed
/lib/modules/2.4.20-gentoo-r5/video/nvidia.o: insmod nvidia failed
bash-2.05b#

Anybody seen this before? What did I do wrong?

I did get the freakin modem to work though. :D :D

Any ideas? :Pengy: :Pengy:

Thanks.

:D :D :D :D

unSpawn 10-15-2003 07:26 PM

Rebuilding the driver for your new kernel should fix any unresolved symbols messages.

dalek 10-15-2003 09:31 PM

Ok? I did this install from the CD. NO internet stuff. Shouldn't it all be the same version? If not how do I rebuild the kernel? NVIDIA kernel I'm assuming? Me a bit :confused: . Something is wrong. I probably did it too. :rolleyes:

Get me started maybe?

Is that the emerge nividia-kernel thingy that needs to be updated?

Let me know. Kind of new to Gentoo. I like it though. It is really nice looking.

Thanks for the help.

:D :D :D :D


All times are GMT -5. The time now is 07:21 AM.