LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 03-05-2003, 12:07 AM   #1
ReasonPointZero
LQ Newbie
 
Registered: Mar 2003
Posts: 8

Rep: Reputation: 0
GDM, WM's Don't work. Only KDE


this is a Mandrake 9.0 system.

I installed my nvidia drivers by rpm for a GEforce3 ti200

after that my kde takes about 5 minutes to load up....it stays black until the nvidia splash screen then it loads up decently quick.

When I reboot I cant get into the gdm it just keeps flashing black then every 3 minutes or so flashes the nvidia splash then starts over.

I dont know where to check for errors and what not but help is definitly appreciate any help.

http://www.justlinux.com/forum/show...&threadid=92170

that link may have some other needed info to help.... it was my problems getting the nvidia drivers to work. Plus a logged error message at the end.

Thanks
Greg
 
Old 03-05-2003, 01:11 AM   #2
rch
Member
 
Registered: Feb 2003
Location: Santa Clara,CA
Distribution: Mandriva
Posts: 909

Rep: Reputation: 48
Re: GDM, WM's Don't work. Only KDE

Quote:
Originally posted by ReasonPointZero
this is a Mandrake 9.0 system.

I installed my nvidia drivers by rpm for a GEforce3 ti200

after that my kde takes about 5 minutes to load up....it stays black until the nvidia splash screen then it loads up decently quick.

When I reboot I cant get into the gdm it just keeps flashing black then every 3 minutes or so flashes the nvidia splash then starts over.

I dont know where to check for errors and what not but help is definitly appreciate any help.

http://www.justlinux.com/forum/show...&threadid=92170

that link may have some other needed info to help.... it was my problems getting the nvidia drivers to work. Plus a logged error message at the end.

Thanks
Greg
make necessary changes in /etc/X11/XFree86-4 file
read the documenation (for howto)
you can also use Xconfigurator
to choose another driver
 
Old 03-05-2003, 01:17 AM   #3
ReasonPointZero
LQ Newbie
 
Registered: Mar 2003
Posts: 8

Original Poster
Rep: Reputation: 0
I did make the necessary changes...

I did do the documentation....

My KDE starts up, I am in it now... so technically it is working.

Im probably wrong about this because im a Semi-Newb but I dont think Mandrake uses Xconfigurator, isnt that redhat?

And as for the last part, I dont think I want to use another driver... I thnk I want to stick with the nvidia driver on this.

thanks for the reply.
-g
 
Old 03-05-2003, 01:30 AM   #4
rch
Member
 
Registered: Feb 2003
Location: Santa Clara,CA
Distribution: Mandriva
Posts: 909

Rep: Reputation: 48
Quote:
Originally posted by ReasonPointZero
I did make the necessary changes...

I did do the documentation....

My KDE starts up, I am in it now... so technically it is working.

Im probably wrong about this because im a Semi-Newb but I dont think Mandrake uses Xconfigurator, isnt that redhat?

And as for the last part, I dont think I want to use another driver... I thnk I want to stick with the nvidia driver on this.

thanks for the reply.
-g
sorry i should be kicked in the ass not looking at your distribution
instead of Xconfigurator
try mcc
 
Old 03-05-2003, 01:33 AM   #5
ReasonPointZero
LQ Newbie
 
Registered: Mar 2003
Posts: 8

Original Poster
Rep: Reputation: 0
i dont think thats the problem tho....

Im in Mandrake, I can run the control center if need be.... but my driver is in fine.... 2d works well and games play opengl like a charm....

:shrug:

i think we must go deeper for this solution.

 
Old 03-05-2003, 01:38 AM   #6
rch
Member
 
Registered: Feb 2003
Location: Santa Clara,CA
Distribution: Mandriva
Posts: 909

Rep: Reputation: 48
ok ! so what is the solution you were looking into
was it about the 5 minutes starting time!!!
 
Old 03-05-2003, 01:48 AM   #7
ReasonPointZero
LQ Newbie
 
Registered: Mar 2003
Posts: 8

Original Poster
Rep: Reputation: 0
yea...

and since i use flux box and not kde i would like to be able to boot into it.... which now i cannot.
 
Old 03-05-2003, 02:06 AM   #8
rch
Member
 
Registered: Feb 2003
Location: Santa Clara,CA
Distribution: Mandriva
Posts: 909

Rep: Reputation: 48
well :boot into it:
are you using runlevel 5
and check your XFree log once
/var/log/XFree-....
and the link above did not worked
 
Old 03-05-2003, 02:07 AM   #9
rch
Member
 
Registered: Feb 2003
Location: Santa Clara,CA
Distribution: Mandriva
Posts: 909

Rep: Reputation: 48
are you using runlevel 5?
and check your XFree log once
/var/log/XFree-....
and the link above did not worked
 
Old 03-05-2003, 02:19 AM   #10
ReasonPointZero
LQ Newbie
 
Registered: Mar 2003
Posts: 8

Original Poster
Rep: Reputation: 0
okiedoke

sorry bout the link



http://www.justlinux.com/forum/showt...threadid=92170

here are my two XFree86 logs

http://www.thefuse.net/XFlogs/XFree86.9.log
http://www.thefuse.net/XFlogs/XFree86.0.log

one is XFree86.0.log
two is XFree86.9.log

whats the difference....

could my timing out be all those resolution errors in the .9.log?
 
Old 03-05-2003, 02:25 AM   #11
ReasonPointZero
LQ Newbie
 
Registered: Mar 2003
Posts: 8

Original Poster
Rep: Reputation: 0
/ok after some further testing, ,this is most definitly the problem....

when i did a simple resolution test in harddrake it took about 3 minutes to change resolutions and change back....

how can i remove these and could this explain my fluxbox problems?

-g
 
Old 03-05-2003, 02:27 AM   #12
ReasonPointZero
LQ Newbie
 
Registered: Mar 2003
Posts: 8

Original Poster
Rep: Reputation: 0
and also... what in the world would cause these to change so slowly?!?!?!
 
Old 03-05-2003, 02:37 AM   #13
rch
Member
 
Registered: Feb 2003
Location: Santa Clara,CA
Distribution: Mandriva
Posts: 909

Rep: Reputation: 48
In XFree.n.log n specifies the display number of the X server
usually 0
you have used two config files "/etc/X11/XF86Config-4"
and "/etc/X11/XF86Config.test" so the two displays
i will check out your log file and will tell you what i think
wait a while
 
Old 03-05-2003, 02:40 AM   #14
ReasonPointZero
LQ Newbie
 
Registered: Mar 2003
Posts: 8

Original Poster
Rep: Reputation: 0
standing by


i like this quick reply chit
 
Old 03-05-2003, 03:14 AM   #15
rch
Member
 
Registered: Feb 2003
Location: Santa Clara,CA
Distribution: Mandriva
Posts: 909

Rep: Reputation: 48
Well you got lucky today
I don't think you can get a quick reply everyday
1.First don't use runlevel 5
instead use runlevel 3
to do this
edit the /etc/inittab file
beside the id it should be 5 so change it to 3
id:3:initdefault:
2.also disable apm(if the first did not worked)
by appending boot parameter apm=no to your current config
3.if the above two also do not work
disable AGP(well you cannot have 3d)
the easy way to do this is through mcc
4.decrease the default resolution to about 800*600 and see if it works
Apparently there are lot of glitches using nvidia in linux
5.if you have the old driver (nv) try this too,maybe it will work
keep posted
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
The best desklet for small wm's! chbin Slackware 1 03-27-2005 02:05 PM
kde 3.4 and GDM gbj Suse/Novell 3 03-21-2005 03:00 AM
How many wm's and or de's do you use? Dswissmiss General 23 10-02-2004 08:56 PM
kdm cannot login to KDE, but gdm and xdm work fine?? ming0 Slackware 2 09-01-2004 02:08 AM
dpi font | gdm | kde DE | xinitrc.kde | Slackware 10 acummings Slackware 2 07-28-2004 10:28 PM


All times are GMT -5. The time now is 10:42 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration