LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - General (http://www.linuxquestions.org/questions/linux-general-1/)
-   -   Garbled Screen after Uninstalling fglrx Driver (http://www.linuxquestions.org/questions/linux-general-1/garbled-screen-after-uninstalling-fglrx-driver-4175415700/)

pigsa 07-09-2012 09:45 AM

Garbled Screen after Uninstalling fglrx Driver
 
I have an AMD HD3850 display and use Debian Sid. The recent version of fglrx does not support my card. So I uninstalled anything with fglrx in their name.

X.org could not start then. And after reboot, the display became garbled shortly in the boot sequence ! The booting continues. And the console actually starts. I can login and run reboot command.

I tried to change vga mode the kernel booting command (vga=ask), use the 'recovery mode' added by debian, use single user mode (init 1). The same issue occur.

Note that the screen became garbled before it attempts to run x server. So the issue is irrelevant to x setting. Seems to me either caused by fbdev or dri...

Any suggestion?

Youtube video:
http://youtu.be/zaA_TzMY0Sk

Sorry for the stupid music, I just can't silent it.

[SOLVED] See #5-#7

ReaperX7 07-09-2012 08:25 PM

You may need to use apt to redownload and install the packages for libmesa, xf86-video-ati, and any other packages that may have been damaged by the proprietary driver.

Is there any way you can use nano to edit /etc/X11/xorg.conf and switch to the vesa driver?

pigsa 07-09-2012 10:48 PM

Damaged package is one direction of the investigation... But the issue occur not when running X, as I tried single user mode. Actually anyone know what happens after checking the SCO Timer or thermal sensor, as this is the last visible message?

Code:

[ok] Synthesizing the initial hotplug events...done.
[....] Waiting for /dev to be fully populated...udevd[348]: unknown key 'SYSFS{i
dVendor}' in /etc/udev/rules.d/51-android.rules:1

udevd[348]: invalid rule '/etc/udev/rules.d/51-android.rules:1'

udevd[348]: unknown key 'SYSFS{idVendor}' in /etc/udev/rules.d/51-android.rules:
2

udevd[348]: invalid rule '/etc/udev/rules.d/51-android.rules:2'

[    5.323157] SP5100 ICO timer: mmio address 0xfec000f8 already in use
[    5.493693] k10temp 0000:00:18.3: unreliable CPU thermal sensor; monitoring d
isabled


pigsa 07-10-2012 02:03 AM

Just found this: http://askubuntu.com/q/38920, so it seems after the SP5100 thing, fglrx is loaded.

Any one know what file configure the loading of fglrx at this stage?

cynwulf 07-10-2012 07:31 AM

Did you download and install fglrx from the .run installer from AMD? Even if you have done this in the past and then installed fglrx from the repos, it will still break the free radeon driver.

The uninstall script is usually in /usr/share/ati/

Try

Code:

# aptitude purge ~nfglrx
Code:

# sh /usr/share/ati/fglrx-uninstall.sh
Code:

# aptitude reinstall libgl1-mesa-dri libdrm-radeon1 libdrm2 xserver-xorg-core xserver-xorg-video-ati xserver-xorg-video-radeon
Get rid of xorg.conf (also check for fglrx related conf files in /usr/share/X11/xorg.conf.d/ and /etc/X11/xorg.conf.d/
Code:

# mv /etc/X11/xorg.conf /etc/X11/xorg.old
Then ensure that radeon is not blacklisted. Check for a blacklist file specific to radeon in /etc/modprobe.d/ and also open /etc/modprobe.d/blacklist.conf and ensure that radeon is not blacklist there.

Next ensure that KMS is enabled, either edit the file /etc/modprobe.d/radeon-kms.conf and ensure that is says "options radeon modeset=1"

Or you can just recreate it as follows
Code:

# echo options radeon modeset=1 > /etc/modprobe.d/radeon-kms.conf
Install the non-free firmware package (contains the radeon microcode)
Code:

# aptitude install firmware-linux-nonfree
Finally reboot.

adamk75 07-10-2012 11:39 AM

Quote:

Originally Posted by caravel (Post 4723868)
Next ensure that KMS is enabled, either edit the file /etc/modprobe.d/radeon-kms.conf and ensure that is says "options radeon modeset=0"

Or you can just recreate it as follows
Code:

# echo options radeon modeset=0 > /etc/modprobe.d/radeon-kms.conf

modeset=0 will disable KMS, not enable it.

Adam

pigsa 07-10-2012 05:44 PM

Seemed the key point was

Quote:

Originally Posted by caravel (Post 4723868)
Then ensure that radeon is not blacklisted. Check for a blacklist file specific to radeon in /etc/modprobe.d/ and also open /etc/modprobe.d/blacklist.conf and ensure that radeon is not blacklist there.

Next ensure that KMS is enabled, either edit the file /etc/modprobe.d/radeon-kms.conf and ensure that is says "options radeon modeset=0"

Or you can just recreate it as follows
Code:

# echo options radeon modeset=0 > /etc/modprobe.d/radeon-kms.conf

After these change, I could pass the boot sequence. Too bad commenting out the line in radeon-kms.conf did not enable/disable the KMS thing. :cry:

BTW, I installed fglrx with dpkg and got no fglrx-uninstall.sh. Also, I didn't reinstalled any deb, or did that already.


All times are GMT -5. The time now is 03:22 AM.