LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 12-13-2004, 04:50 AM   #1
0pal_t0ad
Member
 
Registered: Feb 2004
Location: Southampton, England
Distribution: Laptop:Gentoo-i686-2.6.9-r9 Desktop:Slackware10 2.4.26
Posts: 298

Rep: Reputation: 30
framebuffer/grub boot options


i've recently upgraded my kernel to 2.6.9 from 2.4.26 and now when i boot i get an invalid framebuffer value error. with the old kernel i had 'vga=791' added to my grub.conf which gave a FB at 1024x768 with 16bit colour.
what are the correct options for the 2.6 kernel, or don't i need to use the vga= option anymore?

cheers!
 
Old 12-13-2004, 04:53 AM   #2
abisko00
Senior Member
 
Registered: Mar 2004
Location: Munich
Distribution: SuSE, Ubuntu
Posts: 3,511

Rep: Reputation: 58
Try hexadecimal notation:

791=0x317
Code:
    | 640x480  800x600  1024x768 1280x1024
----+-------------------------------------
256 |  0x301    0x303    0x305    0x307   
32k |  0x310    0x313    0x316    0x319   
64k |  0x311    0x314    0x317    0x31A   
16M |  0x312    0x315    0x318    0x31B
 
Old 12-13-2004, 04:55 AM   #3
oneandoneis2
Senior Member
 
Registered: Nov 2003
Location: London, England
Distribution: Ubuntu
Posts: 1,460

Rep: Reputation: 46
Are you using vesafb or vesafb-tng in the kernel options?

If tng, you need to specify a video= option instead of a vga= one - this caught me out recently too!
 
Old 12-13-2004, 05:11 AM   #4
0pal_t0ad
Member
 
Registered: Feb 2004
Location: Southampton, England
Distribution: Laptop:Gentoo-i686-2.6.9-r9 Desktop:Slackware10 2.4.26
Posts: 298

Original Poster
Rep: Reputation: 30
with the old kernel i was using radeonfb but now lsmod shows vesafb(i think, i don't have my laptop w/ me right now, but i know it's not radeonfb anymore)

i'll try them both later on 2night.
cheers!
 
Old 12-13-2004, 12:48 PM   #5
0pal_t0ad
Member
 
Registered: Feb 2004
Location: Southampton, England
Distribution: Laptop:Gentoo-i686-2.6.9-r9 Desktop:Slackware10 2.4.26
Posts: 298

Original Poster
Rep: Reputation: 30
unfortunatly none of those suggestions worked i still get 1024x768 with only 16colours.
when configuring the kernel what's the syntax for the 'vesa default mode'? when i added mine i was so tired i forgot what the default looked like(literally seconds after i backspaced it) so i added something ramdom like 1024x768@60
also can i use radeonfb again??
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
wireless Keyboard not working to select boot options (Grub boot loader) psrini_vasan Fedora 7 12-16-2009 05:45 PM
GRUB boot options. enyawix Linux - Software 2 12-08-2004 01:49 PM
Grub boot loader menu shows two linux boot options pramos Linux - Newbie 3 09-12-2004 11:40 PM
Hiding boot options with GRUB? kayhan Linux - Newbie 1 12-28-2003 04:48 PM
Mandrake boot options GRUB and LILO question LooseCanon Mandriva 2 09-21-2003 06:30 PM


All times are GMT -5. The time now is 06:42 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration