LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 01-21-2004, 08:54 AM   #1
n3tw0rk
Member
 
Registered: Sep 2003
Location: Rawalpindi, Pakistan
Distribution: Slackware
Posts: 86

Rep: Reputation: 15
Framebuffer console settings


How do i change the framebuffer console resolution and other settings. Its currently set to 1024x768 i think.
 
Old 01-21-2004, 09:24 AM   #2
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: Tupelo, MS
Distribution: Gentoo
Posts: 6,926

Rep: Reputation: 124Reputation: 124
Re: Framebuffer console settings

Quote:
Originally posted by n3tw0rk
How do i change the framebuffer console resolution and other settings. Its currently set to 1024x768 i think.
Try your /etc/X11/XF86Config file (or XF86Config-4). What distribution are you using? If you will put that in your user cp above it will help you get better answers.
 
Old 01-21-2004, 12:14 PM   #3
Tramontane
Member
 
Registered: Oct 2003
Distribution: Debian
Posts: 39

Rep: Reputation: 15
If you use lilo, see the 4th post down
http://www.knoppix.net/forum/viewtopic.php?t=6659

Otherwise, I don't know.


Since you said framebuffer console, I'm assuming you're talking about settings that have nothing to do with X. You can set 'vga=ask' to give you more info about possible vga settings.

Last edited by Tramontane; 01-21-2004 at 12:18 PM.
 
Old 01-21-2004, 02:10 PM   #4
n3tw0rk
Member
 
Registered: Sep 2003
Location: Rawalpindi, Pakistan
Distribution: Slackware
Posts: 86

Original Poster
Rep: Reputation: 15
Well i am using Slackware 9.1. When my system boots up the font size is too small in console(Runlevel 3). I want to change that resolution. Yes i use LILO, but can't it be done without messing with LILO. I mean after all its the frame buffer we have to deal with!
 
Old 01-21-2004, 02:16 PM   #5
Tramontane
Member
 
Registered: Oct 2003
Distribution: Debian
Posts: 39

Rep: Reputation: 15
Since it's Slackware, it's using lilo to alter those settings. So I guess the choice has kind of been made for you already.

If you want it to behave as if normal(larger text, no colors), alter your vga setting in lilo to say 'vga=normal'. And remember to run lilo after editting lilo.conf.
 
Old 01-21-2004, 07:51 PM   #6
IamDaniel
Member
 
Registered: Mar 2003
Location: Sungai Petani
Distribution: Slackware
Posts: 143

Rep: Reputation: 15
Something strange happen here... why the linux 2.4.23 don't have the framebuffer console support in the kernel configuration? Is it altered or else where I can enable it ? (I known where it is reside, or perhaps it is altered?)
 
Old 01-22-2004, 03:02 AM   #7
Shade
Senior Member
 
Registered: Mar 2003
Location: Burke, VA
Distribution: RHEL, Slackware, Ubuntu, Fedora
Posts: 1,418
Blog Entries: 1

Rep: Reputation: 46
The 2.4.23 kernel isn't stock with slack 9.1 -- So I'm assuming you compiled it yourself and left out framebuffer console support -- or vga mode selection support.

All those options are under "character devices" in the menu config.

Once you have support in your kernel, you use a kernel parameter (regardless of boot-loader) to specify what resolution and color depth the framebuffer uses.
# VESA framebuffer console @ 800x600x32k
vga="787"

Is what I'm using on my laptop.

The slackware lilo.conf has a very nicely commented section for selection of framebuffer configuration.

-Shade
 
Old 01-24-2004, 08:31 AM   #8
IamDaniel
Member
 
Registered: Mar 2003
Location: Sungai Petani
Distribution: Slackware
Posts: 143

Rep: Reputation: 15
Forgive me..if I was too annoying...
After searched around the menuconfig, there is no framebuffer options..what can I do ? or does the name changed ? I am lost, help me..
 
Old 01-24-2004, 11:27 AM   #9
hw-tph
Senior Member
 
Registered: Sep 2003
Location: Sweden
Distribution: Debian
Posts: 3,032

Rep: Reputation: 57
If you're using the 2.4 series kernels the framebuffer options are under "Console drivers". Make sure you have the "Prompt for incomplete and experimental drivers" option at the top of the config screen checked (under "Code maturity level options") to get all the options.


Håkan
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Console Framebuffer darkarcon2015 Slackware 9 07-16-2005 05:24 PM
[SOLVED] No text in framebuffer console TarrasQ Linux - Software 2 03-15-2004 03:01 AM
Framebuffer Console Help Crazed123 Linux - Software 5 07-29-2003 02:10 PM
Framebuffer Console jspenguin Linux - General 3 02-28-2003 08:21 AM
Framebuffer Console Jesus Slackware 6 05-02-2002 12:55 AM


All times are GMT -5. The time now is 03:40 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration