LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - General (http://www.linuxquestions.org/questions/linux-general-1/)
-   -   Framebuffer console settings (http://www.linuxquestions.org/questions/linux-general-1/framebuffer-console-settings-137071/)

n3tw0rk 01-21-2004 08:54 AM

Framebuffer console settings
 
How do i change the framebuffer console resolution and other settings. Its currently set to 1024x768 i think.

Bruce Hill 01-21-2004 09:24 AM

Re: Framebuffer console settings
 
Quote:

Originally posted by n3tw0rk
How do i change the framebuffer console resolution and other settings. Its currently set to 1024x768 i think.
Try your /etc/X11/XF86Config file (or XF86Config-4). What distribution are you using? If you will put that in your user cp above it will help you get better answers.

Tramontane 01-21-2004 12:14 PM

If you use lilo, see the 4th post down
http://www.knoppix.net/forum/viewtopic.php?t=6659

Otherwise, I don't know.


Since you said framebuffer console, I'm assuming you're talking about settings that have nothing to do with X. You can set 'vga=ask' to give you more info about possible vga settings.

n3tw0rk 01-21-2004 02:10 PM

Well i am using Slackware 9.1. When my system boots up the font size is too small in console(Runlevel 3). I want to change that resolution. Yes i use LILO, but can't it be done without messing with LILO. I mean after all its the frame buffer we have to deal with!

Tramontane 01-21-2004 02:16 PM

Since it's Slackware, it's using lilo to alter those settings. So I guess the choice has kind of been made for you already.

If you want it to behave as if normal(larger text, no colors), alter your vga setting in lilo to say 'vga=normal'. And remember to run lilo after editting lilo.conf.

IamDaniel 01-21-2004 07:51 PM

Something strange happen here... why the linux 2.4.23 don't have the framebuffer console support in the kernel configuration? Is it altered or else where I can enable it ? (I known where it is reside, or perhaps it is altered?)

Shade 01-22-2004 03:02 AM

The 2.4.23 kernel isn't stock with slack 9.1 -- So I'm assuming you compiled it yourself and left out framebuffer console support -- or vga mode selection support.

All those options are under "character devices" in the menu config.

Once you have support in your kernel, you use a kernel parameter (regardless of boot-loader) to specify what resolution and color depth the framebuffer uses.
# VESA framebuffer console @ 800x600x32k
vga="787"

Is what I'm using on my laptop.

The slackware lilo.conf has a very nicely commented section for selection of framebuffer configuration.

-Shade

IamDaniel 01-24-2004 08:31 AM

Forgive me..if I was too annoying...
After searched around the menuconfig, there is no framebuffer options..what can I do ? or does the name changed ? I am lost, help me..

hw-tph 01-24-2004 11:27 AM

If you're using the 2.4 series kernels the framebuffer options are under "Console drivers". Make sure you have the "Prompt for incomplete and experimental drivers" option at the top of the config screen checked (under "Code maturity level options") to get all the options.


Håkan


All times are GMT -5. The time now is 05:23 PM.