LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 10-27-2003, 08:25 PM   #1
squall14716
Member
 
Registered: Oct 2003
Distribution: Gentoo, Knoppix
Posts: 62

Rep: Reputation: 15
Formating a FAT32 partition, putting the partition correctly into FSTAB, and more.


First question: In fdisk during the Knoppix harddrive install, I marked my 4th partition (hda7) as a FAT32 partition. How do I format it and use that partition.
Second question: Once I do that, how do I set it up correctly in /etc/fstab so I can mount it?
Third question: Once I mount the partition, how can I move /home and /usr to that partition?

That's all for now.

EDIT: Oh yeah, I forgot a question. Since I am using the boot manager (LILO I think) that Knoppix installed, how can I change the what names appear for each operating system when I get the screen to choose an OS when I am booting my PC?

Last edited by squall14716; 10-27-2003 at 08:51 PM.
 
Old 10-27-2003, 08:34 PM   #2
quatsch
LQ Addict
 
Registered: Aug 2003
Location: New York, NY
Distribution: gentoo, gentooPPC
Posts: 1,661

Rep: Reputation: 47
I don't think you want /home or /usr on an fat32 partition. For one, it doesn't support symlinks and I'm sure this'll cause trouble for /usr and probably also for /home.

As for formatting, you can use the command fdisk, or
cfdisk
for easier use (I'm pretty sure you have cfdisk).

fstab. Something like this:
/dev/hda7 /{mountpoint} vfat auto,rw,umask=0 0 0
should do it.
 
Old 10-27-2003, 08:55 PM   #3
squall14716
Member
 
Registered: Oct 2003
Distribution: Gentoo, Knoppix
Posts: 62

Original Poster
Rep: Reputation: 15
When mounting it, I get this error:
Code:
Could not mount device.
The reported error was:
mount: wrong fs type, bad option, bad superblock on /dev/hda7,
or too many mounted file systems
I have /mnt/hda1, /mnt/hda5, and /mnt/auto/cdrom1 mounted, but that's about all, so it shouldn't be too many. I can change the filesystem type in cfdisk, but that still doesn't make it usable, does it? I need to make it FAT32 and usable.
 
Old 10-27-2003, 09:04 PM   #4
quatsch
LQ Addict
 
Registered: Aug 2003
Location: New York, NY
Distribution: gentoo, gentooPPC
Posts: 1,661

Rep: Reputation: 47
what's the exact command you used?

For formatting. my guess is that you still have windows installed on your machine (/dev/hda1??). So the easiest thing to do might be from inside windows. If it's XP, right click on my computer, then management -> disk management and then have it formatted in fat32.
 
Old 10-27-2003, 09:07 PM   #5
squall14716
Member
 
Registered: Oct 2003
Distribution: Gentoo, Knoppix
Posts: 62

Original Poster
Rep: Reputation: 15
I have Windows 2k in /mnt/hda1, and last time I blindly formatted one of the drives, Knoppix stopped working and I had to re-install it. I just right click and selected "Mount" on the icon I created for the drive on my desktop, and it gave me that error.
 
Old 10-27-2003, 09:15 PM   #6
quatsch
LQ Addict
 
Registered: Aug 2003
Location: New York, NY
Distribution: gentoo, gentooPPC
Posts: 1,661

Rep: Reputation: 47
try to do it from a terminal window as root:
mount -t vfat /dev/hda7 /mnt/{mountpoint}

Also, it should be okay formatting from inside windows so long as you don't format the wrong partition - i've done such things a few times with several distros and haven't had problems. hda7 is the third one in the extended partittion.
 
Old 10-27-2003, 09:22 PM   #7
squall14716
Member
 
Registered: Oct 2003
Distribution: Gentoo, Knoppix
Posts: 62

Original Poster
Rep: Reputation: 15
I have 4 partitions and Windows only sees 3, I formatted the last one (E and I no longer got the dual-boot option - it just went straight into Windows 2k, I guess I formatted the Knoppix one.

(For clarity, hda1 is Win 2k (NTFS), hda5 is Knoppix (ext2), hda6 is Linux swap, hda7 is for my data, and should be FAT32, since both Linux and Windows can read it.)

Ok, I ran that from the terminal and I got the same error:
Code:
root@linknopersocom:~# mount -t vfat /dev/hda7 /mnt/hda7
mount: wrong fs type, bad option, bad superblock on /dev/hda7,
       or too many mounted file systems
 
Old 10-27-2003, 09:26 PM   #8
quatsch
LQ Addict
 
Registered: Aug 2003
Location: New York, NY
Distribution: gentoo, gentooPPC
Posts: 1,661

Rep: Reputation: 47
windows see only three??? I guess it's better than it claiming that your drive is corrupted or somethin...

What's the output you get from
fdisk -l /dev/hda
(do this as root). This will give you the list of partitions and the file system types it sees.
 
Old 10-27-2003, 09:28 PM   #9
squall14716
Member
 
Registered: Oct 2003
Distribution: Gentoo, Knoppix
Posts: 62

Original Poster
Rep: Reputation: 15
Code:
root@linknopersocom:~# fdisk -l /dev/hda

Disk /dev/hda: 40.0 GB, 40020664320 bytes
255 heads, 63 sectors/track, 4865 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot    Start       End    Blocks   Id  System
/dev/hda1   *         1       131   1052226    7  HPFS/NTFS
/dev/hda2           132      4864  38017822+   f  Win95 Ext'd (LBA)
/dev/hda5           132       450   2562336   83  Linux
/dev/hda6           451       581   1052226   82  Linux swap
/dev/hda7           582      4864  34403166    b  Win95 FAT32
 
Old 10-27-2003, 09:37 PM   #10
quatsch
LQ Addict
 
Registered: Aug 2003
Location: New York, NY
Distribution: gentoo, gentooPPC
Posts: 1,661

Rep: Reputation: 47
hmmm. It says your /dev/hda7 is fat32. but the size of it bothers me a bit. I think there is a 32GB size limit for fat32 and yours might be slightly above it - I also now see why you want to migrate /home and /usr. Maybe try breaking that up into two; one smaller linux so you can migrate /home to it and then another in fat32.
 
Old 10-27-2003, 09:41 PM   #11
squall14716
Member
 
Registered: Oct 2003
Distribution: Gentoo, Knoppix
Posts: 62

Original Poster
Rep: Reputation: 15
I'm not good in Linux, the only way I got those partitions was with the Win 2k install and I changed their filesystems with cfdisk. Are there any resources that you know of to help me split the partition into two?
 
Old 10-27-2003, 09:52 PM   #12
quatsch
LQ Addict
 
Registered: Aug 2003
Location: New York, NY
Distribution: gentoo, gentooPPC
Posts: 1,661

Rep: Reputation: 47
doesn't the menu system of cfdisk allow you to first delete the partition and then create new ones onto the empty space? cfdisk is the easiest one I know of for linux except for tools that come with mandrake.
 
Old 10-27-2003, 10:06 PM   #13
squall14716
Member
 
Registered: Oct 2003
Distribution: Gentoo, Knoppix
Posts: 62

Original Poster
Rep: Reputation: 15
Oh, I didn't notice that I could create it in the free space. Thanks for your help. Can you also answer the question I edited in the first post a while ago if you know it? Thanks again.

EDIT: How can I create a new Lunux ext2 partition?

Last edited by squall14716; 10-27-2003 at 10:19 PM.
 
Old 10-27-2003, 10:12 PM   #14
Skyline
Senior Member
 
Registered: Jun 2003
Distribution: Debian/other
Posts: 2,104

Rep: Reputation: 45
Change the label names in lilo.conf - make sure you change the default = line aswell if you change the corresponding label name - also run

/sbin/lilo

after youve made the changes.
 
Old 10-27-2003, 10:16 PM   #15
quatsch
LQ Addict
 
Registered: Aug 2003
Location: New York, NY
Distribution: gentoo, gentooPPC
Posts: 1,661

Rep: Reputation: 47
for lilo. What you do is edit /etc/lilo.conf

you will see the entries, called stanzas, for each os installed. Each stanza will have a line like:
label=Knoppix
or
label=DOS

These are the names that appear in the lilo menu. You can change them any way except that you cannot have Spaces in the names. Also, when you change the name, make sure you edit the entry
default=
appropriately. You've got to provide the label of the OS you want to start as default. The entry is somwhere near the top of the file. While you're editing it, you should get rid of all the lines with # at the beginning (kind of useful comments but just annoying when editing it - you could backup the file somewhere for reference if you want to).
After editing lilo.conf, you must run lilo so that the changes take effect:
/sbin/lilo -v

You will see some output about what it is doing and error messages in case something goes wrong. This whole thing has to be done as root.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
accessing a linux partition from a fat32 partition? abtimoteo Ubuntu 4 09-19-2005 10:41 PM
Partition mounting/KDE errors after creating Fat32 Partition BertBert Linux - General 1 07-07-2004 10:59 AM
Help:(linux can mount the fat32 correctly,but dos can't recognize the partition.) zhgjerry Red Hat 11 03-30-2004 09:23 AM
Help me:(linux can mount the fat32 correctly,but dos can't recognize the partition.) zhgjerry Arch 2 03-19-2004 07:41 AM
fstab, mounting a fat32 partition, need help w/ ownership and all that mackstann Linux - General 2 10-15-2001 02:37 PM


All times are GMT -5. The time now is 08:15 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration