LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 11-13-2002, 05:41 PM   #1
Half_Elf
Guru
 
Registered: Sep 2001
Location: Montreal, Canada
Distribution: Slackware; Debian; Gentoo...
Posts: 2,163

Rep: Reputation: 45
Forcing Lilo to DOESN'T check


I have several removable device and some contain bootable OS.
Because of that, I have a very annoying problem with LILO. When I try to rewrite my MBR using Lilo, it give me errors about all "not present device" (of course stupid buggy thing, my device are removable!) so I have to plug all my stuff or to comment some part of the lilo.conf.
Is there a way to force lilo to ignore error or to do not check for error?
 
Old 11-13-2002, 09:38 PM   #2
rootboy
Member
 
Registered: Oct 2001
Distribution: Mint 15
Posts: 768

Rep: Reputation: 51
Re: Forcing Lilo to DOESN'T check

Quote:
Originally posted by Half_Elf
I have several removable device and some contain bootable OS.
Because of that, I have a very annoying problem with LILO. When I try to rewrite my MBR using Lilo, it give me errors about all "not present device" (of course stupid buggy thing, my device are removable!) so I have to plug all my stuff or to comment some part of the lilo.conf.
Is there a way to force lilo to ignore error or to do not check for error?
"lilo -F -Pignore" might work.


John
 
Old 11-14-2002, 08:00 AM   #3
Half_Elf
Guru
 
Registered: Sep 2001
Location: Montreal, Canada
Distribution: Slackware; Debian; Gentoo...
Posts: 2,163

Original Poster
Rep: Reputation: 45
hum the -F option does not appear to exist... and the -P ignore give me the same error
but thanx for the reply
 
Old 11-15-2002, 05:27 PM   #4
linuxcool
LQ Addict
 
Registered: Jun 2001
Posts: 1,183

Rep: Reputation: 47
Half_Elf, I don't know if this will work, but try using ' unsafe ' in the /etc/lilo.conf file. Put it in each removable device's section. Like this:

other=/dev/fd0
unsafe
label=floppy
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
LILO BIOS Check darkarcon2015 Linux - Laptop and Netbook 10 02-18-2010 12:28 PM
LILO and BIOS Data Check jrdioko Linux - Software 1 05-03-2009 05:28 PM
lilo bios check takes forever... edong23 Linux - Laptop and Netbook 1 07-17-2005 11:55 AM
Automatically forcing file system check? The_Nerd Linux - Hardware 1 11-30-2004 10:37 PM
forcing check by mounting '/' or bad free size myrecek Linux - Hardware 4 06-01-2004 06:15 AM


All times are GMT -5. The time now is 07:07 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration