LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 05-23-2004, 06:17 AM   #1
kinasz
Member
 
Registered: Mar 2004
Location: Brisbane, Australia
Distribution: FreeBSD, Suse
Posts: 103

Rep: Reputation: 15
Forcedeth only works as a module with 2.6.6


I have just installed the 2.6.6 kernel on a system built with lfs. Forcedeth for nforce only seems to work when I compile it as a module and then modprobe it. When it is compiled as a driver eth0 doesn't exist.

I am not sure what I am missing and any help would be great!

Thanks




( Sorry if in wrong forum, wasn't sure where this belongs )
 
Old 05-23-2004, 06:27 AM   #2
hw-tph
Senior Member
 
Registered: Sep 2003
Location: Sweden
Distribution: Debian
Posts: 3,032

Rep: Reputation: 57
Is having forcedeth compiled as a module a problem? Add forcedeth to the list of modules that should be loaded on boot (whatever means of automatic module loading you have on LFS) and that should pretty much be it.


Håkan
 
Old 05-23-2004, 07:31 AM   #3
kinasz
Member
 
Registered: Mar 2004
Location: Brisbane, Australia
Distribution: FreeBSD, Suse
Posts: 103

Original Poster
Rep: Reputation: 15
yes, that is what I am doing now, however this doesnt answer why it isn't loading when compiled in. I am trying to find if I am doing something obvious wrong, ie: missing a line in a config file somewhere?

I would like to write my own init scripts as well, can anyone refer me to a good sys v style init tutorial.

Last edited by kinasz; 05-23-2004 at 07:33 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
NIC card works - how do i find which module its using? crazytigger Linux - Hardware 3 09-02-2005 08:38 AM
forcedeth module will not properly load meddle Linux - Networking 0 02-27-2005 06:03 PM
install problem: Suse 9.2 AMD64 Nvidia 'forcedeth' kernel module croutonjones Suse/Novell 1 01-16-2005 04:50 PM
kcmshell module, Background&Screensaver Module can't be launch (but works @LookNFeeL) bobbyjoe Linux - Software 0 01-08-2005 04:48 AM
Network card install trouble, but I *know* this module works! numlock Linux - Networking 1 05-31-2003 08:05 PM


All times are GMT -5. The time now is 09:19 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration