LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - General (http://www.linuxquestions.org/questions/linux-general-1/)
-   -   Fluxbox with slowly boot (http://www.linuxquestions.org/questions/linux-general-1/fluxbox-with-slowly-boot-241363/)

MANTERO 10-11-2004 11:44 AM

Fluxbox with slowly boot
 
Hi folks! Five weeks ago, before to reinstall Debian Sid, I used Fluxbox without problems, but when I reinstalled Debian the boot of Fluxbox with normal user is very slowly and the styles are deformed. But the most importants is when I boot with root user the system run perfectly, fast and with nice styles. I don't understand what this happening :(. I send this problem in other forums in Spanish and English languages, and in mailing lists too, but they can't ask me :P. Thanks for your help. If you need more information, request it.

P.D: Sorry for my low level of english :D.

MANTERO.

darkleaf 10-11-2004 12:11 PM

Are you perhaps trying to run a lot of extra programs on startup of the user? Check your ~/.xinitrc for things you might not need?

MANTERO 10-11-2004 12:57 PM

Hi! Thanks for you help but I don't have this file :P. But I view the file .xsession-errors and I view this errors:

Code:

Failed to load groupfile:
apps file failure
Error creating style menu! Stylesdir: /home/mantero/.fluxbox/styles does not exist or is not a directory!
/bin/sh: Esetroot: command not found

I don't understand the message of "groupfile" and the command Esetroot :P. After, I prove to make the directory of the message. Thanks for your help! By3!

MANTERO.

darkleaf 10-11-2004 02:30 PM

I think your fluxbox is looking in the wrong directory for the styles. I don't know how to get that back but the default directory is /usr/share/fluxbox/styles

MANTERO 10-12-2004 02:15 AM

Hi! I create the directory "styles" in ~/.fluxbox. Also I installed the eterm package to correct the error of "Esetroot: command not found". In this moment in the .xsession-errors only view the following error:

Code:

Failed to load groupfile:
apps file failure

I don't understand the meaning of this error and I search in Google, but I haven't found anything on the matter :(. Thanks for your help :D. By3!

MANTERO.

basix 10-12-2004 11:26 AM

I have to tell you i havent used fluxbox or debian sid but i think you should set a symlink like this:

ln -s /usr/share/fluxbox/styles /home/mantero/.fluxbox/styles

if /usr/share/fluxbox/styles is the place where all your styles are stored.

PS: I dunno if this is just a dirty fix or a legit one =).

MANTERO 10-14-2004 12:26 PM

Thanks for all! But all are equal :(. I seems that I'll reinstall my Debian system. Thanks ;). By3!

MANTERO.

comprookie2000 10-14-2004 03:17 PM

Look in ~.fluxbox/init

ghostwalker 10-15-2004 01:14 AM

20. Fluxbox 0.9.6 is slow...

Add the following line to your .xinitrc before you exec fluxbox:

export LC_ALL=C


All times are GMT -5. The time now is 04:51 AM.