LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 09-01-2003, 12:15 AM   #1
JimW
LQ Newbie
 
Registered: Aug 2003
Location: Saskatoon, SK Canada
Distribution: Mandrake 9.1
Posts: 7

Rep: Reputation: 0
Floppy takes long time to mount


I'm using Mandrake 9.1, just recently upgraded from Man 9.0

My main use of the computer is as a word-processor, so I'm very low on the technical knowledge, though my local LUG has been very helpful.

But, on to the problem: Since moving to 9.1, the floppy takes over a minute to mount. If I have nothing in the floppy drive, the whole /mnt directory comes up almost instantaneously. When I put a floppy in, it takes a very long time to mount.

This is not a hardware problem; I still have Windoze up, for some little things that I can't manage (yet) through linux. On the Windoze partition, the floppy comes up like a shot.

I believe it has to do with putting something into the /fstab, though I may have that wrong.

However, something's got to be put somewhere. What I need is step by step instructions.

Thanks

Jim

 
Old 09-01-2003, 04:37 AM   #2
jalal
Member
 
Registered: Aug 2003
Location: .bh
Distribution: Gentoo
Posts: 188

Rep: Reputation: 30
you can try mounting the floppy explicitly as a vfat file system device,

e.g. mount -t vfat /dev/fd0 /mnt/floppy

see if that enables you to mount it faster, as specifying "auto" can take some time.


... and Welcome to LQ !!

Last edited by jalal; 09-01-2003 at 04:47 AM.
 
Old 09-02-2003, 12:11 AM   #3
JimW
LQ Newbie
 
Registered: Aug 2003
Location: Saskatoon, SK Canada
Distribution: Mandrake 9.1
Posts: 7

Original Poster
Rep: Reputation: 0
Floppy takes long time to mount

When I cat /etc/fstab, the info I get on floppies is this:

none /mnt/floppy supermount dev=/dev/fd0,fs=auto,--,iocharset=iso8859-1,sync,codepage=850,umask=0 0 0

Is there anything obviolus in here that can have a bearing on my problem?

From what I can tell, the supermount is not working, or not working properly. When I'm working from OpenOffice, very frequently when I attempt to save to the floppy, the OO program shuts down, losing all my information.

JimW
 
Old 09-02-2003, 01:03 AM   #4
jalal
Member
 
Registered: Aug 2003
Location: .bh
Distribution: Gentoo
Posts: 188

Rep: Reputation: 30
did you try the explicit mount I mentioned above ?

We will come to know if you need to change anything in your fstab if the explicit mount did improve the performance.
 
Old 09-03-2003, 12:48 AM   #5
JimW
LQ Newbie
 
Registered: Aug 2003
Location: Saskatoon, SK Canada
Distribution: Mandrake 9.1
Posts: 7

Original Poster
Rep: Reputation: 0
I've been trying to respond several times, but can't seem to get through.

Will this change effect the ability to read Windows-formatted and Linux-formatted floppies?

Jimw
 
Old 09-03-2003, 01:29 AM   #6
jalal
Member
 
Registered: Aug 2003
Location: .bh
Distribution: Gentoo
Posts: 188

Rep: Reputation: 30
This will work with Windows formatted floppies only. It is just a test to see if the problem is with autodetection, or you have another problem.
 
Old 09-04-2003, 11:42 PM   #7
JimW
LQ Newbie
 
Registered: Aug 2003
Location: Saskatoon, SK Canada
Distribution: Mandrake 9.1
Posts: 7

Original Poster
Rep: Reputation: 0
Okay. As I've mentioned, I've been having an awful time getting myself properly logged on. Hopefully, I am now.

As I've mentioned before, I'm very much of a newbie at this all.

Below is the entry in /fstab for /mnt/floppy. I'm not sure just what I should do. Do I take the whole lot out and replace it with your suggested entry, or just part of it, and if so, which part?

Thanks

Jim

none /mnt/floppy supermount dev=/dev/fd0,fs=auto,--,iocharset=iso8859-1,sync,codepage=850,umask=0 0 0
 
Old 09-04-2003, 11:51 PM   #8
quatsch
LQ Addict
 
Registered: Aug 2003
Location: New York, NY
Distribution: gentoo, gentooPPC
Posts: 1,661

Rep: Reputation: 47
backup your fstab and then, as root, do

supermount -i disable

this will make changes to the fstab to disable supermount. After this reboot and try to mount the floppy manually (you might have to be root for this) by

mnt /mnt/floppy

If this is faster than before, then it was a supermount problem. You can also try the explicit method jalal was suggesting.
 
Old 09-05-2003, 12:11 AM   #9
DavidPhillips
Guru
 
Registered: Jun 2001
Location: South Alabama
Distribution: Fedora / RedHat / SuSE
Posts: 7,154

Rep: Reputation: 56
try this in fstab

/dev/fd0 /mnt/floppy auto noauto,user,rw 0 0
 
Old 09-05-2003, 12:57 AM   #10
JimW
LQ Newbie
 
Registered: Aug 2003
Location: Saskatoon, SK Canada
Distribution: Mandrake 9.1
Posts: 7

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by quatsch
backup your fstab and then, as root, do

supermount -i disable

this will make changes to the fstab to disable supermount. After this reboot and try to mount the floppy manually (you might have to be root for this) by

mnt /mnt/floppy

If this is faster than before, then it was a supermount problem. You can also try the explicit method jalal was suggesting.

At first it seemed so, but then I tried it through KDE and it was slow again. I went in through Konsole and unmounted it, got a message saying it wasn't mounted. Tried to mount it through Konsole, and got an error message:

mount: I could not determine the filesystem type, and none was specified

I don't know what this signifies.

Jim
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
takes long time to load the KDE bruse Linux - Newbie 14 10-03-2005 03:29 PM
login takes long time doorman007 Linux - Software 2 04-25-2005 12:56 AM
Suse 9.1 takes a LONG time to boot.... randon Suse/Novell 37 03-02-2005 05:28 PM
Bzipping takes a really long time sometimes scott_R General 0 10-10-2004 12:47 AM
Mandrake takes a LONG time to boot VinTSS Mandriva 2 01-11-2004 12:36 AM


All times are GMT -5. The time now is 09:36 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration