LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 04-24-2008, 05:06 AM   #1
lszanto
LQ Newbie
 
Registered: Mar 2008
Location: Down Under
Distribution: Ubuntu 7.10
Posts: 8

Rep: Reputation: 0
Wink Fixing bios/grub boot error 'geom'.


Today I spent a few hours installing Tinysofa 2.0 Classic on my older pc that I have planned to use as a home webserver. The installation could not have gone smoother, it recognized that it had low memory so activated swap and such and I easily selected the packages.

The problem came when I went to restart and It just came up with the error message 'grub grom error' instead of booting. I did a bit of reading and this seems to be because my bios only registers a 8gb harddrive while the linux system can see the full 20gb that is there. So my question is, is there any way to fix this and boot my computer properly? Or if possible some kind of rescue floppy disk or something to use while waiting for a permanent fix?

Thanks in advance, Luke
 
Old 04-24-2008, 03:40 PM   #2
bigrigdriver
LQ Addict
 
Registered: Jul 2002
Location: East Centra Illinois, USA
Distribution: Debian Squeeze
Posts: 5,764

Rep: Reputation: 306Reputation: 306Reputation: 306Reputation: 306
Quote:
I did a bit of reading and this seems to be because my bios only registers a 8gb harddrive
The first thing to do is to determine if the limitation is the BIOS (it's a non-LBA BIOS) itself or a setting in the BIOS (the BIOS is LBS-capable, but LBA is not set). Enter the BIOS and go into the hard drive settings. You should see the drive listed, as well as the number of cylinders, sectors, and heads. At the right-hand end of the line, select the mode (which may read Normal) and change it to LBA.

If the BIOS is not LBA-capable, you could try creating a small /boot partition as the first partition, with the rest of the filesystem in the second partition, and swap in the third partition. Having the bootable kernel image in a small partition at the beginning of the drive may allow normal booting of the system since the BIOS sees it as withing the 8 GB limit. Once the system is booted, the OS takes over. I don't think the BIOS interfers with writes to disk after the 8 GB limit once the OS is booted.

As you can see, this means re-partitioning and re-installing. But, if it works, it's worth the effort.
 
Old 04-24-2008, 05:36 PM   #3
lszanto
LQ Newbie
 
Registered: Mar 2008
Location: Down Under
Distribution: Ubuntu 7.10
Posts: 8

Original Poster
Rep: Reputation: 0
Thanks, I think I will try the /boot method as my hard drive is already to set to LBA but it doesn't seem to help anything, I'll just redo the install.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
grub geom error =no boot up EvilBill Debian 1 08-29-2006 05:58 AM
GRUB Geom Error Soniku Linux - General 1 05-06-2006 05:01 PM
GRUB Geom Error lloydsmart Linux - General 2 12-07-2005 08:11 AM
GRUB geom error alesis_ho Linux - Laptop and Netbook 1 04-19-2005 01:58 AM
"GRUB Geom Error" on boot...What does this mean? arctic123 Linux - Software 1 03-07-2005 05:53 PM


All times are GMT -5. The time now is 06:38 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration