LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices



Reply
 
Search this Thread
Old 01-28-2009, 06:10 AM   #1
manishgarg21
LQ Newbie
 
Registered: May 2008
Posts: 16

Rep: Reputation: 0
Firefox-3.0.5 installation problem on RHEL v4


Hi,

I am facing problem for Firefox-3.0.5 on RHEL v4. I downloaded the rpms from RH website, it gave the error that few packages are missing, i down loaded the same and tried it, i am still not able to fix it. Here is the output for the whole process. Please help me in fixing the problem. Many thanks in advance. regards Manish.

************output for the process*************
[root@isdwks0034 Desktop]# rpm -Uvh firefox-3.0.5-1.el4.x86_64.rpm
error: Failed dependencies:
evolution28-cairo is needed by firefox-3.0.5-1.el4.x86_64
evolution28-gtk2 is needed by firefox-3.0.5-1.el4.x86_64
nspr >= 4.7.0.99.2 is needed by firefox-3.0.5-1.el4.x86_64
nss >= 3.11.99.5 is needed by firefox-3.0.5-1.el4.x86_64
libnssutil3.so()(64bit) is needed by firefox-3.0.5-1.el4.x86_64
Suggested resolutions:
/var/spool/up2dateevolution28-cairo-1.2.4-6.el4.x86_64.rpm
/var/spool/up2dateevolution28-gtk2-2.10.4-21.el4.x86_64.rpm
[root@isdwks0034 Desktop]# rpm -Uvh evolution28-cairo-1.2.4-6.el4.x86_64.rpm
Preparing... ########################################### [100%]
1:evolution28-cairo ########################################### [100%]

[root@isdwks0034 Desktop]#
[root@isdwks0034 Desktop]# rpm -Uvh evolution28-gtk2-2.10.4-22.el4.x86_64.rpm
error: Failed dependencies:
evolution28-glib2 >= 2.12.0-1 is needed by evolution28-gtk2-2.10.4-22.el4.x86_64
evolution28-atk >= 1.9.0-1 is needed by evolution28-gtk2-2.10.4-22.el4.x86_64
Suggested resolutions:
/var/spool/up2dateevolution28-atk-1.12.2-4.el4.x86_64.rpm
/var/spool/up2dateevolution28-glib2-2.12.3-6.el4.x86_64.rpm
[root@isdwks0034 Desktop]# rpm -Uvh evolution28-atk-1.12.2-4.el4.x86_64.rpm
error: Failed dependencies:
evolution28-glib2 is needed by evolution28-atk-1.12.2-4.el4.x86_64
Suggested resolutions:
/var/spool/up2dateevolution28-glib2-2.12.3-6.el4.x86_64.rpm
[root@isdwks0034 Desktop]# rpm -Uvh evolution28-glib2-2.12.3-6.el4.x86_64.rpm
Preparing... ########################################### [100%]
1:evolution28-glib2 ########################################### [100%]
[root@isdwks0034 Desktop]# rpm -Uvh evolution28-atk-1.12.2-4.el4.x86_64.rpm
Preparing... ########################################### [100%]
1:evolution28-atk ########################################### [100%]
[root@isdwks0034 Desktop]# rpm -Uvh evolution28-gtk2-2.10.4-22.el4.x86_64.rpm
Preparing... ########################################### [100%]
1:evolution28-gtk2 ########################################### [100%]
[root@isdwks0034 Desktop]# rpm -Uvh firefox-3.0.5-1.el4.x86_64.rpm
error: Failed dependencies:
nspr >= 4.7.0.99.2 is needed by firefox-3.0.5-1.el4.x86_64
nss >= 3.11.99.5 is needed by firefox-3.0.5-1.el4.x86_64
libnssutil3.so()(64bit) is needed by firefox-3.0.5-1.el4.x86_64
[root@isdwks0034 Desktop]#
 
Old 01-28-2009, 09:36 AM   #2
TB0ne
Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 15,102

Rep: Reputation: 2719Reputation: 2719Reputation: 2719Reputation: 2719Reputation: 2719Reputation: 2719Reputation: 2719Reputation: 2719Reputation: 2719Reputation: 2719Reputation: 2719
Quote:
Originally Posted by manishgarg21 View Post
Hi,

I am facing problem for Firefox-3.0.5 on RHEL v4. I downloaded the rpms from RH website, it gave the error that few packages are missing, i down loaded the same and tried it, i am still not able to fix it. Here is the output for the whole process. Please help me in fixing the problem. Many thanks in advance. regards Manish.

error: Failed dependencies:
nspr >= 4.7.0.99.2 is needed by firefox-3.0.5-1.el4.x86_64
nss >= 3.11.99.5 is needed by firefox-3.0.5-1.el4.x86_64
libnssutil3.so()(64bit) is needed by firefox-3.0.5-1.el4.x86_64
[root@isdwks0034 Desktop]#
Ok..you're still missing dependencies. As it says above, in your error message, you're missing nspr and nss, or they're older than the versions stated. Upgrade those packages.
 
Old 01-29-2009, 03:41 AM   #3
manishgarg21
LQ Newbie
 
Registered: May 2008
Posts: 16

Original Poster
Rep: Reputation: 0
Thank you for the help.

Now i have installed nspr and nss also.
I could able to install firefox without any error.
However, i am still getting an error while launching the firefox. Here is the error also at the end i have posted pango-querymodules output as asked by the error below, may you please let me know what can be the reason.

************error
[manish.garg@isdwks0034 ~]$ firefox

(Gecko:26160): Pango-WARNING **: No builtin or dynamically
loaded modules were found. Pango will not work correctly.
This probably means there was an error in the creation of:
'/usr/evolution28/etc/pango/pango.modules'
You should create this file by running pango-querymodules.

(Gecko:26160): Pango-WARNING **: pango_shape called with bad font, expect ugly output

(Gecko:26160): Pango-WARNING **: pango_font_get_glyph_extents called with bad font, expect ugly output

(Gecko:26160): Pango-WARNING **: pango_shape called with bad shape_engine, expect ugly output

(Gecko:26160): GLib-GObject-CRITICAL **: g_object_get_qdata: assertion `G_IS_OBJECT (object)' failed

(Gecko:26160): Pango-CRITICAL **: pango_font_describe: assertion `font != NULL' failed
/usr/lib64/firefox-3.0.5/run-mozilla.sh: line 131: 26160 Segmentation fault "$prog" ${1+"$@"}
[manish.garg@isdwks0034 ~]$

And here is my pango-querymodules output:
*******
[root@isdwks0034 Desktop]# pango-querymodules-64
# Pango Modules file
# Automatically generated file, do not edit
#
# ModulesPath = /usr/lib64/pango/1.4.0/modules
#
/usr/lib64/pango/1.4.0/modules/pango-thai-fc.so ThaiScriptEngineFc PangoEngineShape PangoRenderFc thai:*/usr/lib64/pango/1.4.0/modules/pango-arabic-fc.so ArabicScriptEngineFc PangoEngineShape PangoRenderFc arabic:*/usr/lib64/pango/1.4.0/modules/pango-basic-x.so BasicScriptEngineX PangoEngineShape PangoRenderX common:/usr/lib64/pango/1.4.0/modules/pango-hangul-fc.so HangulScriptEngineFc PangoEngineShape PangoRenderFc hangul:*/usr/lib64/pango/1.4.0/modules/pango-hebrew-fc.so HebrewScriptEngineFc PangoEngineShape PangoRenderFc hebrew:*/usr/lib64/pango/1.4.0/modules/pango-basic-fc.so BasicScriptEngineFc PangoEngineShape PangoRenderFc armenian:* bopomofo:* cherokee:* coptic:* cyrillic:* deseret:* ethiopic:* georgian:* gothic:* greek:* han:* hiragana:* katakana:* latin:* ogham:* old-italic:* runic:* canadian-aboriginal:* yi:* braille:* cypriot:* limbu:* osmanya:* shavian:* linear-b:* ugaritic:* common:/usr/lib64/pango/1.4.0/modules/pango-indic-fc.so devaScriptEngineFc PangoEngineShape PangoRenderFc devanagari:*/usr/lib64/pango/1.4.0/modules/pango-indic-fc.so bengScriptEngineFc PangoEngineShape PangoRenderFc bengali:*/usr/lib64/pango/1.4.0/modules/pango-indic-fc.so guruScriptEngineFc PangoEngineShape PangoRenderFc gurmukhi:*/usr/lib64/pango/1.4.0/modules/pango-indic-fc.so gujrScriptEngineFc PangoEngineShape PangoRenderFc gujarati:*/usr/lib64/pango/1.4.0/modules/pango-indic-fc.so oryaScriptEngineFc PangoEngineShape PangoRenderFc oriya:*/usr/lib64/pango/1.4.0/modules/pango-indic-fc.so tamlScriptEngineFc PangoEngineShape PangoRenderFc tamil:*/usr/lib64/pango/1.4.0/modules/pango-indic-fc.so teluScriptEngineFc PangoEngineShape PangoRenderFc telugu:*/usr/lib64/pango/1.4.0/modules/pango-indic-fc.so kndaScriptEngineFc PangoEngineShape PangoRenderFc kannada:*/usr/lib64/pango/1.4.0/modules/pango-indic-fc.so mlymScriptEngineFc PangoEngineShape PangoRenderFc malayalam:*[root@isdwks0034 Desktop]#

Last edited by manishgarg21; 01-29-2009 at 03:45 AM.
 
Old 01-29-2009, 12:26 PM   #4
TB0ne
Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 15,102

Rep: Reputation: 2719Reputation: 2719Reputation: 2719Reputation: 2719Reputation: 2719Reputation: 2719Reputation: 2719Reputation: 2719Reputation: 2719Reputation: 2719Reputation: 2719
Quote:
Originally Posted by manishgarg21 View Post
Thank you for the help.

Now i have installed nspr and nss also.
I could able to install firefox without any error.
However, i am still getting an error while launching the firefox. Here is the error also at the end i have posted pango-querymodules output as asked by the error below, may you please let me know what can be the reason.

************error
[manish.garg@isdwks0034 ~]$ firefox

(Gecko:26160): Pango-WARNING **: No builtin or dynamically
loaded modules were found. Pango will not work correctly.
This probably means there was an error in the creation of:
'/usr/evolution28/etc/pango/pango.modules'
You should create this file by running pango-querymodules.
How about reading your error messages....it says above:

Quote:
You should create this file by running pango-querymodules.
Have you done it?
 
Old 01-29-2009, 10:35 PM   #5
manishgarg21
LQ Newbie
 
Registered: May 2008
Posts: 16

Original Poster
Rep: Reputation: 0
Hi,

I have tried the pango-querymodules-64, the output is shown at the end of my last post, same is shown below. Is it giving any clue? Thank you for the help.

[root@isdwks0034 manish.garg]# pango-querymodules-64
# Pango Modules file
# Automatically generated file, do not edit
#
# ModulesPath = /usr/lib64/pango/1.4.0/modules
#
/usr/lib64/pango/1.4.0/modules/pango-thai-fc.so ThaiScriptEngineFc PangoEngineShape PangoRenderFc thai:*
/usr/lib64/pango/1.4.0/modules/pango-arabic-fc.so ArabicScriptEngineFc PangoEngineShape PangoRenderFc arabic:*
/usr/lib64/pango/1.4.0/modules/pango-basic-x.so BasicScriptEngineX PangoEngineShape PangoRenderX common:
/usr/lib64/pango/1.4.0/modules/pango-hangul-fc.so HangulScriptEngineFc PangoEngineShape PangoRenderFc hangul:*
/usr/lib64/pango/1.4.0/modules/pango-hebrew-fc.so HebrewScriptEngineFc PangoEngineShape PangoRenderFc hebrew:*
/usr/lib64/pango/1.4.0/modules/pango-basic-fc.so BasicScriptEngineFc PangoEngineShape PangoRenderFc armenian:* bopomofo:* cherokee:* coptic:* cyrillic:* deseret:* ethiopic:* georgian:* gothic:* greek:* han:* hiragana:* katakana:* latin:* ogham:* old-italic:* runic:* canadian-aboriginal:* yi:* braille:* cypriot:* limbu:* osmanya:* shavian:* linear-b:* ugaritic:* common:
/usr/lib64/pango/1.4.0/modules/pango-indic-fc.so devaScriptEngineFc PangoEngineShape PangoRenderFc devanagari:*
/usr/lib64/pango/1.4.0/modules/pango-indic-fc.so bengScriptEngineFc PangoEngineShape PangoRenderFc bengali:*
/usr/lib64/pango/1.4.0/modules/pango-indic-fc.so guruScriptEngineFc PangoEngineShape PangoRenderFc gurmukhi:*
/usr/lib64/pango/1.4.0/modules/pango-indic-fc.so gujrScriptEngineFc PangoEngineShape PangoRenderFc gujarati:*
/usr/lib64/pango/1.4.0/modules/pango-indic-fc.so oryaScriptEngineFc PangoEngineShape PangoRenderFc oriya:*
/usr/lib64/pango/1.4.0/modules/pango-indic-fc.so tamlScriptEngineFc PangoEngineShape PangoRenderFc tamil:*
/usr/lib64/pango/1.4.0/modules/pango-indic-fc.so teluScriptEngineFc PangoEngineShape PangoRenderFc telugu:*
/usr/lib64/pango/1.4.0/modules/pango-indic-fc.so kndaScriptEngineFc PangoEngineShape PangoRenderFc kannada:*
/usr/lib64/pango/1.4.0/modules/pango-indic-fc.so mlymScriptEngineFc PangoEngineShape PangoRenderFc malayalam:*
[root@isdwks0034 manish.garg]#
 
Old 01-31-2009, 01:16 PM   #6
TB0ne
Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 15,102

Rep: Reputation: 2719Reputation: 2719Reputation: 2719Reputation: 2719Reputation: 2719Reputation: 2719Reputation: 2719Reputation: 2719Reputation: 2719Reputation: 2719Reputation: 2719
Quote:
Originally Posted by manishgarg21 View Post
Hi,

I have tried the pango-querymodules-64, the output is shown at the end of my last post, same is shown below. Is it giving any clue? Thank you for the help.

[root@isdwks0034 manish.garg]# pango-querymodules-64
# Pango Modules file
Have you tried Firefox after you've run this??

And why post messages, and ask someone else to interpret them for you? If you're confused or stuck, that's one thing, but saying "here's what it said, what does it mean?", when you don't say if you've even got an error, is another.

Read your error messages, do what they say.
 
Old 05-12-2009, 10:02 PM   #7
stojo01
LQ Newbie
 
Registered: May 2009
Posts: 1

Rep: Reputation: 0
I came across the last part of this problem during an install of Redhat Enterprise Linux 4
I installed the firefox package 3.0.1 provided on the install disks and it would not load. When i ran it from a terminal session it would not load but gave me the pango.modules error
To fix the problem i ran the /usr/bin/pango-querymodules-32 to create the modules file but then i had to copy the file to where firefox was looking for it
ie
cp /etc/pango/i386-redhat-linux-gnu/pango.modules /usr/evolution28/etc/pango/i686-redhat-linux-gnu/.
firefox worked after this
 
  


Reply

Tags
firefox, installation


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
RHEL 5 installation problem: need help iammasum Linux - Enterprise 14 10-27-2008 12:32 PM
RHEL 5 installation problem elthox Linux - Newbie 4 05-09-2008 05:53 AM
Installation Problem with RHEL AS 4.0 Update4 das711 Linux - Enterprise 3 12-27-2006 09:51 AM
RHEL 4 ES Installation problem pvlajith Red Hat 8 06-20-2006 02:24 AM
printing problem from Firefox RHEL 4.0 jdd66 Red Hat 3 06-08-2006 08:24 PM


All times are GMT -5. The time now is 04:05 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration