LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 11-14-2008, 11:30 PM   #1
smurthy
Member
 
Registered: Oct 2008
Location: KL Malaysia
Distribution: Fedora 9, Ubuntu Hardy, Puppy Linux
Posts: 32

Rep: Reputation: 16
Fedora 9 -system/desktop clock keeps changing


Hello,

I am new, so please bear with me, on what could be a silly question.

I have XP on hard drive /sdb and recently installed Fedora on a separate hard drive /sda. I boot into either by interrupting BIOS and changing boot priority as necessary.

When I set my system clock on XP to my time zone GMT+8, my Fedora clock shows GMT. When I reset the Fedora clock, my XP clock gets affected.

What is happening here and what am I doing wrong? I have seen four similar threads on this site, but couldn't see a solution.

Can somebody please help? More a nuisance than anything else for me.

murthy
 
Old 11-14-2008, 11:42 PM   #2
billymayday
Guru
 
Registered: Mar 2006
Location: Sydney, Australia
Distribution: Fedora, CentOS, OpenSuse, Slack, Gentoo, Debian, Arch, PCBSD
Posts: 6,678

Rep: Reputation: 122Reputation: 122
First, your computer only has one clock, so it has nothing to do with what drive you boot from, etc.

Unix's generally run time from UCT (old GMT), so the system clock by default will run UCT. Windows wants to run the clock at local time. Somewhere in the Fedora time setting there is a checkbox to tell Fedora that your system clock is or is not on UCT. Tell it it sin't.

I would guess that's the problem.
 
Old 11-15-2008, 12:20 AM   #3
smurthy
Member
 
Registered: Oct 2008
Location: KL Malaysia
Distribution: Fedora 9, Ubuntu Hardy, Puppy Linux
Posts: 32

Original Poster
Rep: Reputation: 16
Thanks. The Help documentation for the clock also seems to suggest that I should be able to do this. Went to the Fedora clock settings, but I don't appear to have a check box for UCT to check/uncheck.

Is there a file or something I can get at to change this?

murthy
 
Old 11-15-2008, 12:45 AM   #4
billymayday
Guru
 
Registered: Mar 2006
Location: Sydney, Australia
Distribution: Fedora, CentOS, OpenSuse, Slack, Gentoo, Debian, Arch, PCBSD
Posts: 6,678

Rep: Reputation: 122Reputation: 122
If you have /etc/sysconfig/clock, change UTC=true to UTC=false
 
Old 11-15-2008, 01:18 AM   #5
smurthy
Member
 
Registered: Oct 2008
Location: KL Malaysia
Distribution: Fedora 9, Ubuntu Hardy, Puppy Linux
Posts: 32

Original Poster
Rep: Reputation: 16
Hi,

My /etc/sysconfig/clock reads as follows:

# The ZONE parameter is only evaluated by system-config-date.
# The time zone of the system is defined by the contents of /etc/localtime.
ZONE="Asia/Kuala Lumpur"

I can't find system-config-date, and can't open /etc/localtime. There is a file called /etc/adjtime that reads as follows:

-3.594820 1226729150 0.000000
1226729150
UTC

Is this something I can / should change?


murthy
 
Old 11-15-2008, 01:34 AM   #6
billymayday
Guru
 
Registered: Mar 2006
Location: Sydney, Australia
Distribution: Fedora, CentOS, OpenSuse, Slack, Gentoo, Debian, Arch, PCBSD
Posts: 6,678

Rep: Reputation: 122Reputation: 122
Add UTC=false to /etc/sysconfig/clock
 
Old 11-15-2008, 02:15 AM   #7
smurthy
Member
 
Registered: Oct 2008
Location: KL Malaysia
Distribution: Fedora 9, Ubuntu Hardy, Puppy Linux
Posts: 32

Original Poster
Rep: Reputation: 16
Did what you said - changed file, shutdown, syncd clock to GMT+8 in XP, rebooted to Fedora but unfortunately didn't work.

Resetting the time each time I boot up is not a problem, but it really screws up the system logs!!

Oh well, maybe I shall just watch some cricket on TV.

Thanks for your help anyway!!

murthy
 
Old 11-15-2008, 02:20 AM   #8
billymayday
Guru
 
Registered: Mar 2006
Location: Sydney, Australia
Distribution: Fedora, CentOS, OpenSuse, Slack, Gentoo, Debian, Arch, PCBSD
Posts: 6,678

Rep: Reputation: 122Reputation: 122
I had a rather similar problem when I first installed F9. I never got a useful response on fedoraforum, and ended up reinstalling which fixed the problem. Perhaps you had a similar issue, but I really can't say for sure.

http://forums.fedoraforum.org/showthread.php?t=192789
 
Old 11-15-2008, 03:18 AM   #9
smurthy
Member
 
Registered: Oct 2008
Location: KL Malaysia
Distribution: Fedora 9, Ubuntu Hardy, Puppy Linux
Posts: 32

Original Poster
Rep: Reputation: 16
Thanks, I checked your Fedora thread and looks like you had an identical problem. Perhaps a re-install may help.

I just installed my Fedora and have spent a lot of time getting it to work right - so I am not in a hurry to re-install and start all over!! Time for me probably better spent learning some more on Linux.

murthy
 
Old 11-15-2008, 03:28 AM   #10
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 12,053

Rep: Reputation: 971Reputation: 971Reputation: 971Reputation: 971Reputation: 971Reputation: 971Reputation: 971Reputation: 971
Sometimes you just have to bite the bullet. I decided to try the Fedora 10 pre-release. Could not get the upgrade to work - kept failing at different points, on different packages. Didn't take long and the Fedora 9 system was totally hosed.

Full re-install using the same DVD (which I cut last night), and the on-line repos worked fine. Go figure.
Fedora 9 was me first foray into Redhat/Fedora since a fiasco in RH9. Maybe they still has a way to go to be "prime-time" ready.
 
Old 11-16-2008, 01:59 AM   #11
DCOH
Member
 
Registered: Oct 2006
Location: Ohio
Distribution: Fedora 13/14/15KDE/PclinuxOS
Posts: 95

Rep: Reputation: 16
In Fedora 9 or any other go to System > Administration >Date & Time goto Time zone and take check out of UTC at bottom.
 
Old 11-17-2008, 08:34 AM   #12
smurthy
Member
 
Registered: Oct 2008
Location: KL Malaysia
Distribution: Fedora 9, Ubuntu Hardy, Puppy Linux
Posts: 32

Original Poster
Rep: Reputation: 16
Smile

Thanks!! That worked real fine!! Windows and XP clocks in sync now!!

Really appreciate the help!!

murthy
 
Old 11-17-2008, 02:01 PM   #13
billymayday
Guru
 
Registered: Mar 2006
Location: Sydney, Australia
Distribution: Fedora, CentOS, OpenSuse, Slack, Gentoo, Debian, Arch, PCBSD
Posts: 6,678

Rep: Reputation: 122Reputation: 122
What was it that worked?
 
Old 11-17-2008, 08:36 PM   #14
smurthy
Member
 
Registered: Oct 2008
Location: KL Malaysia
Distribution: Fedora 9, Ubuntu Hardy, Puppy Linux
Posts: 32

Original Poster
Rep: Reputation: 16
billymayday, I do owe you an apology.

In your very first post, you told me right off the bat to go and find a check box with UCT on it and uncheck it. So I went to System-Administration-Date & Time, and read the Help document. The Help document said that there were three ways to access the settings 1) via Menu-System etc 2) via Time applet on the Desktop 3) by typing command system-config-time on a terminal.

I foolishly chose the applet option as the easiest, and found that the preferences there didn't have the UCT checkbox, despite the fact that the Help menu there also said there would be a UCT checkbox.

This time around, following DCOH's suggestion I went back again to System-Admin-Date&Time and found that the preference options included the UCT checkbox, that I unchecked. And now everything is fine.

I spent some time retracing my steps to find out why I didn't find the UCT box earlier, and only now realized, that to use the applet option I should be signed in as root to get the full menu. I was misled by a little icon on the panel that said I continued to have root privileges.

Again, I do apologize. You had the answer right away.
 
Old 11-22-2008, 10:51 PM   #15
trien27
Member
 
Registered: Feb 2005
Location: NYC
Distribution: Fedora 14
Posts: 195

Rep: Reputation: 15
UTC not UCT

It's UTC[Coordinated Universal Time], which used to be called GMT[Greenwich Mean Time], not UCT.

Check wikipedia's site on UTC here:
http://en.wikipedia.org/wiki/Coordinated_Universal_Time

Thanks for the help, especially DCOH.
I got rid of the problem by clicking on System --> Administration --> Date and Time --> signing on as root, then clicking on Time Zone tab, then unchecking System clock uses UTC at the bottom, then click on OK, and everything should be fine in Fedora Core 9 time wise.

Last edited by trien27; 11-22-2008 at 11:11 PM. Reason: additional information
 
  


Reply

Tags
clock


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Desktop clock not synced with system clock greenphreak Debian 5 08-22-2007 01:32 PM
System clock running too fast in fedora!! samgu3990 Fedora 1 03-06-2006 06:46 PM
System clock running too fast in fedora!! samgu3990 Linux - Software 1 03-06-2006 03:11 PM
changing desktop layout for all users of one system k4zau Linux - Software 0 09-06-2003 01:43 PM


All times are GMT -5. The time now is 05:14 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration