LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 08-04-2009, 01:19 PM   #1
MrUmunhum
Member
 
Registered: May 2006
Location: Mt Umunhum, CA, USA
Distribution: Debian/ Fedora
Posts: 409

Rep: Reputation: 33
FATAL: Module binfmt_misc not found.


Hi group,
I starting having this problem at boot time. In my rc.local I have rgese lines:
Code:
modprobe binfmt_misc

echo ':rexx:M::/*::/usr/bin/rexx:'     >> /proc/sys/fs/binfmt_misc/register
echo ':rexxcmd:E::cmd::/usr/bin/rexx:' >> /proc/sys/fs/binfmt_misc/register
All worked well for a long time, since FC5.

Now for some reason I get this:
Code:
$ modprobe binfmt_misc
FATAL: Module binfmt_misc not found.
FATAL: Error running install command for binfmt_misc
I am running Fedora Core 10 on a Fujitsu LifeBook.

Any ideas?

Thanks for your time.
 
Old 08-04-2009, 05:02 PM   #2
bathory
Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 10,884

Rep: Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322
It looks like your FC 10 kernel does not have the binfmt_misc module compiled in, unlike your old FC 5. If you still need it (to run rexx as I see in your rc.local), then you have to recompile your kernel adding it. Quoting from kernel help:
Quote:
CONFIG_BINFMT_MISC:
If you say Y here, it will be possible to plug wrapper-driven binary formats into the kernel. You will like this especially when you use programs that need an interpreter to run like Java, Python, .NET or Emacs-Lisp.
...
Once you have registered such a binary class with the kernel, you can start one of those programs simply by typing in its name at a shell prompt; Linux will automatically feed it to the correct interpreter.
...
To use binfmt_misc, you will need to mount it:
mount binfmt_misc -t binfmt_misc /proc/sys/fs/binfmt_misc You may say M here for module support and later load the module when you have use for it; the module is called binfmt_misc. If you don't know what to answer at this point, say Y.
Symbol: BINFMT_MISC [=m]
Prompt: Kernel support for MISC binaries
Defined at fs/Kconfig.binfmt:139
Location:
-> Executable file formats / Emulations
 
Old 08-05-2009, 12:58 PM   #3
MrUmunhum
Member
 
Registered: May 2006
Location: Mt Umunhum, CA, USA
Distribution: Debian/ Fedora
Posts: 409

Original Poster
Rep: Reputation: 33
It was working

Quote:
Originally Posted by bathory View Post
It looks like your FC 10 kernel does not have the binfmt_misc module compiled in, unlike your old FC 5. If you still need it (to run rexx as I see in your rc.local), then you have to recompile your kernel adding it. Quoting from kernel help:
It was working until about a week ago. I just updated the kernel and it still is broken.
 
Old 08-05-2009, 05:19 PM   #4
bathory
Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 10,884

Rep: Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322
Quote:
$ modprobe binfmt_misc
FATAL: Module binfmt_misc not found.
FATAL: Error running install command for binfmt_misc
Try to run it as root and see what happens.
Also what is the output of
Code:
grep BINFMT_MISC /boot/config-`uname -r`
 
Old 08-06-2009, 01:45 PM   #5
MrUmunhum
Member
 
Registered: May 2006
Location: Mt Umunhum, CA, USA
Distribution: Debian/ Fedora
Posts: 409

Original Poster
Rep: Reputation: 33
Quote:
Originally Posted by bathory View Post
Try to run it as root and see what happens.
Also what is the output of
Code:
grep BINFMT_MISC /boot/config-`uname -r`
$ grep BINFMT_MISC /boot/config-`uname -r`
500:CONFIG_BINFMT_MISC=y

[root@laptop ~]# modprobe binfmt_misc
FATAL: Module binfmt_misc not found.
FATAL: Error running install command for binfmt_misc
 
Old 08-06-2009, 03:33 PM   #6
bathory
Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 10,884

Rep: Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322
So you have binfmt_misc built-in the kernel and not as a module. This means that you can skip the modprobe command and use the rest to do what you want.
 
Old 08-07-2009, 12:41 PM   #7
MrUmunhum
Member
 
Registered: May 2006
Location: Mt Umunhum, CA, USA
Distribution: Debian/ Fedora
Posts: 409

Original Poster
Rep: Reputation: 33
Quote:
Originally Posted by bathory View Post
So you have binfmt_misc built-in the kernel and not as a module. This means that you can skip the modprobe command and use the rest to do what you want.
But it is not working. Not sure why?
 
Old 08-07-2009, 01:07 PM   #8
MrUmunhum
Member
 
Registered: May 2006
Location: Mt Umunhum, CA, USA
Distribution: Debian/ Fedora
Posts: 409

Original Poster
Rep: Reputation: 33
fixed

Quote:
Originally Posted by MrUmunhum View Post
But it is not working. Not sure why?
OK, I figured it out. The problem was that the entry pointed /usr/local/bin/rexx and not /usr/bin/rexx. Don't know why this has changed?
The quick fix was 'sudo ln -s /usr/bin/rexx /usr/local/bin/rexx'.
This was the give away.
Code:
# cat /proc/sys/fs/binfmt_misc/rexx
enabled
interpreter /usr/local/bin/rexx
flags: 
offset 0
magic 2f2a
Working on proper fix.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
FATAL: Module off not found. cov Linux - Hardware 1 09-10-2007 04:19 PM
[SOLVED] Fatal Module not found Bryan7 Slackware 2 12-03-2006 01:02 AM
FATAL: Module usbvision not found. bhomass Debian 2 11-20-2005 11:09 PM
Fatal: Module radeon not found. _InTeNsDoWn_ Linux - Newbie 8 05-10-2005 03:06 PM
FATAL - no usb module found fenice1976 Linux - Software 2 05-19-2004 02:02 PM


All times are GMT -5. The time now is 10:19 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration