LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 05-21-2008, 08:03 AM   #1
clvic
Member
 
Registered: Feb 2008
Location: Rome, Italy
Distribution: OpenSuSE 11.x, vectorlinux, slax, Sabayon
Posts: 206
Blog Entries: 2

Rep: Reputation: 44
ext3 commit interval on root device


Hi,
I want to use laptop mode and remount my journaled filesystems with long commit intervals... anyway this is ok with my /home filesystem, but when I try to remount my / filesystem, nothing changes.
That is, I do:
mount -o remount,commit=600 /dev/dm-1
but then the output of mount shows nothing about the "commit=" option, while for /home this works.
dmes and /var/log/messages log nothing when I execute this command... is it possible at all to remount the root device with a non-default commit interval?
 
Old 05-21-2008, 08:58 AM   #2
unSpawn
Moderator
 
Registered: May 2001
Posts: 27,286
Blog Entries: 54

Rep: Reputation: 2854Reputation: 2854Reputation: 2854Reputation: 2854Reputation: 2854Reputation: 2854Reputation: 2854Reputation: 2854Reputation: 2854Reputation: 2854Reputation: 2854
Does 'mount / -o remount,commit=600' work? BTW 10m is a long time. If you don't care for journalling, why not forget about it and mount as ext2 instead?
 
Old 05-21-2008, 09:05 AM   #3
clvic
Member
 
Registered: Feb 2008
Location: Rome, Italy
Distribution: OpenSuSE 11.x, vectorlinux, slax, Sabayon
Posts: 206
Blog Entries: 2

Original Poster
Rep: Reputation: 44
Thank you for your answer. No, also your suggestion does not work.
Yes I know 10m is maybe too much, well it's only an example, no other value works anyway. I do want journalling, but I want to disable it whenever I want, for energy saving (and curiosity). And changing the filesystem type on-the-fly is not possible anyway, so it's not suitable for laptop-mode scripts
 
Old 05-21-2008, 06:41 PM   #4
unSpawn
Moderator
 
Registered: May 2001
Posts: 27,286
Blog Entries: 54

Rep: Reputation: 2854Reputation: 2854Reputation: 2854Reputation: 2854Reputation: 2854Reputation: 2854Reputation: 2854Reputation: 2854Reputation: 2854Reputation: 2854Reputation: 2854
Quote:
Originally Posted by clvic View Post
No, also your suggestion does not work.
W/o command and output I can not react on anything. Maybe file a bug report.


Quote:
Originally Posted by clvic View Post
I do want journalling, but I want to disable it whenever I want, for energy saving
I think ditching eyecandy will get you bigger energy savings than mutilating journalling.


Quote:
Originally Posted by clvic View Post
changing the filesystem type on-the-fly is not possible
That's your interpretation. I didn't say you should do that OTF.

Last edited by unSpawn; 05-22-2008 at 06:48 AM.
 
Old 05-22-2008, 04:07 AM   #5
clvic
Member
 
Registered: Feb 2008
Location: Rome, Italy
Distribution: OpenSuSE 11.x, vectorlinux, slax, Sabayon
Posts: 206
Blog Entries: 2

Original Poster
Rep: Reputation: 44
Quote:
Originally Posted by unSpawn View Post
I think ditching eyecandy will get you bigger energy savings than mutilating journalling.
I agree with you... say I want to know it for curiosity!

Quote:
Originally Posted by unSpawn View Post
That's your interpreation. I didn't say you should do that OTF.
Sorry I didn't mean you said that... anyway I think I'll look for bug reports and in case file a new one.
Thank you
 
  


Reply

Tags
ext3, journal


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
cvs [commit aborted]: 'root' is not allowed to commit files r_ramya06 Linux - Newbie 5 07-08-2008 09:04 AM
Block device /dev/sda3 is not a valid root device.. rincewind Linux - Hardware 7 06-09-2006 04:47 AM
ext3 - No space left on device Anne H Linux - Enterprise 4 02-17-2006 02:24 PM
Ext3 warnings on a loop device andreseso Linux - Hardware 2 12-09-2004 09:47 PM
ext3-fs warning device ext3_clear_journal sKiZZiT Red Hat 3 10-31-2004 02:26 PM


All times are GMT -5. The time now is 05:25 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration