LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 09-17-2008, 10:39 AM   #1
MarkEHansen
LQ Newbie
 
Registered: Dec 2006
Posts: 19

Rep: Reputation: 0
Error: Missing Dependency: libsysfs.so.1 is needed by package iputils


I'm using CentOS 4.6 on an Intel-based pc, and have been using 'yum' to keep the O/S up to date.

Within about the last three days, I found that yum wanted to install updates to what looks like all packages, but when I attempt to update, I get the following error:

Error: Missing Dependency: libsysfs.so.1 is needed by package iputils

When I looked, my system includes libsysfs.so.2 from the package sysfsutils-2.0.0-1.

Is CentOS 4.6 still supported? I realize that at some point, I will have to upgrade my machine to a more recent version of CentOS, but that will take a lot of effort, and I'm just trying to put it off as long as possible.

Is there any way I can get yum to continue updating my CentOS 4.6 release?


My .repo files (/etc/yum.repos.d/) include the following repositories:

[base]
mirrorlist=http://mirrorlist.centos.org/?release=$releasever&arch=$basearch&repo=os

[update]

mirrorlist=http://mirrorlist.centos.org/?release=$releasever&arch=$basearch&repo=os

[addons]

mirrorlist=http://mirrorlist.centos.org/?release=$releasever&arch=$basearch&repo=os

[extras]

mirrorlist=http://mirrorlist.centos.org/?release=$releasever&arch=$basearch&repo=os

[centosplus]

mirrorlist=http://mirrorlist.centos.org/?release=$releasever&arch=$basearch&repo=os

[contrib]

mirrorlist=http://mirrorlist.centos.org/?release=$releasever&arch=$basearch&repo=os

[dag]

mirrorlist=http://mirrorlist.centos.org/?release=$releasever&arch=$basearch&repo=os
 
Old 09-17-2008, 10:56 AM   #2
w3bd3vil
Senior Member
 
Registered: Jun 2006
Location: Hyderabad, India
Distribution: Fedora
Posts: 1,189

Rep: Reputation: 49
Try making a copy of libsysfs.so.2 with name libsysfs.so.1
 
Old 09-17-2008, 05:43 PM   #3
MarkEHansen
LQ Newbie
 
Registered: Dec 2006
Posts: 19

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by w3bd3vil View Post
Try making a copy of libsysfs.so.2 with name libsysfs.so.1
Thanks, but that didn't help. It still complains. I'm not sure how that would help anyway, as I thought the yum utility looked at the packages that were installed to determine what was missing, not files in the file system.

Anyway, isn't the fact the iputils appears to depend on libsysfs.so.1 a bug in that package? Clearly, the version that is currently on my system doesn't depend on that (because it is on my system, running fine).

I can't really live without iputils, so eliminating that from my system isn't a good solution either.

Can anyone help?

Thanks,
 
Old 09-17-2008, 06:17 PM   #4
w3bd3vil
Senior Member
 
Registered: Jun 2006
Location: Hyderabad, India
Distribution: Fedora
Posts: 1,189

Rep: Reputation: 49
Generally a copy or a sym link works. And yum doesnt necessarily look for only packages.

What is probably happening is that the repos are creating a conflict, you should be able to bypass this error if you try a single repo. Try hashing out a some of them and check.
 
Old 09-18-2008, 09:19 AM   #5
MarkEHansen
LQ Newbie
 
Registered: Dec 2006
Posts: 19

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by w3bd3vil View Post
Generally a copy or a sym link works. And yum doesnt necessarily look for only packages.

What is probably happening is that the repos are creating a conflict, you should be able to bypass this error if you try a single repo. Try hashing out a some of them and check.
Thank you for your help. I'm a bit confused by this, as I thought each of the repositories were required (except for the 'dag', which I'm using for some non-distribution packages). To list them again, I have:

[base]
[update]
[addons]
[extras]
[centosplus]
[contrib]
[dag]

I commented out all but [base] and [update], and the problem still exists.

Is this a problem with my system? Wouldn't everyone trying to update CentOS 4.6 using yum run into this?

Is there a different set of repositories that I should point my configuration at?

Thanks again for the help.
 
Old 09-18-2008, 01:02 PM   #6
w3bd3vil
Senior Member
 
Registered: Jun 2006
Location: Hyderabad, India
Distribution: Fedora
Posts: 1,189

Rep: Reputation: 49
Sometimes some of the repos arent updated properly, which causes the error. It could also be that there is some cached content which is causing the problem, so you could try "yum clean all".
Your repos are already pointing to a random list you wouldnt need to change it.

Obviously, I do not have a definite explanation for this...thats why I am giving you the most probable work arounds.
 
Old 09-18-2008, 01:23 PM   #7
w3bd3vil
Senior Member
 
Registered: Jun 2006
Location: Hyderabad, India
Distribution: Fedora
Posts: 1,189

Rep: Reputation: 49
One thing, you could also try updating iputils by downloading and updating through rpm/tar and see what that spills out.
 
Old 09-19-2008, 11:03 AM   #8
MarkEHansen
LQ Newbie
 
Registered: Dec 2006
Posts: 19

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by w3bd3vil View Post
One thing, you could also try updating iputils by downloading and updating through rpm/tar and see what that spills out.
Thank you very much for your help with this.

I did try clearing out the yum cache (using yum clean all), but that
didn't change the error. I did notice that yum re-build the cache,
downloading all the headers again, etc., so it seems the clean did
what it was supposed to do.

The version of iputils which yum wants to upgrade my CentOS 4.6 system
with is iputils-20020927-21.e14.i386, which looks to be from the CentOS 4.7 release.

However, I downloaded this specific RPM and tried to upgrade my system
using:

rpm -U -v -h iputils-20020927-21.e14.i386.rpm

(after having downloaded the RPM file from one of the CentOS mirrors)
and received the same error:

=====================================================================
error: Failed dependencies:
libsysfs.so.1 is needed by iputils-20020927-21.el4.i386
Suggested resolutions:
/home/buildcentos/CENTOS/en/4.0/i386/CentOS/RPMS/sysfsutils-1.2.0-1.i386.rpm
=====================================================================

But of course, my CentOS 4.6 system already has a newer version of the
sysfs package, so I don't think I should install the older version.

It seems like the iputils RPM was built with the wrong dependency.

Is it possible that I'm the only person left still trying to update my
CentOS 4.6 system with yum? I was hoping that whatever group is
responsible for building the RPM/yum update sets would notice the
error and correct it, but it's been over a week now, and it still
fails.

Again, thank you for being so patient with me. Do you have any other
suggestions?

Best Regards,
 
Old 09-19-2008, 04:55 PM   #9
w3bd3vil
Senior Member
 
Registered: Jun 2006
Location: Hyderabad, India
Distribution: Fedora
Posts: 1,189

Rep: Reputation: 49
The last thing that I can help you with, would again be my first post.
Could you paste the location of libsysfs.so.2.
locate libsysfs.so.2 or find.
 
Old 09-19-2008, 05:54 PM   #10
MarkEHansen
LQ Newbie
 
Registered: Dec 2006
Posts: 19

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by w3bd3vil View Post
The last thing that I can help you with, would again be my first post.
Could you paste the location of libsysfs.so.2.
locate libsysfs.so.2 or find.
Sorry. If you asked for the location earlier, I must have missed it.
libsysfs.so.2 is located in /usr/local/lib. I ran "rpm -q --list" on
the sysfsutils-2.1.0-1 package, and it shows the file in this location
as well.

Oh... I see what you're getting at. Yes, after looking, I see that
some time ago, I downloaded sysfsutils-2.1.0-1.i386.rpm, as this was
required by the latest lm-sensors package (which I also downloaded
and installed).

lm-sensors isn't working right now anyway (it requires a newer kernel
than what is on my machine). I've removed the libsysfs package and now
yum gets past the transaction check.

Thanks for all your help (and patience). I'll give the update and
go now and see how it progresses.

Best Regards,
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Error: Missing Dependency: python(abi) = 2.4 is needed by package rhnlib etc... punt Linux - Software 8 09-06-2013 08:26 AM
Error: Missing Dependency: libdts.so.0 is needed by package mplayer slackergeek Fedora 5 06-07-2008 09:20 AM
Error: Missing Dependency: kdelibs3 >= 3.5.8 is needed by package koffice-libs Dr_Death_UAE Linux - General 4 11-13-2007 03:33 PM
PHP5 Upgrade Error: Missing Dependency: php = 4.3.x is needed by package php-pear vsystems Linux - Server 1 05-02-2007 07:17 AM
Error: Missing Dependency: libwpd-1.so.7 is needed by package abiword tmick Fedora 9 10-11-2005 12:06 PM


All times are GMT -5. The time now is 01:32 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration