LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 01-26-2005, 12:39 PM   #1
davcefai
Member
 
Registered: Dec 2004
Location: Malta
Distribution: Debian Sid
Posts: 764

Rep: Reputation: 32
Error Messages with new Kernel


I have compiled the Mandrake 2.6.3-19 kernel, having heavily modified the config.

Can anybody tell me what these messages about the symbol struct_module mean and how to fix them:

Jan 26 18:48:26 localhost kernel: Resuming from device hdf5
Jan 26 18:48:26 localhost kernel: Resume Machine: This is normal swap space
Jan 26 18:48:26 localhost kernel: RAMDISK: Compressed image found at block 0
Jan 26 18:48:26 localhost kernel: VFS: Mounted root (ext2 filesystem).
Jan 26 18:48:26 localhost kernel: scsi_mod: disagrees about version of symbol struct_module
Jan 26 18:48:26 localhost kernel: libata: disagrees about version of symbol struct_module
Jan 26 18:48:26 localhost kernel: sata_via: disagrees about version of symbol struct_module
Jan 26 18:48:26 localhost kernel: sd_mod: disagrees about version of symbol struct_module
Jan 26 18:48:26 localhost kernel: jbd: disagrees about version of symbol struct_module
Jan 26 18:48:26 localhost kernel: mbcache: disagrees about version of symbol struct_module
Jan 26 18:48:26 localhost kernel: ext3: disagrees about version of symbol struct_module

The system boots, I'm writing this using the new kernel, but I'm uneasy about this and don't dare use it for serious work until I can get a clean boot.
 
Old 01-26-2005, 01:01 PM   #2
Matir
Moderator
 
Registered: Nov 2004
Location: San Jose, CA
Distribution: Ubuntu
Posts: 8,507

Rep: Reputation: 118Reputation: 118
Well, it seems like you are resuming from a swap partition... that is VERY dangerous if you are booting using a different kernel version than the suspend-data was created with.
 
Old 01-26-2005, 04:20 PM   #3
davcefai
Member
 
Registered: Dec 2004
Location: Malta
Distribution: Debian Sid
Posts: 764

Original Poster
Rep: Reputation: 32
Solved it!

(Hangs head in shame)

I had an error in lilo.conf and was booting kernel 2.6.3-19 with initrd 2.6.3-7

Now I need to find out why my nvidia driver is being replaced by the nv driver. Probably because I need to reinstall the nvidia driver but I'm off to bed now.

Thanks for the reply.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Kernel 2.4.7 Compile error messages~ help me? leeysa Linux - Software 2 03-09-2005 08:22 PM
strange error messages when recompiling kernel. levicc00123 Slackware 8 12-21-2004 11:00 PM
Kernel - error messages... posible bug Qucho Debian 3 05-02-2004 02:10 AM
Getting some error messages after upgrading kernel... Whitehat Slackware 2 01-04-2004 08:10 AM
Warnings and error messages during kernel compile rdaves@earthlink.net Linux - Software 2 09-19-2001 07:45 PM


All times are GMT -5. The time now is 03:57 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration