LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 03-19-2003, 01:20 AM   #1
correro
Member
 
Registered: Oct 2002
Distribution: RedHat 8.0
Posts: 140

Rep: Reputation: 15
Error messages when launching apps from shell prompt


Sometimes when I launch an utility or application from the shell prompt, I get weird messages which I cannot interpret.

(1) When starting Nautilus, KWrite, LICQ, I get the same message:

Authentication Rejected, reason : None of the authentication protocols specified are supported and host-based authentication failed.

(2) When starting redhat-config-printer, I get

(redhat-config-printer:1692): GLib-GObject-CRITICAL **: file gobject.c: line 972 (g_object_get): assertion `G_IS_OBJECT (object)' failed


And yet, these utilities/apps do run properly.

I just wonder what causes these errors and how I can fix them.
 
Old 03-25-2003, 07:58 PM   #2
chrisk5527
Member
 
Registered: Oct 2002
Location: Michigan
Distribution: Slackware Linux 10.0
Posts: 289

Rep: Reputation: 30
Make sure your not launching these programs as root, if so, try it without it. And if the problem still exisits, recompile the glib-gobject-* libraries.
 
Old 03-25-2003, 08:20 PM   #3
correro
Member
 
Registered: Oct 2002
Distribution: RedHat 8.0
Posts: 140

Original Poster
Rep: Reputation: 15
like you said, the error messages were due to the fact that i started these applications as root.

thanks, chris!

but why?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Error launching gnome apps as root: " Failed to contact configuration server" Kropotkin Fedora 1 12-16-2005 12:11 PM
Launching Apps rjkfsm Linux - Newbie 3 07-11-2005 08:44 PM
Error with shared libs when launching apps Joe Soap Debian 0 02-19-2005 09:15 AM
libstartup-notification error when launching apps gyost Fedora 1 12-25-2004 08:47 PM
shell error messages not displayed as a message box!!! user222 Linux - General 10 10-25-2004 02:11 AM


All times are GMT -5. The time now is 08:45 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration