LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - General (http://www.linuxquestions.org/questions/linux-general-1/)
-   -   Error message about 'libatk-bridge' whenever I run Gnome applications (http://www.linuxquestions.org/questions/linux-general-1/error-message-about-libatk-bridge-whenever-i-run-gnome-applications-747684/)

mark_alfred 08-14-2009 10:50 PM

Error message about 'libatk-bridge' whenever I run Gnome applications
 
Hello. I get the error message, "Gnome-WARNING **: Accessibility: failed to find module 'libatk-bridge' which is needed to make this application accessible" whenever I run Gnome applications, such as gedit. Is this something I should be concerned about? Otherwise the applications work, but I do get the error message whenever I use them.

I use Fluxbox, and not Gnome, on Debian Lenny. Note, I do have libatk1.0-0, libatk1.0-data, and libatk1.0-dbg packages installed.

knudfl 08-15-2009 02:46 AM

'/usr/lib/gtk-2.0/modules/libatk-bridge.so'
is from the package " at-spi "

... You could try reinstalling 'at-spi' ...

So far, it is a warning, not an error :
A warning is an information only, and when
everything is working, probably no reason
to worry.
.....

mark_alfred 08-15-2009 12:57 PM

Thanks. I installed at-spi, so now the module 'libatk-bridge' is found. However, it now reads,

Code:

mark@debian:~$ gedit

(gedit:3322): atk-bridge-WARNING **: AT_SPI_REGISTRY was not started at session startup.

(gedit:3322): atk-bridge-WARNING **: IOR not set.

(gedit:3322): atk-bridge-WARNING **: Could not locate registry

So, to hell with it. Gnome programs whine too much. Goodbye gedit, hello leafpad. Goodbye brasero, hello k3b. Goodbye sound-juicer, hello ripperx. Goodbye totem, hello smplayer. Goodbye rhythmbox, hello moc (mocp). Etc. Whining gnomes are no longer welcome on my computer.


All times are GMT -5. The time now is 07:26 AM.