LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - General (http://www.linuxquestions.org/questions/linux-general-1/)
-   -   Editing /etc/DIR_COLORS does not change colours in terminal (http://www.linuxquestions.org/questions/linux-general-1/editing-etc-dir_colors-does-not-change-colours-in-terminal-341232/)

ethics 07-08-2005 07:02 AM

Editing /etc/DIR_COLORS does not change colours in terminal
 
Hi all,

i'm trying to change the default colours for files/directories/etc in my terminal (a term), i did some looking around and found that i need to edit /etc/DIR_COLORS

so i did, following the comment lines i added

term aterm

and edited the colour values, yet it remains the same, i logged out and in again but still nothing, even copied the file into ~/ but that didnt work.

Is there some aterm config or somethign over writing these settings.

Thanks for your time

seran 07-08-2005 07:51 AM

Did you copied /etc/DIR_COLORS in to your home directory as .dir_colors ?

The /etc/DIR_COLORS file says.....

# Configuration file for the color ls utility
# This file goes in the /etc directory, and must be world readable.
# You can copy this file to .dir_colors in your $HOME directory to override
# the system defaults.


I tried this sometime before, and it works fine for me.

TruckStuff 07-08-2005 08:50 AM

are you sure you are trying to view the listing w/ colors? e.g. ls --color==tty

ethics 07-08-2005 07:22 PM

I'm pretty sure it's using colours, the directories appear blue etc.

trickykid 07-08-2005 07:46 PM

Try a:

Code:

source /etc/profile
And see if that changes your colors.. it's called upon one of your bash startup scripts, usually the /etc/profile has the bit about DIR COLORS in it..

VibeOfOurTribe 08-11-2005 10:41 PM

I was also having this problem, but then after much frustration found the answer. I noticed that there were actually two files: /etc/DIR_COLORS and /etc/DIR_COLORS.xterm then i noticed that echo $TERM returned "xterm". If this is your case, like it was mine, you have two options:

1) edit /etc/DIR_COLORS.xterm according to man /etc/DIR_COLORS

or

2) add these two lines to ~/.bash_profile

TERM=xterm-color
export TERM

StevenXL 02-27-2014 01:56 AM

Did anyone ever figure this out? I am having the same problems.

I have a .dir_colors in my home directory; I have added TERM=xterm-color and export TERM to my .bashrc; and I have added d=$HOME/.dir_colors as well as eval 'dircolors $HOME/.dir_colors" and the colors still don't seem to change.


All times are GMT -5. The time now is 01:45 AM.