LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - General (http://www.linuxquestions.org/questions/linux-general-1/)
-   -   dump + restore to backup linux ; "Couldn't find matching filesystem: LABEL=/" on boot (http://www.linuxquestions.org/questions/linux-general-1/dump-restore-to-backup-linux-%3B-couldnt-find-matching-filesystem-label%3D-on-boot-30884/)

markus1982 09-21-2002 08:53 AM

dump + restore to backup linux ; "Couldn't find matching filesystem: LABEL=/" on boot
 
Just used dump -0 -f root.dump /dev/hdb7 to backup my linux root filesystem. I used restore rf dump.tar on another partition (hdb8) to restore the filesystem then!

Afterwards I removed hdb7 using fdisk, wrote the changes and rebooted.


Now on the boot up proccess I get a problem:
Couldn't find matching filesystem: LABEL=/


The filesystem is there and it holds ALL the files like the original ones does.


Contents of /etc/fstab
Code:

LABEL=/                /                      ext2    defaults        1 1
none                    /dev/pts                devpts  gid=5,mode=620  0 0
none                    /proc                  proc    defaults        0 0
none                    /dev/shm                tmpfs  defaults        0 0
/dev/hdb2              swap                    swap    defaults        0 0
/dev/cdrom              /mnt/cdrom              iso9660 noauto,owner,kudzu,ro 0 0


Contents of /etc/mtab
Code:

/dev/hdb7 / ext2 rw 0 0
none /proc proc rw 0 0



I got that contents after rebooting with the RH rescue cd and just mounting the partition manually and copying those 2 files ...



Anybody knows what to do to fix that? Cause actually the system SHOULD be working!

orgcandman 09-21-2002 12:05 PM

you might try...
 
Maybe I'm totally wrong on this, but your fstab looks a little screwed up.
I think the LABEL=/ should be replaced with whatever device your / FS is on. (IE: /dev/hda1)


org

markus1982 09-21-2002 12:13 PM

well normally mtab is used for that purpose afaik. but i'm not 100% sure, well i didn't try changing the fstab so far, maybe that will do the job. trying that now ... will post the result in a few mins i bet!

markus1982 09-21-2002 12:32 PM

fs label's
 
Well the only problem at all is that the file system has had NO VOLUME LABEL! So what needs to be done is setting the volume label. This can be done using tune2fs.

Like you can read in the tun2fs manpage:
...
Code:

      -L volume-label
              Set  the  volume  label  of  the  filesystem.  Ext2
              filesystem labels can  be  at  most  16  characters
              long; if volume-label is longer than 16 characters,
              tune2fs will truncate it and print a warning.  The
              volume  label can be used by mount(8), fsck(8), and
              /etc/fstab(5) (and possibly others)  by  specifying
              LABEL=volume_label  instead  of  a  block  special
              device name like /dev/hda5.

So this is the solution :)

acid_kewpie 09-21-2002 01:16 PM

all that, or use e2label. the point of labels is so that you don't need to specify a rigid partition name, as if you mess around with partitions, split some and such, the partitions will naturally change their number, which will screw things up. if they are given their own name then they won't get lost..


All times are GMT -5. The time now is 05:37 AM.