LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - General (http://www.linuxquestions.org/questions/linux-general-1/)
-   -   Dual-booting Mandrake & Slackware: Kernel panic: VFS: Unable to mount root fs (http://www.linuxquestions.org/questions/linux-general-1/dual-booting-mandrake-and-slackware-kernel-panic-vfs-unable-to-mount-root-fs-220834/)

vasudevadas 08-22-2004 05:21 AM

Dual-booting Mandrake & Slackware: Kernel panic: VFS: Unable to mount root fs
 
Hi all,

I see Slackware gets raved about here, so I thought I'd try it and see what all the fuss is about.

I am actually finding it harder to get two Linux distributions to coexist on my computer than it was to get Mandrake and Windows to sit alongside each other, which is not what I was expecting. Anyway, here's the problem.

I have the following partitions:

/dev/hde1 (ReiserFS) Mandrake root partition (bootable)
/dev/hde3 (ReiserFS) Slackware root partition (bootable)
/dev/hde4 (ReiserFS) Slackware home partition
/dev/hde5 (Linux swap) Swap partition
/dev/hde6 (ext3) Mandrake home partition

Just to prove it, here is my /etc/fstab from my Mandrake install:

Code:

/dev/hde1 / reiserfs notail,defaults 1 1
none /dev/pts devpts mode=0620 0 0
/dev/hde6 /home ext3 defaults 1 2
/dev/hda /mnt/cdrom auto umask=0,user,iocharset=iso8859-15,codepage=850,noauto,ro,exec 0 0
/dev/hdb /mnt/cdrom2 auto umask=0,user,iocharset=iso8859-15,codepage=850,noauto,ro,exec 0 0
none /mnt/floppy supermount dev=/dev/fd0,fs=ext2:vfat,--,umask=0,iocharset=iso8859-15,sync,codepage=850 0 0
none /proc proc defaults 0 0
/dev/hde4 /slackhome reiserfs notail,defaults 1 2
/dev/hde3 /slackroot reiserfs notail 1 2
/dev/hde5 swap swap defaults 0 0

So the Mandrake bootloader on hde1 gets used when the machine is powered on, and Mandrake can start up OK. Slackware installed its bootloader on the first sector of hde3, and obviously that is not being used.

I tried to set up lilo on hde1 so that it can boot Slackware too, by giving it the following entry in /etc/lilo.conf:

Code:

# File generated by DrakX/drakboot
# WARNING: do not forget to run lilo after modifying this file

boot=/dev/hde
map=/boot/map
default="Mandrake"
keytable=/boot/uk.klt
prompt
nowarn
timeout=100
message=/boot/message
menu-scheme=wb:bw:wb:bw
disk=/dev/hde bios=0x80
<snip>
image=/boot/vmlinuz
        root=/dev/hde3
        label="Slackware"
        read-only
<snip>

However, when I try to boot Slackware, I get "Kernel panic: VFS: Unable to mount root fs on hde3". The only way I can boot into Slackware is to use the boot floppy that I created when I installed it. Obviously this is not acceptable (it takes too long, for one thing!)

I must be going about this all wrong. Can anybody help?

RestInPieces 08-22-2004 07:03 AM

make sure you have the ReiserFS filesistem supported by your kernel (you may need to recompile your kernel to add that) then, in your lilo.conf make sure you have specified the correct path to "root="

vasudevadas 08-22-2004 07:06 AM

Surely the Slackware setup program would not have defaulted the partitions to reiser if the kernel shipped did not support it? The correct path to root is specified, as you can see in the lilo.conf extract I posted above. Please correct me if I'm wrong.

RestInPieces 08-22-2004 08:43 AM

well..it may be the bootloader... can't there be conflicts between those two? Slackware installs lilo,but it offers an option to skip the instalation... maybe if you skip it and reconfigure your bootloader from Mandrake... this won't happen :)
just a thought tho... :D

mdg 08-22-2004 09:25 AM

If you're booting Slackware with the Mandrake bootloader, the "image=/boot/vmlinuz" line will send lilo to look for the Slack kernel image in the Mdk /boot directory and will load the wrong kernel.

You have this line in fstab
Code:

/dev/hde3 /slackroot reiserfs notail 1 2
so you should reflect that in lilo.conf
Code:

image=/slackroot/boot/vmlinuz
I assume you made a "slackroot" dir in Mdk /

vasudevadas 08-22-2004 04:43 PM

Quote:

Originally posted by mdg
You have this line in fstab
Code:

/dev/hde3 /slackroot reiserfs notail 1 2
so you should reflect that in lilo.conf
Code:

image=/slackroot/boot/vmlinuz

Oh aye, that worked a charm. Thanks a lot you two! :D

Now I have a zillion other things that I need to sort out, first boot of a new distro and all, but this isn't the place to discuss them!


All times are GMT -5. The time now is 02:59 PM.