LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 03-16-2004, 01:32 AM   #1
mickboda
Member
 
Registered: Jul 2002
Location: Sydney
Distribution: Kubuntu Edgy
Posts: 74

Rep: Reputation: 15
dmask=,fmask=,umask= ARGHHHHHHH


Hi all,

Firstly, if you know a good site that covers "mounting windows drives via /etc/fstab" and don't want to read this long post, please post the link ....

My distro is a fully updated redhat 8.0 installation. I want to mount windows shares using /etc/fstab

I have set up icons on the desktop to each drive, but they won't allow me to mount as a user. here is the relevant section of the /etc/fstab file. All the mentioned drives mount and are readable as root using mount -a from console.

//server/dropbox1 /mnt/dropbox1 smbfs uid=root,password=,rw,dmask=0000,fmask=0000,umask=0000
//server/dropbox2 /mnt/dropbox2 smbfs uid=root,password=,rw,dmask=0000,fma
sk=0000,umask=0000
//server/dropbox3 /mnt/dropbox3 smbfs uid=root,password=,rw,dmask=0000,fma
sk=0000,umask=0000

I would like users to be able to mount the drives and have read, write and execute permissions.

I have run chmod a+s smbmnt. I did the same to smbmount, but apparently this is a really bad idea, so I THINK I have fixed that.

Here the Permissions for smbmnt and smbmount incase the problem lay here.

-rwsr-sr-x 1 root root 560774 Apr 6 2003 smbmnt
-rwxr-xr-x 1 root root 571222 Apr 6 2003 smbmount

Because I can log in and access the drives as root, I don't think the following is where the problem is, but a full picture.....

I have an e-smith server which acts as the internet/DHCP server. The windows box 'server' is another machine on the network. it has three drives shared as dropbox1, 2 & 3 respectively. There is no login required on the box and it runs Win98 SE. The drives are shared with user access. the network logon is set to Windows Logon for the win98 box.

I used to be able to mount samba shares from the e-smith server using

//esmith/esmithr_bay /mnt/esmith smbfs username=nobody,password=,dmask=0777,fmask=0777,user,auto,user,rw 0 0

This string does not appear to work when editted to accomodate the win98 'server' settings.

Any help appreciated.

Mick
 
Old 03-16-2004, 04:32 AM   #2
bigearsbilly
Senior Member
 
Registered: Mar 2004
Location: england
Distribution: FreeBSD, Debian, Mint, Puppy
Posts: 3,287

Rep: Reputation: 173Reputation: 173
Ain't it just to add
"user" in the fstab options?

have you had a good read of the mount man page?


billy
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Why is fmask & dmask required to write to a WinXP share mounted on Mdrake SMB client ruscook_oz Linux - Networking 1 02-08-2007 05:50 PM
getting fat32 (Win98SE) part to mount with dmask and fmask options Simon Bridge Linux - General 3 06-22-2005 01:50 AM
smbmnt,fmask=,dmask=,umask= ARRGGHHH mickboda Linux - Networking 3 12-23-2004 05:04 PM
umask,dmask,fmask mmm Linux - General 1 08-14-2003 12:29 AM
umask Spaz17 Linux - Newbie 1 07-04-2003 10:12 AM


All times are GMT -5. The time now is 07:09 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration