LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 12-06-2012, 08:27 AM   #1
mbzadegan
Member
 
Registered: Jul 2011
Location: Beside of Andromeda !
Distribution: ♥♥ Just Kernel ♥♥ ( LFS )
Posts: 76

Rep: Reputation: Disabled
Question Disabling Root Autologin on Backtrack ( UBUNTU ) ?


Hi Linux User ,
When i boot my BackTrack_5r3 ( ubuntu base ) , it login automatically with root access !
How i could configure it to autologin with my user that i created with adduser command ?
 
Old 12-06-2012, 12:19 PM   #2
malekmustaq
Senior Member
 
Registered: Dec 2008
Location: /root
Distribution: Slackware & BSD
Posts: 1,218

Rep: Reputation: 231Reputation: 231Reputation: 231
There are ways to overcome this. For security reason put down first all network devices "~# ifconfig eth0 down" or whatever device you are connected: to isolate your box for a moment.

1. Use the GUI application in (KDE or whatever) Menu -> System -> Users and Groups -> then disable auto-login for root.
...or if this doesn't work,

2. At GUI application utility try to locate "Sessions" then disable auto-login from there.
...or if this doesn't work, try

3.
Quote:
~# usermod --password "WritE_A_diFf1cult_PaSsw0rD" root
Try reboot and login as root at runlevel 3 find out if you are prompted for password.

Please furnish us with further information if none of those work so that we are better equipped to analyze what is going on.

Hope that helps.

Last edited by malekmustaq; 12-06-2012 at 12:21 PM.
 
1 members found this post helpful.
Old 12-07-2012, 01:10 PM   #3
mbzadegan
Member
 
Registered: Jul 2011
Location: Beside of Andromeda !
Distribution: ♥♥ Just Kernel ♥♥ ( LFS )
Posts: 76

Original Poster
Rep: Reputation: Disabled
Thanks for Guide ,
with your command i could login with my user BUT I COULD NOT LOGIN WITH ROOT after run usermod command because didn't accept my root password !
How can login with both root & user ?
 
Old 12-07-2012, 01:32 PM   #4
malekmustaq
Senior Member
 
Registered: Dec 2008
Location: /root
Distribution: Slackware & BSD
Posts: 1,218

Rep: Reputation: 231Reputation: 231Reputation: 231
Okay if there is no way you can login the root account reboot to a live CD ( this means your install hard drive partition is not at work, since you are booting from a liveCD ).

Running liveCD get into terminal;
mount the / partition of that installed backtrack;
cd into the /mnt/backtrack/etc...
then edit by any means comfortable to you "vi" "emacs" "gedit" "nano" "vim" this file:

Quote:
gedit shadow
find, look for, and remove that exclamation mark " ! " before or beside the password of the root line. Usually looks like this:

root:!wiEs[x\$*+dLOEs[nn$^xsXPgdElgsPlD;!wS.xx:xxxxxxx:x:::::

NOTE: Don't change anything else: just delete/remove that exclamation mark " ! " Save and exit.

Reboot and try login as root.

Hope that helps.

Good luck.

Last edited by malekmustaq; 12-07-2012 at 01:40 PM.
 
Old 12-07-2012, 11:38 PM   #5
mbzadegan
Member
 
Registered: Jul 2011
Location: Beside of Andromeda !
Distribution: ♥♥ Just Kernel ♥♥ ( LFS )
Posts: 76

Original Poster
Rep: Reputation: Disabled
Dear malekmustaq ,

The first raw of my /etc/shadow is :
root:$5$TGhjecA4n$Ll8LwV8QqsKvIUZCr4P1bXbdQszMVptRMHpjRRiIDcC:15587:0:::::

i don't find any ! exclamation !
 
Old 12-08-2012, 03:29 AM   #6
malekmustaq
Senior Member
 
Registered: Dec 2008
Location: /root
Distribution: Slackware & BSD
Posts: 1,218

Rep: Reputation: 231Reputation: 231Reputation: 231
Okay, thanks, I see now there is no " ! " exclamation in your /etc/passwd: 'root' line.
You may now "Delete" that single post above, that's something personal and security matter: be careful not to post anything like that for your security.

Now we go back to the problem.

When you login as root at runlevel 3 what does it say?
Please post us also the output of "~# dmesg | tail" so that we will know what is happening.

Dont' worry there is always an easy solution to that problem. You can even delete the passwd entry from the /etc/passwd 'root' line so that you can re-enter without password:

Delete whatever lies in-between the two colons " : " e.g.--
Quote:
root:zzzzzzzzz8QqsKvIUZCr4P1bXbdQszMVptRzzzzzzzzzzzzzzzzzzzzz:15587:0:::::
so that the two colons will look like contagious:
Quote:
"root::15587:0:::::"
I have done this with a regular $USER account, but have not yet tried it with ROOT.

Reboot and try to login as root. If you happen to be able to login as root right then and there from the terminal issue command
Quote:
~# passwd <Enter>
to change your password to a new one.

And please post back whatever the system spouts out in complaint or error so that we (helpers) are also appraised properly and seek proper solutions. So far WHAT I AM TELLING ARE BASED IN PURE GUESS and assumptions because your feedback is very wanting.

Last edited by malekmustaq; 12-08-2012 at 03:37 AM.
 
1 members found this post helpful.
Old 12-08-2012, 04:48 AM   #7
mbzadegan
Member
 
Registered: Jul 2011
Location: Beside of Andromeda !
Distribution: ♥♥ Just Kernel ♥♥ ( LFS )
Posts: 76

Original Poster
Rep: Reputation: Disabled
Thanks Dear malekmustaq
It's solved by your hints !
 
Old 12-08-2012, 11:41 AM   #8
malekmustaq
Senior Member
 
Registered: Dec 2008
Location: /root
Distribution: Slackware & BSD
Posts: 1,218

Rep: Reputation: 231Reputation: 231Reputation: 231
Quote:
Originally Posted by mbzadegan View Post
Thanks Dear malekmustaq
It's solved by your hints !
Congratulations!
Glad to hear.

So, you may now mark this thread as "Solved".
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Activating/Disabling the autologin videoediting Programming 3 04-05-2005 10:44 PM
Autologin as root - how? tomcat22 Debian 9 10-15-2004 06:27 PM
disabling autologin nacha Debian 5 05-30-2004 05:45 PM
Autologin under Lindows, not root lectraplayer Linux - Newbie 2 03-06-2004 08:47 PM
disabling x-windows autologin in Suse .0 ako Linux - Newbie 6 02-11-2004 01:30 AM


All times are GMT -5. The time now is 02:12 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration