LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - General (http://www.linuxquestions.org/questions/linux-general-1/)
-   -   disable ssh-timout after some idle time (http://www.linuxquestions.org/questions/linux-general-1/disable-ssh-timout-after-some-idle-time-386429/)

papa_anarchia 11-25-2005 11:51 AM

disable ssh-timout after some idle time
 
Hi,

Iīm using Cygwin/X to remotely log into a linux-box. After some idle time, the session is closed.

<remotehostusername>.#Read from remote host <remotehost>: Connection reset by peer. Connection to <remotehost> closed.

I wonder where I could disable this default kick-the-idle-client behaviour?

After reading /etc/ssh/sshd_configsīs man page I could not figure out how to neither could I after giving my useraccountīs .bashrc of Cygwin a try.

Google told me, that ssh-sessions donīt get reset by the daemon, is that correct? Could anybody give me a hint from preventing the sshd to kick me and thus having to login again?

Regards

papa_anarchia 11-25-2005 03:38 PM

..ok, I re-read some stuff and actually this seems to do the trick.
To /etc/ssh/sshd_config I added:

ClientAliveInterval 1800
Protocol 2

What Iīm not quite sure about is, whether I just think I do not get kicked within half an hour due to the mentioned entry in sshd_conf, or if the default for logging me off the is higher anyway.

Hm?


All times are GMT -5. The time now is 09:38 AM.