LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices


Reply
  Search this Thread
Old 02-27-2007, 05:43 PM   #1
ZiGz
LQ Newbie
 
Registered: Feb 2007
Posts: 5

Rep: Reputation: 0
disable sleep mode, away mode standby, etc.


Hey all,

I'm running Gnome on Fedora Core 6. I am (was) using acpid. I want to disable "away" or sleep mode because this comp is hooked up to some "monitoring" screens which display an automatically refreshing webpage 24x7 to look fancy. I have tried the following already:

-disabled screensaver in gnome
-service stop acpid (ps -ef still shows [kacpid] and not even a kill -9 will stop it. is this pertinent?)
-there are no power save options in the BIOS, just options for what devices can bring it out of sleep mode

just in case it had anything to do with the monitor i've done "xset -dpms" and "xset dpms 0 0 0" and commented out Option DPMS in my xorg. Now the screen still goes black after 20 mins or so, but the monitors stay on

Is there anything else i can try?!? why is it still doing it, ive completely shut off the acpi daemon. grawrrr! If nothing else, I was thinking of making a cron script that spawns an gnome terminal then closes it right away or some crap. anyone else have a better suggestion?

Thanks very much guys!

Last edited by ZiGz; 02-27-2007 at 05:45 PM.
 
Old 02-27-2007, 07:36 PM   #2
Matir
LQ Guru
 
Registered: Nov 2004
Location: San Jose, CA
Distribution: Ubuntu
Posts: 8,507

Rep: Reputation: 122Reputation: 122
Is the PC still running? If the power lights on the monitor stay green/constant, I'd be inclined to think it was. Does it INSTANTLY resume when you move the mouse?

If this is the case, it doesn't seem like acpi so much as a screensaver-esque problem.
 
Old 02-28-2007, 12:04 PM   #3
ZiGz
LQ Newbie
 
Registered: Feb 2007
Posts: 5

Original Poster
Rep: Reputation: 0
nah the computer powers down :/. gotta wiggle the mouse, takes 3-4 seconds for the comp to come back on. If screensaver was enabled it would prompt for password
 
Old 02-04-2008, 12:32 AM   #4
wolverine5
LQ Newbie
 
Registered: Feb 2008
Distribution: openSuse
Posts: 1

Rep: Reputation: 0
guys I have same problem, I have laptop I want to use as small server, how to turn off moniotor? when I close lid it goes to sleep. Is there a way to change way linux behave when I close lid or set monitor to turn off (real turn off not just some stupid black screen) ?
 
Old 06-19-2016, 01:15 PM   #5
wfc988
LQ Newbie
 
Registered: Apr 2016
Location: Iowa
Distribution: Linux Mint 17.3 Rosa
Posts: 12

Rep: Reputation: Disabled
sleep/power saving mode

Update to 17.3 mint 64/b from 32/b system, and as was the case with the 32/b here comes the monitor going into save/sleep mode, I came across this ytube site,
Published on Feb 6, 2015
Caffeine Indicator For Linux Mint (Ubuntu) : Temporarily Disable Screensaver, Screenlock & Sleep Mode

Commands :
sudo add-apt-repository ppa:caffeine-developers/ppa
sudo apt-get update
sudo apt-get install caffeine

I have used it with the 17.2 and now with 17.3 64/b. It works for me, thought I would pass this info along. Hope it helps out someone.

Update, It seems that caffeine is not always doing it's job, and more so. Back to the drawing board, came across some info on ubuntu site, list here about kernel options, acpi=off, Went to my menu, search box and type in acpi and it came up with a number of packages to install, read down through the list and found info about sleep/hibernation, and Power Manager. Installed package and the P.Manager is listed right under P. Management in the Preference Tab, it has the capabilities to handle the sleep/hib mode. I set my preferences and so far so good.
Hopefully this will take care of the 10min sleep mode for me, again hope this will help other.
Romans 10v9,10

Last edited by wfc988; 06-27-2016 at 01:36 PM. Reason: update
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
standby mode bruse Linux - Newbie 1 04-29-2005 03:18 AM
Standby Mode hansi umayangan Linux - General 3 03-11-2005 10:54 PM
disable standby mode? wimva Linux - Newbie 7 09-23-2003 09:06 AM
Standby Mode LinuxTiro Linux - General 4 09-12-2003 03:59 AM
Network Connection in Sleep/Standby Mode ucdstudent Linux - Newbie 1 01-16-2002 06:25 PM


All times are GMT -5. The time now is 05:01 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration