LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - General (http://www.linuxquestions.org/questions/linux-general-1/)
-   -   disable sleep mode, away mode standby, etc. (http://www.linuxquestions.org/questions/linux-general-1/disable-sleep-mode-away-mode-standby-etc-533069/)

ZiGz 02-27-2007 05:43 PM

disable sleep mode, away mode standby, etc.
 
Hey all,

I'm running Gnome on Fedora Core 6. I am (was) using acpid. I want to disable "away" or sleep mode because this comp is hooked up to some "monitoring" screens which display an automatically refreshing webpage 24x7 to look fancy. I have tried the following already:

-disabled screensaver in gnome
-service stop acpid (ps -ef still shows [kacpid] and not even a kill -9 will stop it. is this pertinent?)
-there are no power save options in the BIOS, just options for what devices can bring it out of sleep mode

just in case it had anything to do with the monitor i've done "xset -dpms" and "xset dpms 0 0 0" and commented out Option DPMS in my xorg. Now the screen still goes black after 20 mins or so, but the monitors stay on :rolleyes:

Is there anything else i can try?!? why is it still doing it, ive completely shut off the acpi daemon. grawrrr! If nothing else, I was thinking of making a cron script that spawns an gnome terminal then closes it right away or some crap. anyone else have a better suggestion?

Thanks very much guys!

Matir 02-27-2007 07:36 PM

Is the PC still running? If the power lights on the monitor stay green/constant, I'd be inclined to think it was. Does it INSTANTLY resume when you move the mouse?

If this is the case, it doesn't seem like acpi so much as a screensaver-esque problem.

ZiGz 02-28-2007 12:04 PM

nah the computer powers down :/. gotta wiggle the mouse, takes 3-4 seconds for the comp to come back on. If screensaver was enabled it would prompt for password

wolverine5 02-04-2008 12:32 AM

guys I have same problem, I have laptop I want to use as small server, how to turn off moniotor? when I close lid it goes to sleep. Is there a way to change way linux behave when I close lid or set monitor to turn off (real turn off not just some stupid black screen) ?

wfc988 06-19-2016 01:15 PM

sleep/power saving mode
 
Update to 17.3 mint 64/b from 32/b system, and as was the case with the 32/b here comes the monitor going into save/sleep mode, I came across this ytube site,
Published on Feb 6, 2015
Caffeine Indicator For Linux Mint (Ubuntu) : Temporarily Disable Screensaver, Screenlock & Sleep Mode

Commands :
sudo add-apt-repository ppa:caffeine-developers/ppa
sudo apt-get update
sudo apt-get install caffeine

I have used it with the 17.2 and now with 17.3 64/b. It works for me, thought I would pass this info along. Hope it helps out someone.

Update, It seems that caffeine is not always doing it's job, and more so. Back to the drawing board, came across some info on ubuntu site, list here about kernel options, acpi=off, Went to my menu, search box and type in acpi and it came up with a number of packages to install, read down through the list and found info about sleep/hibernation, and Power Manager. Installed package and the P.Manager is listed right under P. Management in the Preference Tab, it has the capabilities to handle the sleep/hib mode. I set my preferences and so far so good.
Hopefully this will take care of the 10min sleep mode for me, again hope this will help other.
Romans 10v9,10


All times are GMT -5. The time now is 05:55 PM.