LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices



Reply
 
Search this Thread
Old 12-04-2013, 12:23 PM   #1
newbiesforever
Senior Member
 
Registered: Apr 2006
Location: Glendale, AZ
Distribution: Distro-homeless. Lost.
Posts: 1,886

Rep: Reputation: 62
device is listed with wrong mount point


I have been unable to mount a certain USB device. Eventually, while trying everything to mount it, I saw what's surely the problem: the device is /dev/sdc1 but the system says its mount point is /dev/sdb1, which another USB device is using. Actually, I just tried to open that device and can't open that either. Except in a file manager running as root.

I have no idea how this would have happened, unless perhaps I confused the system by plugging these USB devices into different ports while the computer was on (which I did yesterday)...? Anyway, how do I change the mount point?

Last edited by newbiesforever; 12-04-2013 at 01:18 PM.
 
Old 12-04-2013, 01:20 PM   #2
lleb
Senior Member
 
Registered: Dec 2005
Location: Florida
Distribution: CentOS/Fedora
Posts: 2,582

Rep: Reputation: 480Reputation: 480Reputation: 480Reputation: 480Reputation: 480
thats simple, its no different then under MS Windows. the device is NOT flagged by any special means and is just mounted in a willy nilly order so to speak. What ever device goes live first is sdb, then sdc, etc...

Just think about USB Printers in Windows. Its installed, its running, but god help you if you unplug it and plug it back in, you will be prompted to install new hardware and start amassing multiple copies of the same printer and none but the last one will work.

Or you plug your USB drive into Windows, today its drive letter E:/ tomorrow you have an other USB device plugged in, you plug in what was E yesterday, but today its F:/

its all the same.

if you want to get around that, the a few things need to happen.

1. disable the automagical mounting of USB devices
2. create a script combined with labels on the flash drive.
3. mount the specific label to your desired location
OR
4. learn udev rules and customize each device for mounting at specific points into the system

you can also stop using drive letter and use drive mapping:

https://liquidat.wordpress.com/2007/...of-hard-disks/

as each device once formatted is unique.
 
1 members found this post helpful.
Old 12-04-2013, 01:40 PM   #3
273
Senior Member
 
Registered: Dec 2011
Location: UK
Distribution: Debian Sid AMD64, Raspbian Wheezy, various VMs
Posts: 3,565

Rep: Reputation: 804Reputation: 804Reputation: 804Reputation: 804Reputation: 804Reputation: 804Reputation: 804
Just to clarify:
The files at /dev/sd* are not mount points they are simply files that connect to hard disk drives (sda, sdb) and partitions on those (sda1, sdb1). The mount point is where you mount that with a command like "mount /dev/sdb1 /media/me/kingston_usb_stick". To access a partition through your file manager you need to mount it somewhere. Where it mounts will probably be down to udev and, if it is, the drive is in my experience mounted in either /media/ or /media/username as a folder named after its label.
 
1 members found this post helpful.
Old 12-04-2013, 11:28 PM   #4
sunilpopaliya
Member
 
Registered: Apr 2012
Posts: 45

Rep: Reputation: Disabled
Hello,

Unplug problematic USB and then Plug it again and after that check output of dmesg command. It will show device name of newly mounted USB.

After that you can see how many partitions this particular USB drive has by running fdisk -l command. Then you can mount any partition of that USB drive.



Thanks
======
sunil
 
1 members found this post helpful.
Old 12-07-2013, 09:53 PM   #5
frankbell
Guru
 
Registered: Jan 2006
Location: Virginia, USA
Distribution: Slackware, Mageia, Mint
Posts: 8,243

Rep: Reputation: 1556Reputation: 1556Reputation: 1556Reputation: 1556Reputation: 1556Reputation: 1556Reputation: 1556Reputation: 1556Reputation: 1556Reputation: 1556Reputation: 1556
Alternatively, you could put it in /etc/fstab using the UUID.

Here's an example from my fstab. You might want to use the "noauto" flag if you don't want it to automount.

Code:
UUID=1655a198-15a7-471f-9e99-e3fc9fd92ca0       /media/sdb1     ext3    rw,user,auto    0      1
Here's a good article about using UUID in /etc/fstab; it's the one I used.

http://www.cyberciti.biz/faq/linux-f...-update-fstab/
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Mount point by device ID yo8rxp Linux - Hardware 5 01-08-2013 02:09 PM
Mount Point for Tape device shubhamuddu Linux - Newbie 6 07-10-2012 04:46 AM
Mount problem - device already mounted or mount point busy zahoo Linux - General 7 08-28-2009 06:02 PM
Partition table problem. fdis is lying to me, shows the wrong mount point I believe imtedkaczynski Slackware 6 12-05-2008 11:41 AM
find mount point given device kornelix Programming 2 04-13-2007 10:01 AM


All times are GMT -5. The time now is 12:52 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration