LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 05-04-2008, 12:29 PM   #1
shogun1234
Member
 
Registered: May 2004
Posts: 165

Rep: Reputation: 15
device descriptor read/all, error -71


I encounter a problem when plugging on my usb drive. Previously this error did not exist (All my usb devices worked fine in the past, including mouse and hard disk). The error in dmesg is as follow:

Code:
usb 4-3: new high speed USB device using ehci_hcd and address 2
usb 4-3: device descriptor read/all, error -71
usb 4-3: new high speed USB device using ehci_hcd and address 3
usb 4-3: device descriptor read/64, error -71
usb 4-3: device descriptor read/64, error -71
usb 4-3: new high speed USB device using ehci_hcd and address 4
usb 4-3: device not accepting address 4, error -71
usb 4-3: new high speed USB device using ehci_hcd and address 5
usb 4-3: device descriptor read/all, error -71
If I do 'modprobe -r ehci_hcd' and 'modprobe ehci_hcd', then the usb can be found. However, more often it does not work. I can not mount or find sda* in the /dev through 'ls /dev/sda*' command.

How to solve this problem?

Thank you very much,

Env: Debian lenny testing/ kernel 2.6.24.2/ gcc (GCC) 4.2.3 20071123 (prerelease) (Debian 4.2.2-4).

Last edited by shogun1234; 05-04-2008 at 12:31 PM.
 
Old 09-04-2008, 09:09 AM   #2
toni_uk
LQ Newbie
 
Registered: May 2008
Posts: 18

Rep: Reputation: 0
shogun,had the same problem. Not sure whether youhave solved but here is the solution I found just yesterday:

http://www.linuxquestions.org/questi...2/#post3269374
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Read-error on swap-device(9:0:8) andyknvs Linux - Newbie 2 02-27-2008 02:29 AM
device descriptor read/8, error -110 seagate external hard drive genex Linux - Hardware 1 09-08-2007 12:40 PM
Simultaneous Asynchronous write and read on same descriptor mikepol Programming 1 06-23-2007 07:51 AM
how to know how many bytes can read from a descriptor? (C/C++) Thinking Programming 6 10-28-2005 12:46 PM
canoscan n670u device read error shellcode Linux - General 3 09-19-2004 01:20 AM


All times are GMT -5. The time now is 05:41 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration