LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices



Reply
 
Search this Thread
Old 01-05-2012, 10:57 PM   #1
rajaniyer123
Member
 
Registered: Feb 2004
Location: BARODA, GUJARAT
Posts: 259

Rep: Reputation: 30
Dependency Issue while installing rpm


Hi,

While installing libXpm-3.5.5-3.x86_64.rpm i got below error please let me know it points out to which package.

OS is RHEL 4

libc.so.6(GLIBC_2.4)(64bit) is needed by libXpm-3.5.5-3.x86_64
rtld(GNU_HASH) is needed by libXpm-3.5.5-3.x86_64



Thanks
Rajan
 
Old 01-06-2012, 12:25 AM   #2
askandstudy
LQ Newbie
 
Registered: Jan 2012
Posts: 3

Rep: Reputation: Disabled
[root@RHEL6A Packages]# rpm --whatprovides -q 'rtld'
no package provides rtld
[root@RHEL6A Packages]# rpm --whatprovides -q 'libc.so.6'
glibc-2.12-1.7.el6.i686
[root@RHEL6A Packages]#

---------- Post added 01-06-12 at 01:26 PM ----------

Or view this:
https://bugzilla.redhat.com/show_bug.cgi?id=206247
 
Old 01-06-2012, 01:00 AM   #3
John VV
Guru
 
Registered: Aug 2005
Posts: 13,481

Rep: Reputation: 1803Reputation: 1803Reputation: 1803Reputation: 1803Reputation: 1803Reputation: 1803Reputation: 1803Reputation: 1803Reputation: 1803Reputation: 1803Reputation: 1803
RHEL4 is old
you will not be able to install a new version on it
you might but not easily

also RHEL 4 was NOT free
is this an older version using "up2date"
or a newer version of 4 ( like 4.9 ) that has "yum" installed

seeing as you ARE paying for the Required EXTENDED Life support contract - for the continued support of 4 ( you do have a license ? )

ask red hat
http://www.redhat.com/support/

libxpm.so.4 is in the old el4 "xorg-x11-libs"
use up2date or yum ( if installed)
 
Old 01-06-2012, 04:28 AM   #4
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2014.08, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 14,273

Rep: Reputation: 2663Reputation: 2663Reputation: 2663Reputation: 2663Reputation: 2663Reputation: 2663Reputation: 2663Reputation: 2663Reputation: 2663Reputation: 2663Reputation: 2663
The el4 packages containing libXpm are like :

( xorg-x11-6.8.2-1.EL.63.x86_64.rpm )
xorg-x11-libs-6.8.2-1.EL.63.x86_64.rpm
xorg-x11-devel-6.8.2-1.EL.63.x86_64.rpm
http://mirror.centos.org/centos/4.9/...4/CentOS/RPMS/
Provides /usr/X11R6/lib64/libXpm.so libXpm.a libXpm.so.4 libXpm.so.4.11

..

Last edited by knudfl; 01-06-2012 at 04:36 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
RH 8.0 - Minimal package install- RPM dependency issue johnrams Red Hat 3 02-17-2009 09:32 PM
Fedora 9 dependency errors when installing R 2.7.1.rpm gareth_t Linux - Newbie 5 08-16-2008 07:43 PM
centos & madwifi rpm madness (weird dependency issue) angryfirelord Linux - Wireless Networking 3 10-05-2006 04:35 PM
rpm dependency issue afrodocter Linux - Software 1 04-15-2004 03:58 PM
rpm dependency issue edverb Linux - Newbie 9 03-04-2003 04:20 AM


All times are GMT -5. The time now is 09:58 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration