LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 10-07-2001, 08:17 AM   #1
hagenuk
LQ Newbie
 
Registered: Aug 2001
Posts: 7

Rep: Reputation: 0
Unhappy Denied access by squid


I have just installed squid on RH 7.1 at home for all my home 5 pc, but client pc/server itself was denied access when using Netscape. Why ? Is my ACL correct ?

Squid Pc
-------------
eth0 - 192.168.0.1(home network)
eth1 - 202.100.100.50(Connected to ISP Broadband)

Client IP from 192.168.0.1 - 192.168.0.200


Squid.conf
---------------
http_port 8080
acl all src 0.0.0.0/0.0.0.0
acl home src 192.168.0.0/16
acl ownself1 src 202.100.100.50/255.255.255.255
acl ownself2 src 192.168.0.1/255.255.255.255
acl manager proto cache_object
acl localhost src 127.0.0.1/255.255.255.255
acl SSL_ports port 443 563
acl Safe_ports port 80 21 443 563 70 210 1025-65535
acl Safe_ports port 280 # http-mgmt
acl Safe_ports port 488 # gss-http
acl Safe_ports port 591 # filemaker
acl Safe_ports port 777 # multiling http
acl CONNECT method CONNECT

#Default configuration:
http_access allow manager
http_access deny manager
http_access deny !Safe_ports
http_access deny CONNECT !SSL_ports

# INSERT YOUR OWN RULE(S) HERE TO ALLOW ACCESS FROM YOUR CLIENTS
http_access allow home own1 own2
http_access deny all
 
Old 10-07-2001, 10:45 AM   #2
DavidPhillips
Guru
 
Registered: Jun 2001
Location: South Alabama
Distribution: Fedora / RedHat / SuSE
Posts: 7,154

Rep: Reputation: 56
Your squid config file has acl ownself1 and ownself2 ...your access has own1 and own2 which are not defined.


there is no http_access localhost, only a definition.

Squid is listening on port 8080, You need to allow clients to access this port, you may have firewall rules that block it.

the following ipchains rules may be useful in setting up a transparent proxy.


ipchains -A input -p TCP -d 0/0 www -j REDIRECT 8080

or iptables

iptables -t nat -A PREROUTING -i eth0 -p tcp --dport 80 -j REDIRECT --to-port 8080


or at least you need to allow port 8080.

iptables -A tcp_packets -p TCP -s 0/0 --dport 8080 -j allowed
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Squid Access Denied Help eurekaguy4u Linux - Networking 21 04-29-2010 10:30 AM
Squid url port 81 access-denied error steve@korehicom.com Linux - Networking 0 10-13-2005 09:55 AM
squid access denied hariiyer Linux - Networking 2 10-30-2004 09:55 AM
Access Denied Using Squid Lucinda Linux - Software 8 06-10-2004 06:30 AM
squid comes back with message 'access denied' mhs1973 Linux - Networking 4 02-08-2002 11:17 PM


All times are GMT -5. The time now is 04:42 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration