LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 11-22-2006, 01:52 AM   #1
peter88
LQ Newbie
 
Registered: Nov 2006
Posts: 20

Rep: Reputation: 0
cyrillic, unicode fonts not displaying under FC5


If I have a simiple text file with a mixture of Cyrillic and English
fonts, and saved as unicode under a W32 system say W2000 or XP and I take it to my FC5 2.6.16.29 system (under KDE) and try to open it using

Vim I see many @@@@@ signs and if I try to open it with kwrite it opens
and I see most of the text but it warns me that the file is binary and
saving it will corrupt it.

Can someone guide me as to how I can get cyrillic fonts to appear properly in my file and unicode fonts in general. I thought when I did
the installation, I installed the langages I wish to use like Russian,
French, German etc.

As an extension to this question, I notice that when I play <cyrillic titles>.mp3 songs in XMMS the Russian fonts do not appear properly. Anyway I can get Ru/Cyrillic song titles and Tags to appear properly under FC5 ?

TIA
 
Old 11-22-2006, 01:39 PM   #2
exvor
Senior Member
 
Registered: Jul 2004
Location: Phoenix, Arizona
Distribution: LFS-Version SVN-20091202, Arch 2009.08
Posts: 1,485

Rep: Reputation: 66
Has something to do with the charecter encoding for the system. You set this in the kernel when its compiled. You need to compile in support to handel the fonts and then enable them.
 
Old 11-23-2006, 11:39 PM   #3
peter88
LQ Newbie
 
Registered: Nov 2006
Posts: 20

Original Poster
Rep: Reputation: 0
cyrillic, unicode fonts not displaying under FC5

OK, does anyone know which are the relevant parameters in the kernel config file I need to tweek to get cyrillic or unicode compiled into the kernel under FC5 and FC6 ?

TIA.
 
Old 11-26-2006, 11:07 PM   #4
peter88
LQ Newbie
 
Registered: Nov 2006
Posts: 20

Original Poster
Rep: Reputation: 0
unicode fonts not displaying under FC5

After some further research, the following may be of use to others. I am using FC5 kernel v2.6.16.29, running KDE

Frankly I am not sure if after the initial installation where u specify which languages u wish to use that any further kernel compilation is required but perhaps someone can clarify this.

I did not appear to have cyrillic fonts installed under KDE, try following to
see if u have them installed.

xlsfonts | grep cyrillic -- however for .rpm packges installed it wont show. Use:

rpm -qa *cyrillic*
rpm -qa *KOI*

xfontsel -- should display the fonts available to the system but I had limited success with it.

Unfortuately despite the above fonts .rpm's installed I still had the problem.

If you are in KDE go Control Center -> Regional and Accessibility -> Country, Region and Language, pick Russia, and most of the menus go Cyrillic (I think all the KDE components).

The various editors still use the Roman alphabet, but you can also change the keyboard layout in the Control Center, and the application font. So maybe it is not so hard to have a complete Cyrillic setup inside KDE.

Add russian fonts in KDE via: (Control Center->System Administration->Font Installer).

It appears that windows fonts will work too if u cannot find Linux/cyrillic fonts.

For XMMS use the fonts setting to change to cyrillic once you have installed cyrillic fonts.

-------
http://alkalay.net/linux/docs/font-howto/Font.html
http://www.linuxquestions.org/questi...ad.php?t=83407
http://www.linuxjunkies.org/html/Slovenian-HOWTO.html -- in Slovenian
http://www.linuxquestions.org/questi...d.php?t=356152

Cyrillic fonts for X (Cyr-RFX collection) -- google this, may be useful too
Cyrillic fonts for X (Cronyx collection) -- google this, may be useful too


http://download.fedora.redhat.com/pu...s/Fedora/RPMS/
http://download.fedora.redhat.com/pu...pdates/5/i386/
http://rpm2html.osmirror.nl/fedora/c...at,_Inc..html:

xorg-x11-fonts-cyrillic-7.0-3.noarch -- Cyrillic fonts for X.
fonts-KOI8-R-1.0-9.1.noarch -- Russian and Ukrainian language fonts for the X Window System. Fedora Core
fonts-KOI8-R-100dpi-1.0-9.1.noarch -- KOI8-R fonts in 100 dpi resolution for X
fonts-KOI8-R-75dpi-1.0-9.1.noarch -- A set of 75 dpi Russian and Ukrainian language fonts for X.

kde-i18n-Russian-3.5.5-0.1.fc5.noarch.rpm -- Russian language support for KDE (9MB)
{dependencies: kdelibs-3.5.5-0.2.fc5.i386.rpm (18MB) which has dependencies -->

arts-1.5.5-0.1.fc5.i386.rpm
qt-3.3.7-0.1.fc5.i386.rpm

}

I had to force the installation to avoid dependency errors whilst trying to install and uninstall privious versions.

rpm -ivh --force <package.rpm>

Bottom line:
After the above procedures I discovred that you can change the language of the KDE environment by a couple of means. First is to simply choose the language on the longin screen, the second is to run:

$ /usr/bin/system-config-language -- you need to log out and in again
$ /usr/bin/system-config-keyboard -- change kb. Alternatively use the kb button off the toolbar.

$ echo $LANG -- this will show u the current language settings, for Russian it was ru_RU.UTF-8

Now when u use an editor such as vim, you can type in Roman or Russian/cyrillic depending upon whether you have choosen an En or Ru kb. Frankly this will work in any language setting, what differs is for example if you try to change to options in XMMS, the menus are scrambled if not displayed in English.

Not tested if a song entitled in Russian/cyrillic displays ok in XMMS.

Last edited by peter88; 11-26-2006 at 11:08 PM.
 
Old 11-27-2006, 11:27 PM   #5
peter88
LQ Newbie
 
Registered: Nov 2006
Posts: 20

Original Poster
Rep: Reputation: 0
cyrillic, unicode fonts not displaying under FC5

Cyrillic X11 bitmap fonts from CYR-RFX project seem quite useful:
http://www.inp.nsk.su/~bolkhov/files...0index.en.html
http://www.inp.nsk.su/~bolkhov/files....en.html#S_1.1

FC5 commands and font locations as an example:

$ man -k FontPath -- to see which cmds are used to check font PATHs and info

$ chkfontpath -- see /etc/X11/fs/config for the PATH info for installed fonts

$ /usr/share/fonts/ , /usr/share/X11/fonts -- main locations for fonts under FC5, I installed the new ones uder: /usr/X11R6/lib/X11/fonts/<dir for each font set> and updated the config file to include the new paths against the Catalgue= entry/list. $ chkfontpath should now list the PATH of the new fonts. Try shifting the order the directories are specified in the config file if you have similar fonts in 2 or more locations and you want one to be used/picked up first. Reboot system or try using following commands if you want to use fonts immediately:

$ xset +fp <font dir> -- see the INSTALL.en.txt file which comes with the cyr-rfx fonts download.

$ xset fp rehash
 
Old 12-06-2006, 02:08 AM   #6
peter88
LQ Newbie
 
Registered: Nov 2006
Posts: 20

Original Poster
Rep: Reputation: 0
Ok, to summarise my problem/solution... I was saving simple text files (containing both Latin and Cyrillic fonts) under WXP using notepad and using an encoding scheme of unicode and when I took that file over the FC5 envrionment and opening with vim I was getting @@@@@@@@ filled file. The solution I found was to save the file in WXP as encoding UTF-8, now when you take it to a Linux system the Cyrillic fonts will be displayed fine providing you have the various cyrillic fonts loaded (microsoft-cp1251 or simply cp1251). There is just one querk which is that the first 6 bytes of the file are: <feff> . Does anyone have any idea why this happens?

XMMS not displaying cyrillic file names of the tracks being played... (and garbled tags). The solution to this problem is solved by choosing a cp1251 related font in the options which will turn all your XMMS menus to Russian too even if the rest of KDE is running Latin character set. The problem however is that this did not solve the problem for my version of xmms (v1.2.10) as the menus were in Russian but the tagging info still was incorrect. Further to research on the xmms site I discovered that this is not supported yet and in the next version of xmms they hope to solve this problem.

XMMS Cyrillic mini HowTo --> http://5ko.free.fr/en/xmms.html

The Winamp Cyrillic Howto --> http://5ko.free.fr/en/winamp.html -- for W32 not Linux

Last edited by peter88; 12-06-2006 at 02:13 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Cyrillic fonts broken TomaCzar Slackware 2 12-17-2005 10:54 AM
Displaying characters of secondary character set: Cyrillic mjjzf Linux - Software 2 08-11-2005 02:49 PM
cyrillic chars - unicode or koi8_ru ojav Linux - Newbie 1 05-29-2005 02:51 PM
Cyrillic fonts qrz1800 Linux - Newbie 1 02-22-2005 08:14 PM
I want to use Cyrillic (Russian) fonts! maximizer Linux - Software 10 12-26-2003 09:47 PM


All times are GMT -5. The time now is 03:06 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration