LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - General (http://www.linuxquestions.org/questions/linux-general-1/)
-   -   Custom Kernel Won't Boot!?!?1 (http://www.linuxquestions.org/questions/linux-general-1/custom-kernel-wont-boot-1-a-72055/)

martinman 07-11-2003 11:54 PM

Custom Kernel Won't Boot!?!?1
 
ARGH! I read the success story here about the guy who got his radeon to work with opengl. It sounded believeable, so i went ahead and followed step one. Recompile the kernel. I don't have to make any changes, so i didnt.

I followed the tut here
and now i have myself a wonderful little custom kernel. 2.4.20-8martinman

I go to restart, choose my kernel from the GRUB boot menu...scrolling, scrolling...BAM! a big, fat, ugly fatal error that locks up the system:

Quote:


VMS: no socket drivers defined!
then something about not being able to understand "LABEL=/"
Please define a "root=" attribute in your boot loader settings
Then something about not being able to load the root fs on 00:00

I'll post the EXACT four lines in a minute, gotta write them down this time.

Anyways, this is REALLY holding me up, as there is NO reason why it shouldn't boot. I checked my grub.conf file and the entry for my new kernel is the exact same as the others, only with different initrd .img names and such.

Here's the excerpt from my grub.cong file.
Quote:


title Red Hat Linux (2.4.20-8martinman)
root (hd1,0)
kernel /vmlinuz-2.4.20-8martinman ro root=LABEL=/ hdd=ide-scsi
initrd /initrd-2.4.20-8martinman.img


DavidPhillips 07-12-2003 01:10 AM

you could try to use root=/dev/hd?? where hd?? is the partition, like /dev/hda1 or whatever you have the filesystem on.

I would expect there are going to be other problems as well. You must correctly configure your kernel, you probably ended up using a default config file. maybe you could try using this..

make oldconfig

I can't help but wonder why we would think that if nothing needs to be changed in the config, how is it going to fix anything?


All times are GMT -5. The time now is 12:13 PM.