LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 10-07-2010, 01:38 PM   #1
marsques
Member
 
Registered: Jan 2004
Location: Manchester
Distribution: slackware...
Posts: 344

Rep: Reputation: 31
Custom kernel not booting...


Had a custom kernel (2.6.35.5) running under Slackware 12.1 and also the same kernel on an Ubuntu 10.04 machine just fine, however after a clean install of Slackware 13.1 this kernel no longer works (This kernel was re-compiled with the same .config file under Slack 13.1) as I keep getting the the following: -

Please append a correct "root=" boot option
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(8,3)

The strange thing is it keeps looking for the root file system in hda1, however the stock 13.1 kernel finds it in /dev/sda1 so the root partition is /dev/sda1 in lilo and the harddisk is known as /dev/sda.

I think I may know the problem, but not the solution!

Any help?
 
Old 10-07-2010, 02:26 PM   #2
jmc1987
Member
 
Registered: Sep 2009
Location: Oklahoma
Distribution: Debian, CentOS, windows 7
Posts: 866

Rep: Reputation: 110Reputation: 110
did you compile it with modules and then just copy the kernel to your knew machine. Don't forget to install your modules.
 
Old 10-08-2010, 09:10 AM   #3
hughetorrance
Member
 
Registered: Aug 2009
Location: London North West
Distribution: x86_64 Slack 13.37 current : +others
Posts: 459

Rep: Reputation: 59
Please append a correct "root=" boot option

It means that its not finding the root file system so you edit whatever boot manager you are using GRUB or LILO,sda1 equates to (hda,0) as usual I am guessing but sometimes my guesses are good. LOL
 
Old 10-08-2010, 02:47 PM   #4
marsques
Member
 
Registered: Jan 2004
Location: Manchester
Distribution: slackware...
Posts: 344

Original Poster
Rep: Reputation: 31
recompiled the kernel with the following unticked in the configuration yesterday and it worked

ATA/ATAPI/MFM/RLL support (DEPRECATED) (IDE)

Looks like with both this and sata enabled - it loads the IDE part first (so the root partition becomes /dev/hda1) and prevents the sata part from taking over root (so no root on /dev/sda1).
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Booting a custom kernel with a new root filesystem LinuxNewman Linux - General 10 04-19-2009 10:53 PM
Is it possible to install a custom kernel without booting to the drive? Mark_667 Linux - Kernel 6 03-22-2009 10:08 AM
kernel panic while booting custom compiled 2.6.24 kernel on RHEL 4 AS samkraju Red Hat 4 02-10-2008 12:55 AM
Booting a 2.6.12 Custom Kernel in Debian pfizur Linux - Kernel 4 07-26-2006 07:39 PM
How do I make sure Im booting onto my custom kernel? Kramer Linux - General 10 10-21-2003 12:43 PM


All times are GMT -5. The time now is 11:11 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration