-   Linux - General (
-   -   Custom kernel not booting... (

marsques 10-07-2010 02:38 PM

Custom kernel not booting...
Had a custom kernel ( running under Slackware 12.1 and also the same kernel on an Ubuntu 10.04 machine just fine, however after a clean install of Slackware 13.1 this kernel no longer works (This kernel was re-compiled with the same .config file under Slack 13.1) as I keep getting the the following: -

Please append a correct "root=" boot option
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(8,3)

The strange thing is it keeps looking for the root file system in hda1, however the stock 13.1 kernel finds it in /dev/sda1 so the root partition is /dev/sda1 in lilo and the harddisk is known as /dev/sda.

I think I may know the problem, but not the solution!

Any help?

jmc1987 10-07-2010 03:26 PM

did you compile it with modules and then just copy the kernel to your knew machine. Don't forget to install your modules.

hughetorrance 10-08-2010 10:10 AM

Please append a correct "root=" boot option

It means that its not finding the root file system so you edit whatever boot manager you are using GRUB or LILO,sda1 equates to (hda,0) as usual I am guessing but sometimes my guesses are good. LOL

marsques 10-08-2010 03:47 PM

recompiled the kernel with the following unticked in the configuration yesterday and it worked


Looks like with both this and sata enabled - it loads the IDE part first (so the root partition becomes /dev/hda1) and prevents the sata part from taking over root (so no root on /dev/sda1).

All times are GMT -5. The time now is 03:53 AM.