LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - General (http://www.linuxquestions.org/questions/linux-general-1/)
-   -   CUPS shows job sent from gLabels, but doesn't print it (http://www.linuxquestions.org/questions/linux-general-1/cups-shows-job-sent-from-glabels-but-doesnt-print-it-588337/)

CJ Chitwood 09-30-2007 02:37 AM

CUPS shows job sent from gLabels, but doesn't print it
 
Hello all,

When printing with CUPS, most programs work fine. I can print from Gimp, Iceape, and Opera, specifically. There may be a few others I can print from but have not yet tried. However, I cannot print from gLabels.

Before, I used to use gLabels to print directly on top of printable CD media. I had to reinstall my OS (Debian, Etch I think) recently, and since have been returning it to its previous glamour, yet I'm still running into snags like this.

I can log into my CUPS web interface via localhost:631 and see, among other things, my jobs. When I look at successful jobs, they have something in common. They show either "Test Page" or "(stdin)" in the "Name" column of CUPS' All Jobs view.

The ones from gLabels all say "unknown" in this column and do not print at all, even though CUPS apparently acknowledges that they were received.

FWIW, I'm using the PPD for a Hewlett-Packard Photosmart D5100 series from OpenPrinting.org. I own an HP Photosmart D5160.

I almost feel like I'm just missing some oddbal .deb package, but I've gone through Synaptic and installed everything I can think of that would appear to affect this.

Any ideas? Many thanks in advance for any help that can be provided.

CJ

CJ Chitwood 09-30-2007 08:23 AM

Whelp... Update....


It seems gLables does print, to letter-sized paper when letter-sized paper is selected in the CUPS setup... Will explore further, but the problem's not solved yet...

CJ Chitwood 09-30-2007 08:27 AM

Okay, gLabels will print as long as CUPS has the printer set up to print on 8.5x11-inch media. It refuses to print on CD loaded in the CD tray. Gimp will print to CD loaded in the CD tray, but has a classic alignment problem (that I think is due to GIMP wanting to print at 317 dpi instead of the 300 dpi I've set the image to be...


All times are GMT -5. The time now is 12:48 PM.