LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 06-24-2004, 04:05 PM   #1
Spudley
Member
 
Registered: Mar 2003
Location: Berkshire, England.
Distribution: SuSE 10.0
Posts: 299

Rep: Reputation: 32
Cron slowing down my system.


My system has a problem.

Every now and then it suddenly just grinds to a halt. Even the mouse pointer goes juddery, switching windows is a painful experience.

I've watched the process list, and it's cron that's doing the damage, which would be understandable... except that I've got no crontabs set up at all. I can't find anything that should be running, let alone slowing me down so badly. And the machine is almost brand new too - AMD2600 and 1gig memory - I wouldn't expect speed problems like I'm seeing, even with a busy crontab.

The cron process is running various programs, but the ones that seem to be slowing me down are sed and find in particular. (I don't know what it's trying to find though)

Can anyone help point me in the right direction to find out what's happening? What should I be looking at? Thanks

I'm running SuSE 9.0, by the way.
 
Old 06-24-2004, 04:29 PM   #2
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 22,974
Blog Entries: 11

Rep: Reputation: 879Reputation: 879Reputation: 879Reputation: 879Reputation: 879Reputation: 879Reputation: 879
Have a look in
/etc/cron.hourly
/etc/cron.daily
/etc/cron.weekly
/etc/cron.monthly

If you can't find anything containing find and or sed
in these directories, have a look at /var/spool/cron/crontabs/

If find makes the system behave that badly you've probably
got DMA disabled. Type
hdparm /dev/hda


Cheers,
Tink
 
Old 06-24-2004, 05:11 PM   #3
Spudley
Member
 
Registered: Mar 2003
Location: Berkshire, England.
Distribution: SuSE 10.0
Posts: 299

Original Poster
Rep: Reputation: 32
Thank you for the reply Tinkster. Very helpful

The file in cron.daily that's doing it is 'updatedb'.

But more importantly, I think you may be on the right track with that comment about the DMA. hdparm tells me that it's off, so you may well have got something there.

So the next question is how do I turn it on... and also *should* I turn it on? Are there any reasons why I shouldn't? And if not, why wasn't it already switched on (I certainly haven't turned anything off - it should be set the way Suse installed it)

Anyway, thanks for the help.
 
Old 06-24-2004, 05:13 PM   #4
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 22,974
Blog Entries: 11

Rep: Reputation: 879Reputation: 879Reputation: 879Reputation: 879Reputation: 879Reputation: 879Reputation: 879
To turn it on, try
hdpram -d 1 /dev/hda


It shouldn't be a problem with the supposedly very recent
hardware you're using, no idea why SuSE's installer would
have chosen NOT to enable it.


Cheers,
Tink
 
Old 06-24-2004, 06:00 PM   #5
Spudley
Member
 
Registered: Mar 2003
Location: Berkshire, England.
Distribution: SuSE 10.0
Posts: 299

Original Poster
Rep: Reputation: 32
Okay.

hdparm turned it on just fine, but it was back off again after a reboot.

So I tried turning it on using YaST (which is where SuSE likes us to do things), and the computer locked up.

Hmm... either that or perhaps I didn't leave it long enough to think about it?
 
Old 06-24-2004, 06:42 PM   #6
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 22,974
Blog Entries: 11

Rep: Reputation: 879Reputation: 879Reputation: 879Reputation: 879Reputation: 879Reputation: 879Reputation: 879
Sorry mate, no idea what SuSE does ... haven't used it
since 7, I'm a Slacker now ;)
If all else fails edit your `locate rc\.local` and put it in
manually.


Cheers,
Tink
 
Old 09-21-2007, 04:47 AM   #7
edubidu
Member
 
Registered: Mar 2007
Location: Switzerland
Distribution: Ubuntu
Posts: 32

Rep: Reputation: 15
Hi,

I also use suse, but 10.2.
In Yast2, go to Hardware-IDE DMA Mode-DMA On (default).
Works without rebooting.

My computer needed 5-10 min's, then it was ok. If no, reboot.

Last edited by edubidu; 09-21-2007 at 04:53 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
something is slowing my system down gaah Linux - Newbie 6 09-21-2007 04:42 AM
udev is slowing my FC2 system down yong_sa Fedora 4 12-09-2004 10:13 PM
System slowing down after a few hours?? BajaNick Linux - General 23 04-24-2004 03:02 AM
Why is my system slowing down? BajaNick Slackware 19 04-15-2004 03:41 AM
Network Card Slowing system down vdi_nenna Linux - Hardware 4 02-17-2003 01:21 PM


All times are GMT -5. The time now is 04:54 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration