LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
LinkBack Search this Thread
Old 01-11-2004, 06:34 AM   #1
wangcity
LQ Newbie
 
Registered: Dec 2002
Posts: 24

Rep: Reputation: 15
couldn't open mixer device /dev/sound/mixer


when i use swaret update 9.1 for fix a few bugs, but when finish it tell me :couldn't open mixer device /dev/sound/mixer

how can i do ?
 
Old 01-11-2004, 11:47 AM   #2
bibilit
Member
 
Registered: Nov 2002
Location: Montrouge / FRANCE
Distribution: MANDRAKE 9.2/ DSL / smalllinux / Ubuntu 5.1
Posts: 202

Rep: Reputation: 30
Try to chmod /dev/sound/mixer to 777

That may solve the problem.
 
Old 01-11-2004, 12:00 PM   #3
coolamit78
Member
 
Registered: Aug 2003
Location: New Delhi, India
Distribution: RHEL AS 3/4, Windows XP
Posts: 546

Rep: Reputation: 31
That may happen, when the module for your soundcard isnt loaded into memory.

To load the module for ur soundcard, su to root like this:

su -
password: *****

and then, enter the command

modprobe <name-for-your-soundcard-driver>

example:

modprobe sb

(where 'sb' is the name of module for the sound blaster soundcard)

I guess that will help..

Regards,

amit
 
Old 01-22-2004, 10:12 AM   #4
wangcity
LQ Newbie
 
Registered: Dec 2002
Posts: 24

Original Poster
Rep: Reputation: 15
i use this cmd:chmod +777 /dev/sound/mixer
but it's told me : no this kind of file or dir
and it's say :alsa_alias have some problem

any other way can try ?

thanks
 
Old 01-22-2004, 03:51 PM   #5
Snodge
LQ Newbie
 
Registered: Dec 2003
Posts: 6

Rep: Reputation: 0
I had this after I upgraded my kernel to 2.6 - by default the OSS drivers are not selected as they are deprecated. If you compile your own 2.6 kernel you can either tell ALSA to emulate OSS, or you can compile in the OSS drivers.

Not sure if that's what the problem is, but it might be worth looking at...
 
Old 01-23-2004, 12:50 PM   #6
wangcity
LQ Newbie
 
Registered: Dec 2002
Posts: 24

Original Poster
Rep: Reputation: 15
when i update this:
----------------------------
Tue Jan 6 15:01:54 PST 2004
patches/kernels/: Upgraded to Linux 2.4.24. This fixes a bounds-checking
problem in the kernel's mremap() call which could be used by a local attacker
to gain root privileges. Sites should upgrade to the 2.4.24 kernel and
kernel modules. After installing the new kernel, be sure to run 'lilo'.
For more details, see:
http://cve.mitre.org/cgi-bin/cvename...=CAN-2003-0985
Thanks to Paul Starzetz for finding and researching this issue.
(* Security fix *)
patches/packages/alsa-driver-0.9.8-i486-2.tgz: Recompiled against
linux-2.4.24.
patches/packages/cvs-1.11.11-i486-1.tgz: Upgraded to cvs-1.11.11.
This version enforces greater security. Changes include pserver
refusing to run as root, and logging attempts to exploit the security
hole fixed in 1.11.10 in the syslog.
patches/packages/kernel-ide-2.4.24-i486-1.tgz: Upgraded bare.i kernel
package to Linux 2.4.24.
patches/packages/kernel-modules-2.4.24-i486-1.tgz: Upgraded to Linux
2.4.24 kernel modules.
patches/packages/kernel-source-2.4.24-noarch-2.tgz: Upgraded to Linux
2.4.24 kernel source, with XFS and Speakup patches included (but not
pre-applied). This uses the XFS and Speakup patches for 2.4.23, which
should be fine since 2.4.24 didn't change much code. Proper XFS
patches for 2.4.24 will probably be out soon to fix the one Makefile
rejection for EXTRAVERSION = -xfs, but likely little else will be
different since XFS development has already gone ahead to what is now
the 2.4.25-pre kernel series.
patches/packages/kernel-modules-xfs/alsa-driver-xfs-0.9.8-i486-2.tgz:
Recompiled against linux-2.4.24-xfs.
patches/packages/kernel-modules-xfs/kernel-modules-xfs-2.4.24-i486-1.tgz:
Upgraded to Linux 2.4.24 kernel modules for the xfs.s (XFS patched)
kernel.

------------------------------
i find no sound !
maybe should i compile kernel ?
 
Old 01-24-2004, 05:01 AM   #7
wangcity
LQ Newbie
 
Registered: Dec 2002
Posts: 24

Original Poster
Rep: Reputation: 15
and i use floppy disk to boot my system
 
Old 01-24-2004, 06:19 PM   #8
mary
Member
 
Registered: Sep 2003
Distribution: Gentoo
Posts: 135

Rep: Reputation: 15
Well, this may not be of any help to you, but yesterday I ran swaret. It upgraded alsa, and a few other packages. When I restarted the next time, KDE complained that /dev/dsp couldn't be opened. I think Gnome complained about /dev/sound/mixer being missing, when I booted into Gnome to see if that would help the problem.

I uninstalled the new alsa packages swaret installed, reinstalled the old, rebooted, and all is well now. I am not sure how to get the new ones working.

Btw, this happened to me a couple weeks ago as well, and I'm fairly certain I ran swaret that day. I gave up and reinstalled last time. But this time I managed to get it working again.

Mary
 
Old 02-01-2004, 07:17 AM   #9
wangcity
LQ Newbie
 
Registered: Dec 2002
Posts: 24

Original Poster
Rep: Reputation: 15
i download alsa form it's website and install it again by my hand--follow the install doc, it's work again.

i think it's the swaret's problem.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Couldn't open mixer device /dev/sound/mixer laurentwahl Linux - General 8 05-17-2005 08:15 PM
couldn't open mixer device /dev/sound/mixer pitts68 Linux - Newbie 4 11-15-2004 08:03 AM
Couldn't open mixer device /dev/sound/mixer arctic123 Linux - Newbie 4 09-22-2004 09:39 AM
Sound issue - "Couldn't open mixer device /dev/sound/mixer" zsejk Slackware 17 08-14-2003 10:20 PM
Couldn't open mixer device /dev/sound/mixer Dabria Linux - Hardware 2 07-29-2003 11:50 AM


All times are GMT -5. The time now is 12:46 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration